asusctl/debian/rules
Ward from fusion-voyager-3 fe761b97e0 fix cargo build opts
2024-07-26 22:34:33 +03:00

13 lines
274 B
Makefile
Executable File

#!/usr/bin/make -f
export PIKA_BUILD_ARCH = $(shell cat ../pika-build-arch)
override_dh_prep:
# amd64 build prep
ifeq (amd64-v3,$(PIKA_BUILD_ARCH))
export RUSTFLAGS = -C target-cpu=x86-64-v3 -C opt-level=3 -C lto=fat -C embed-bitcode -C codegen-units=1
endif
%:
dh ${@}