71 lines
2.2 KiB
Diff
71 lines
2.2 KiB
Diff
From: =?utf-8?b?Ik1hcmNvIFRyZXZpc2FuIChUcmV2acOxbyki?= <mail@3v1n0.net>
|
|
Date: Tue, 20 Feb 2024 08:22:42 +0100
|
|
Subject: build: Look for sh just once
|
|
|
|
Origin: https://gitlab.freedesktop.org/libfprint/libfprint/commit/4b72f27d
|
|
Forwarded: yes
|
|
---
|
|
meson.build | 1 +
|
|
tests/meson.build | 10 +++++-----
|
|
2 files changed, 6 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index 435827c..28ee27a 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -91,6 +91,7 @@ gusb_dep = dependency('gusb', version: '>= 0.2.0')
|
|
mathlib_dep = cc.find_library('m', required: false)
|
|
|
|
# The following dependencies are only used for tests
|
|
+sh = find_program('sh', required: true)
|
|
cairo_dep = dependency('cairo', required: false)
|
|
|
|
# introspection scanning and Gio-2.0.gir
|
|
diff --git a/tests/meson.build b/tests/meson.build
|
|
index f68ed40..8c8f5d0 100644
|
|
--- a/tests/meson.build
|
|
+++ b/tests/meson.build
|
|
@@ -151,7 +151,7 @@ if get_option('introspection')
|
|
endif
|
|
else
|
|
test(vdtest,
|
|
- find_program('sh'),
|
|
+ sh,
|
|
args: ['-c', 'exit 77']
|
|
)
|
|
endif
|
|
@@ -205,7 +205,7 @@ if get_option('introspection')
|
|
endif
|
|
else
|
|
test(driver_test,
|
|
- find_program('sh'),
|
|
+ sh,
|
|
args: ['-c', 'exit 77']
|
|
)
|
|
endif
|
|
@@ -224,13 +224,13 @@ if get_option('introspection')
|
|
else
|
|
warning('Skipping all driver tests as introspection bindings are missing')
|
|
test('virtual-image',
|
|
- find_program('sh'),
|
|
+ sh,
|
|
args: ['-c', 'exit 77']
|
|
)
|
|
|
|
foreach driver_test: drivers_tests
|
|
test(driver_test,
|
|
- find_program('sh'),
|
|
+ sh,
|
|
args: ['-c', 'exit 77']
|
|
)
|
|
endforeach
|
|
@@ -273,7 +273,7 @@ foreach test_name: unit_tests
|
|
# Create a dummy test that always skips instead
|
|
warning('Test @0@ cannot be compiled due to missing dependencies'.format(test_name))
|
|
test(test_name,
|
|
- find_program('sh'),
|
|
+ sh,
|
|
suite: ['unit-tests'],
|
|
args: ['-c', 'exit 77'],
|
|
)
|