first commit

This commit is contained in:
Ward Nakchbandi 2023-03-04 16:52:44 +03:00
parent 0c601d908c
commit d60ade38ec
14 changed files with 83 additions and 30 deletions

40
.github/workflows/release.yml vendored Normal file
View File

@ -0,0 +1,40 @@
name: PikaOS Package Release
on:
workflow_dispatch
jobs:
build:
runs-on: self-hosted
container:
image: ubuntu:22.10
volumes:
- /proc:/proc
options: --privileged -it
steps:
- uses: actions/checkout@v3
- name: Install needed packages
run: apt update && apt install software-properties-common sudo git bc gpg gpg-agent bison build-essential ccache cpio fakeroot flex git kmod libelf-dev libncurses5-dev libssl-dev lz4 qtbase5-dev rsync schedtool wget zstd tar reprepro dpkg-sig devscripts dh-make -y
- name: Import GPG key
id: import_gpg
uses: crazy-max/ghaction-import-gpg@v5
with:
gpg_private_key: ${{ secrets.GPG_PRIVATE_KEY }}
passphrase: ${{ secrets.PASSPHRASE }}
- name: Install SSH key
uses: shimataro/ssh-key-action@v2
with:
key: ${{ secrets.SSH_KEY }}
name: id_rsa
known_hosts: ${{ secrets.KNOWN_HOSTS }}
if_key_exists: replace
- name: Build Package
run: ./main.sh
- name: Release Package
run: ./release.sh

View File

@ -1 +0,0 @@
make sure dh_clean isn't ran to avoid deletion of vendor

View File

@ -1,3 +1,9 @@
supergfxctl (5.0.1-99pika5) kinetic; urgency=low
* New Upstream Update
-- Ward Nakchbandi <hotrod.master@hotmail.com> Sat, 01 Oct 2022 14:50:00 +0200
supergfxctl (4.0.5-99pika5) kinetic; urgency=low
* Try To fix offline rust fetching

4
debian/rules vendored Executable file
View File

@ -0,0 +1,4 @@
#!/usr/bin/make -f
%:
dh $@

1
debian/source/format vendored Normal file
View File

@ -0,0 +1 @@
3.0 (native)

21
main.sh Executable file
View File

@ -0,0 +1,21 @@
# Add dependent repositories
wget -q -O - https://ppa.pika-os.com/key.gpg | sudo apt-key add -
add-apt-repository https://ppa.pika-os.com
add-apt-repository ppa:pikaos/pika
add-apt-repository ppa:kubuntu-ppa/backports
# Clone Upstream
git clone https://gitlab.com/asus-linux/supergfxctl -b 5.0.1
cp -rvf ./debian ./supergfxctl
cd ./supergfxctl
# Get build deps
apt-get build-dep ./ -y
# Build package
LOGNAME=root dh_make --createorig -y -l -p supergfxctl_5.0.1
dpkg-buildpackage
# Move the debs to output
cd ../
mkdir -p ./output
mv ./*.deb ./output/

11
release.sh Executable file
View File

@ -0,0 +1,11 @@
# Sign the packages
dpkg-sig --sign builder ./output/*.deb
# Pull down existing ppa repo db files etc
rsync -azP --exclude '*.deb' ferreo@direct.pika-os.com:/srv/www/pikappa/ ./output/repo
# Add the new package to the repo
reprepro -V --basedir ./output/repo/ includedeb kinetic ./output/*.deb
# Push the updated ppa repo to the server
rsync -azP ./output/repo/ ferreo@direct.pika-os.com:/srv/www/pikappa/

View File

@ -1,14 +0,0 @@
diff -ruN a/Makefile b/Makefile
--- a/Makefile 2022-06-21 00:48:22.000000000 +0300
+++ b/Makefile 2022-10-22 11:32:46.293542591 +0300
@@ -70,10 +70,8 @@
rm -rf vendor
build:
-ifeq ($(VENDORED),1)
@echo "version = $(VERSION)"
tar pxf vendor-$(VERSION).tar.xz
-endif
cargo build --features "daemon cli" $(ARGS)
strip -s ./target/release/$(BIN_SD)
strip -s ./target/release/$(BIN_SC)

View File

@ -1 +0,0 @@
make_build_always_vendered.patch

View File

@ -1,13 +0,0 @@
#!/usr/bin/make -f
CARGO_HOME=$(CURDIR)/.cargo
%:
dh $@ --with-quilt
override_dh_clean:
echo "dh_clean disabled!"
override_dh_auto_clean:
echo "dh_auto_clean disabled!"

View File

@ -1 +0,0 @@
3.0 (quilt)