first commit

This commit is contained in:
Ward 2023-02-23 22:01:39 +02:00
commit ad86e17628
13 changed files with 148 additions and 0 deletions

View File

@ -0,0 +1,11 @@
gamescope-session (0.0.git.92.60c3f5f9-99pika2) kinetic; urgency=low
* Fix return to desktop
-- Ward Nakchbandi <hotrod.master@hotmail.com> Sat, 01 Oct 2022 14:50:00 +0200
gamescope-session (0.0.git.92.60c3f5f9-99pika1) kinetic; urgency=low
* Initial Creation
-- Ward Nakchbandi <hotrod.master@hotmail.com> Sat, 01 Oct 2022 14:50:00 +0200

View File

@ -0,0 +1,15 @@
Source: gamescope-session
Section: games
Priority: optional
Maintainer: Ward Nakchbandi <hotrod.master@hotmail.com>
Build-Depends: debhelper-compat (= 13)
Standards-Version: 4.6.1
Homepage: https://github.com/KyleGospo/gamescope-session
Package: gamescope-session
Section: games
Architecture: all
Depends: ${misc:Depends}, gamescope, python3
Multi-Arch: foreign
Description: Steam Big Picture Mode/Gamemode session based on gamescope

View File

@ -0,0 +1,15 @@
DO WHAT THE FUCK YOU WANT TO PUBLIC LICENSE
Version 2, December 2004
Copyright (C) 2020-2022 Jaoquín I. Aramendía <samsagax@gmail.com>
Everyone is permitted to copy and distribute verbatim or modified
copies of this license document, and changing it is allowed as long
as the name is changed.
DO WHAT THE FUCK YOU WANT TO PUBLIC LICENSE
TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
0. You just DO WHAT THE FUCK YOU WANT TO.

View File

@ -0,0 +1,8 @@
#!/bin/bash
set -e
die() { echo >&2 "!! $*"; exit 1; }
systemctl --user stop gamescope-session.service

View File

@ -0,0 +1 @@
gamescope-session_0.0.git.92.60c3f5f9-99pika2_source.buildinfo games optional

View File

@ -0,0 +1,2 @@
usr
debian/extras/steamos-session-select usr/bin/

View File

@ -0,0 +1,24 @@
From 55e7d0c200f21d6d0d4b858b8ca8a42a2558426d Mon Sep 17 00:00:00 2001
From: GloriousEggroll <gloriouseggroll@gmail.com>
Date: Wed, 11 Jan 2023 10:13:04 -0700
Subject: [PATCH] change wayland session name to something distro-agnostic
---
usr/share/wayland-sessions/gamescope-session.desktop | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/usr/share/wayland-sessions/gamescope-session.desktop b/usr/share/wayland-sessions/gamescope-session.desktop
index a6c1746..ee48bfa 100644
--- a/usr/share/wayland-sessions/gamescope-session.desktop
+++ b/usr/share/wayland-sessions/gamescope-session.desktop
@@ -1,6 +1,6 @@
[Desktop Entry]
Encoding=UTF-8
-Name=ChimeraOS (gamescope)
+Name=Steam Deck Mode
Comment=Steam Big Picture session
Exec=gamescope-session
Type=Application
--
2.39.0

View File

@ -0,0 +1,54 @@
From 9611d3d68b659a1328836f77fc209eb6db534320 Mon Sep 17 00:00:00 2001
From: GloriousEggroll <gloriouseggroll@gmail.com>
Date: Wed, 11 Jan 2023 10:08:19 -0700
Subject: [PATCH] update to work on nobara with hdr
---
usr/share/gamescope-session/gamescope-session-script | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)
diff --git a/usr/share/gamescope-session/gamescope-session-script b/usr/share/gamescope-session/gamescope-session-script
index fddf7a2..bdba432 100755
--- a/usr/share/gamescope-session/gamescope-session-script
+++ b/usr/share/gamescope-session/gamescope-session-script
@@ -1,4 +1,7 @@
-#!/bin/bash
+#!/usr/bin/bash
+
+export ENABLE_GAMESCOPE_WSI=1
+export DXVK_HDR=1
# Some environment variables by default (taken from Deck session)
export SDL_VIDEO_MINIMIZE_ON_FOCUS_LOSS=0
@@ -154,7 +157,7 @@ fi
# Define session if not overriden
if [ -z "$STEAMCMD" ] ; then
- STEAMCMD="steam -gamepadui -steamos3 -steampal -steamdeck"
+ STEAMCMD="steam -gamepadui -newbigpicture -steamdeck -steamos3"
fi
if [ -z "$GAMESCOPECMD" ] ; then
@@ -164,6 +167,7 @@ if [ -z "$GAMESCOPECMD" ] ; then
fi
GAMESCOPECMD="/usr/bin/gamescope \
$CURSOR \
+ --hdr-enabled \
-e \
$RESOLUTION \
--xwayland-count 2 \
--
2.39.0
diff --git a/usr/share/gamescope-session/gamescope-session-script b/usr/share/gamescope-session/gamescope-session-script
index bdba432..68ff633 100755
--- a/usr/share/gamescope-session/gamescope-session-script
+++ b/usr/share/gamescope-session/gamescope-session-script
@@ -168,6 +168,7 @@ if [ -z "$GAMESCOPECMD" ] ; then
GAMESCOPECMD="/usr/bin/gamescope \
$CURSOR \
--hdr-enabled \
+ --hdr-itm-enable \
-e \
$RESOLUTION \
--xwayland-count 2 \

View File

@ -0,0 +1,9 @@
diff -ur a/usr/bin/steam-http-loader b/usr/bin/steam-http-loader
--- a/usr/bin/steam-http-loader 2023-01-03 13:25:18.155825373 -0800
+++ b/usr/bin/steam-http-loader 2023-01-03 13:29:58.125988565 -0800
@@ -1,4 +1,4 @@
-#!/bin/env python
+#!/bin/env python3
import urllib.parse
import os.path
import argparse

View File

@ -0,0 +1,4 @@
fedora.patch
0001-update-to-work-on-nobara-with-hdr.patch
0001-change-wayland-session-name-to-something-distro-agno.patch

3
gamescope-session/debian/rules Executable file
View File

@ -0,0 +1,3 @@
#!/usr/bin/make -f
%:
dh $@

View File

@ -0,0 +1 @@
3.0 (quilt)

1
orig.source.txt Normal file
View File

@ -0,0 +1 @@
#https://github.com/KyleGospo/gamescope-session