Update packging to new repo

This commit is contained in:
Ward Nakchbandi (Cosmic Fusion) 2023-07-15 15:01:42 +03:00 committed by GitHub
parent 72c416a0c7
commit d8b02e9f63
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
4 changed files with 4 additions and 59 deletions

2
debian/changelog vendored
View File

@ -1,4 +1,4 @@
gamescope-session (0.1-99pika3-lunar) lunar; urgency=low
gamescope-session (0.2-99pika1-lunar) lunar; urgency=low
* Initial Creation

3
debian/control vendored
View File

@ -9,7 +9,6 @@ Homepage: https://github.com/KyleGospo/gamescope-session
Package: gamescope-session
Section: games
Architecture: all
Depends: ${misc:Depends}, gamescope, python3
Multi-Arch: foreign
Depends: ${misc:Depends}, gamescope, python3, mangoapp, ryzenadj, steamdeck-jupiter-driver-btrfs | steamdeck-jupiter-driver
Description: Steam Big Picture Mode/Gamemode session based on gamescope

View File

@ -1,17 +1,15 @@
DEBIAN_FRONTEND=noninteractive
# Clone Upstream
git clone https://github.com/KyleGospo/gamescope-session
git clone https://github.com/PikaOS-linux/gamescope-session
cp -rvf ./debian ./gamescope-session
cd ./gamescope-session
patch -Np1 -i ./fedora.patch
patch -Np1 -i ../patches/0001-update-to-work-on-nobara-with-hdr.patch
# Get build deps
apt-get build-dep ./ -y
# Build package
dpkg-buildpackage
dpkg-buildpackage --no-sign
# Move the debs to output
cd ../

View File

@ -1,52 +0,0 @@
From 9611d3d68b659a1328836f77fc209eb6db534320 Mon Sep 17 00:00:00 2001
From: GloriousEggroll <gloriouseggroll@gmail.com>
Date: Wed, 11 Jan 2023 10:08:19 -0700
Subject: [PATCH] update to work on nobara with hdr
---
usr/share/gamescope-session/gamescope-session-script | 9 +++++++--
1 file changed, 7 insertions(+), 2 deletions(-)
diff --git a/usr/share/gamescope-session/gamescope-session-script b/usr/share/gamescope-session/gamescope-session-script
index 5c99641..7f3982a 100755
--- a/usr/share/gamescope-session/gamescope-session-script
+++ b/usr/share/gamescope-session/gamescope-session-script
@@ -7,6 +7,13 @@
export INTEL_DEBUG=norbc
export mesa_glthread=true
+# Set Gamescope args
+export GAMESCOPE_EXTRA_LAUNCH_ARGS='--hdr-enabled --hdr-itm-enable'
+export GAMESCOPE_BASE_LAUNCH_ARGS='--xwayland-count 2 -O *,eDP-1 --default-touch-mode 4 --hide-cursor-delay 3000 --fade-out-duration 200':$GAMESCOPE_EXTRA_LAUNCH_ARGS
+
+export ENABLE_GAMESCOPE_WSI=1
+export DXVK_HDR=1
+
# Some environment variables by default (taken from Deck session)
export SDL_VIDEO_MINIMIZE_ON_FOCUS_LOSS=0
@@ -184,22 +191,14 @@
$CURSOR \
-e \
$RESOLUTION \
- --xwayland-count 2 \
- -O *,eDP-1 \
- --default-touch-mode 4 \
- --hide-cursor-delay 3000 \
- --fade-out-duration 200 \
+ $GAMESCOPE_EXTRA_LAUNCH_ARGS \
-R $socket -T $stats"
else
GAMESCOPECMD="/usr/bin/gamescope \
$CURSOR \
-e \
$RESOLUTION \
- --xwayland-count 2 \
- -O *,eDP-1 \
- --default-touch-mode 4 \
- --hide-cursor-delay 3000 \
- --fade-out-duration 200 \
+ $GAMESCOPE_EXTRA_LAUNCH_ARGS \
--prefer-vk-device $VULKAN_ADAPTER \
-R $socket -T $stats"
fi