Sync with nobara
This commit is contained in:
parent
0d145e34ad
commit
cee1597380
2
debian/changelog
vendored
2
debian/changelog
vendored
@ -1,4 +1,4 @@
|
|||||||
steamdeck-jupiter-driver (20221213.1-99pika3-lunar) lunar; urgency=low
|
steamdeck-jupiter-driver (20221213.1-99pika4-lunar) lunar; urgency=low
|
||||||
|
|
||||||
* Initial Creation
|
* Initial Creation
|
||||||
|
|
||||||
|
2
main.sh
2
main.sh
@ -6,7 +6,7 @@ DEBIAN_FRONTEND=noninteractive
|
|||||||
git clone https://github.com/KyleGospo/jupiter-fan-control
|
git clone https://github.com/KyleGospo/jupiter-fan-control
|
||||||
git clone https://github.com/KyleGospo/jupiter-hw-support
|
git clone https://github.com/KyleGospo/jupiter-hw-support
|
||||||
mkdir -p ./steamdeck-jupiter-driver
|
mkdir -p ./steamdeck-jupiter-driver
|
||||||
cp -rvf ./jupiter-hw-support/usr ./jupiter-fan-control
|
cp -rvf ./jupiter-fan-control/usr ./steamdeck-jupiter-driver
|
||||||
cp -rvf ./jupiter-hw-support/etc ./steamdeck-jupiter-driver
|
cp -rvf ./jupiter-hw-support/etc ./steamdeck-jupiter-driver
|
||||||
cp -rvf ./jupiter-hw-support/usr ./steamdeck-jupiter-driver
|
cp -rvf ./jupiter-hw-support/usr ./steamdeck-jupiter-driver
|
||||||
cp -rvf ./debian ./steamdeck-jupiter-driver
|
cp -rvf ./debian ./steamdeck-jupiter-driver
|
||||||
|
@ -5,3 +5,23 @@ index 1a46251..cbf7857 100755
|
|||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
-#!/usr/bin/python
|
-#!/usr/bin/python
|
||||||
+#!/bin/env python3 -u
|
+#!/bin/env python3 -u
|
||||||
|
|
||||||
|
diff -ur a/usr/share/jupiter-fan-control/fancontrol.py b/usr/share/jupiter-fan-control/fancontrol.py
|
||||||
|
--- a/usr/share/jupiter-fan-control/fancontrol.py 2022-12-23 13:14:48.861887067 -0800
|
||||||
|
+++ b/usr/share/jupiter-fan-control/fancontrol.py 2022-12-23 00:42:03.223412367 -0800
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/bin/python -u
|
||||||
|
+#!/bin/env python3 -u
|
||||||
|
"""jupiter-fan-controller"""
|
||||||
|
import signal
|
||||||
|
import os
|
||||||
|
|
||||||
|
diff -ur a/usr/share/jupiter-fan-control/PID.py b/usr/share/jupiter-fan-control/PID.py
|
||||||
|
--- a/usr/share/jupiter-fan-control/PID.py 2022-12-23 13:14:48.861887067 -0800
|
||||||
|
+++ b/usr/share/jupiter-fan-control/PID.py 2022-12-23 00:42:03.222412347 -0800
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/bin/python
|
||||||
|
+#!/bin/env python3
|
||||||
|
#
|
||||||
|
# This file is part of IvPID.
|
||||||
|
# Copyright (C) 2015 Ivmech Mechatronics Ltd. <bilgi@ivmech.com>
|
||||||
|
Loading…
Reference in New Issue
Block a user