port to pika os 4
Some checks failed
PikaOS Package Build Only (Canary) (amd64-v3) / build (push) Successful in 9s
PikaOS Package Build Only (amd64-v3) / build (push) Failing after 0s
PikaOS Package Build & Release (Canary) (amd64-v3) / build (push) Successful in 10s
PikaOS Package Build & Release (amd64-v3) / build (push) Failing after 1s
Some checks failed
PikaOS Package Build Only (Canary) (amd64-v3) / build (push) Successful in 9s
PikaOS Package Build Only (amd64-v3) / build (push) Failing after 0s
PikaOS Package Build & Release (Canary) (amd64-v3) / build (push) Successful in 10s
PikaOS Package Build & Release (amd64-v3) / build (push) Failing after 1s
This commit is contained in:
parent
7d119cf6bc
commit
fd1410c8aa
1
.github/build-canary-v3
vendored
Normal file
1
.github/build-canary-v3
vendored
Normal file
@ -0,0 +1 @@
|
||||
1
|
1
.github/build-nest-v3
vendored
Normal file
1
.github/build-nest-v3
vendored
Normal file
@ -0,0 +1 @@
|
||||
1
|
1
.github/release-canary-v3
vendored
Normal file
1
.github/release-canary-v3
vendored
Normal file
@ -0,0 +1 @@
|
||||
3
|
1
.github/release-nest-v3
vendored
Normal file
1
.github/release-nest-v3
vendored
Normal file
@ -0,0 +1 @@
|
||||
1
|
37
.github/workflows/build-canaryv3.yml
vendored
Normal file
37
.github/workflows/build-canaryv3.yml
vendored
Normal file
@ -0,0 +1,37 @@
|
||||
name: PikaOS Package Build Only (Canary) (amd64-v3)
|
||||
|
||||
on:
|
||||
push:
|
||||
branches:
|
||||
- main
|
||||
paths:
|
||||
- '.github/build-canary-v3'
|
||||
|
||||
jobs:
|
||||
build:
|
||||
runs-on: ubuntu-latest
|
||||
container:
|
||||
image: ghcr.io/pikaos-linux/pikaos-builder:canaryv3
|
||||
volumes:
|
||||
- /proc:/proc
|
||||
options: --privileged -it
|
||||
|
||||
steps:
|
||||
- uses: actions/checkout@v3
|
||||
|
||||
- name: Install SSH key
|
||||
uses: shimataro/ssh-key-action@v2
|
||||
with:
|
||||
key: ${{ secrets.SSH_KEY }}
|
||||
name: id_rsa
|
||||
known_hosts: ${{ secrets.KNOWN_HOSTS }}
|
||||
if_key_exists: replace
|
||||
|
||||
- name: Update APT Cache
|
||||
run: apt-get update -y
|
||||
|
||||
- name: Set Build Config
|
||||
run: cp -vf ./pika-build-config/amd64-v3.sh ./pika-build-config.sh
|
||||
|
||||
- name: Build Package
|
||||
run: ./main.sh
|
37
.github/workflows/build-nestv3.yml
vendored
Normal file
37
.github/workflows/build-nestv3.yml
vendored
Normal file
@ -0,0 +1,37 @@
|
||||
name: PikaOS Package Build Only (amd64-v3)
|
||||
|
||||
on:
|
||||
push:
|
||||
branches:
|
||||
- main
|
||||
paths:
|
||||
- '.github/build-nest-v3'
|
||||
|
||||
jobs:
|
||||
build:
|
||||
runs-on: ubuntu-latest
|
||||
container:
|
||||
image: ghcr.io/pikaos-linux/pikaos-builder:nestv3
|
||||
volumes:
|
||||
- /proc:/proc
|
||||
options: --privileged -it
|
||||
|
||||
steps:
|
||||
- uses: actions/checkout@v3
|
||||
|
||||
- name: Install SSH key
|
||||
uses: shimataro/ssh-key-action@v2
|
||||
with:
|
||||
key: ${{ secrets.SSH_KEY }}
|
||||
name: id_rsa
|
||||
known_hosts: ${{ secrets.KNOWN_HOSTS }}
|
||||
if_key_exists: replace
|
||||
|
||||
- name: Update APT Cache
|
||||
run: apt-get update -y
|
||||
|
||||
- name: Set Build Config
|
||||
run: cp -vf ./pika-build-config/amd64-v3.sh ./pika-build-config.sh
|
||||
|
||||
- name: Build Package
|
||||
run: ./main.sh
|
40
.github/workflows/release-canaryv3.yml
vendored
Normal file
40
.github/workflows/release-canaryv3.yml
vendored
Normal file
@ -0,0 +1,40 @@
|
||||
name: PikaOS Package Build & Release (Canary) (amd64-v3)
|
||||
|
||||
on:
|
||||
push:
|
||||
branches:
|
||||
- main
|
||||
paths:
|
||||
- '.github/release-canary-v3'
|
||||
|
||||
jobs:
|
||||
build:
|
||||
runs-on: ubuntu-latest
|
||||
container:
|
||||
image: ghcr.io/pikaos-linux/pikaos-builder:canaryv3
|
||||
volumes:
|
||||
- /proc:/proc
|
||||
options: --privileged -it
|
||||
|
||||
steps:
|
||||
- uses: actions/checkout@v3
|
||||
|
||||
- name: Install SSH key
|
||||
uses: shimataro/ssh-key-action@v2
|
||||
with:
|
||||
key: ${{ secrets.SSH_KEY }}
|
||||
name: id_rsa
|
||||
known_hosts: ${{ secrets.KNOWN_HOSTS }}
|
||||
if_key_exists: replace
|
||||
|
||||
- name: Update APT Cache
|
||||
run: apt-get update -y
|
||||
|
||||
- name: Set Build Config
|
||||
run: cp -vf ./pika-build-config/amd64-v3.sh ./pika-build-config.sh
|
||||
|
||||
- name: Build Package
|
||||
run: ./main.sh
|
||||
|
||||
- name: Release Package
|
||||
run: ./release.sh
|
40
.github/workflows/release-nestv3.yml
vendored
Normal file
40
.github/workflows/release-nestv3.yml
vendored
Normal file
@ -0,0 +1,40 @@
|
||||
name: PikaOS Package Build & Release (amd64-v3)
|
||||
|
||||
on:
|
||||
push:
|
||||
branches:
|
||||
- main
|
||||
paths:
|
||||
- '.github/release-nest-v3'
|
||||
|
||||
jobs:
|
||||
build:
|
||||
runs-on: ubuntu-latest
|
||||
container:
|
||||
image: ghcr.io/pikaos-linux/pikaos-builder:nestv3
|
||||
volumes:
|
||||
- /proc:/proc
|
||||
options: --privileged -it
|
||||
|
||||
steps:
|
||||
- uses: actions/checkout@v3
|
||||
|
||||
- name: Install SSH key
|
||||
uses: shimataro/ssh-key-action@v2
|
||||
with:
|
||||
key: ${{ secrets.SSH_KEY }}
|
||||
name: id_rsa
|
||||
known_hosts: ${{ secrets.KNOWN_HOSTS }}
|
||||
if_key_exists: replace
|
||||
|
||||
- name: Update APT Cache
|
||||
run: apt-get update -y
|
||||
|
||||
- name: Set Build Config
|
||||
run: cp -vf ./pika-build-config/amd64-v3.sh ./pika-build-config.sh
|
||||
|
||||
- name: Build Package
|
||||
run: ./main.sh
|
||||
|
||||
- name: Release Package
|
||||
run: ./release.sh
|
46
.github/workflows/release.yml
vendored
46
.github/workflows/release.yml
vendored
@ -1,46 +0,0 @@
|
||||
name: PikaOS Package Release
|
||||
|
||||
on:
|
||||
workflow_dispatch
|
||||
|
||||
jobs:
|
||||
build:
|
||||
runs-on: self-hosted
|
||||
container:
|
||||
image: ghcr.io/pikaos-linux/pika-package-container:latest
|
||||
volumes:
|
||||
- /proc:/proc
|
||||
options: --privileged -it
|
||||
|
||||
steps:
|
||||
- uses: actions/checkout@v3
|
||||
|
||||
- name: Import GPG key
|
||||
id: import_gpg
|
||||
uses: crazy-max/ghaction-import-gpg@v5
|
||||
with:
|
||||
gpg_private_key: ${{ secrets.GPG_PRIVATE_KEY }}
|
||||
passphrase: ${{ secrets.PASSPHRASE }}
|
||||
|
||||
- name: Install SSH key
|
||||
uses: shimataro/ssh-key-action@v2
|
||||
with:
|
||||
key: ${{ secrets.SSH_KEY }}
|
||||
name: id_rsa
|
||||
known_hosts: ${{ secrets.KNOWN_HOSTS }}
|
||||
if_key_exists: replace
|
||||
|
||||
- name: Build Package
|
||||
run: ./main.sh
|
||||
|
||||
- name: Release Package
|
||||
run: ./release.sh
|
||||
|
||||
- name: Purge cache
|
||||
uses: strrife/cloudflare-chunked-purge-action@master
|
||||
env:
|
||||
# Zone is required by both authentication methods
|
||||
CLOUDFLARE_ZONE: ${{ secrets.CLOUDFLARE_ZONE }}
|
||||
|
||||
CLOUDFLARE_TOKEN: ${{ secrets.CLOUDFLARE_TOKEN }}
|
||||
PURGE_URLS: ${{ vars.PURGE_URLS }}
|
24
LICENSE.md
Normal file
24
LICENSE.md
Normal file
@ -0,0 +1,24 @@
|
||||
MIT License (With DPKG packaging compatibility)
|
||||
|
||||
Copyright (c) 2024 PikaOS
|
||||
|
||||
Permission is hereby granted, free of charge, to any person obtaining a copy
|
||||
of this software and associated documentation files (the "Software"), to deal
|
||||
in the Software without restriction, including without limitation the rights
|
||||
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
|
||||
copies of the Software, and to permit persons to whom the Software is
|
||||
furnished to do so, subject to the following conditions:
|
||||
|
||||
The above copyright notice and this permission notice shall be included in all
|
||||
copies or substantial portions of the Software.
|
||||
|
||||
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
|
||||
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
|
||||
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
|
||||
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
|
||||
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
|
||||
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
|
||||
SOFTWARE.
|
||||
|
||||
Notes:
|
||||
The files covered by this license are any files and directories in the root of this repository (including but not limited to: `main.sh`, `release.sh`, and `.github`), with the exception of the `debian` directory and its contents if `debian/copyright` exists, and declares any files or directories as a different LICENSE/COPYRIGHT.
|
1
debian/files
vendored
1
debian/files
vendored
@ -1 +0,0 @@
|
||||
xone-dkms_0.3-6_source.buildinfo games optional
|
1
debian/source/format
vendored
1
debian/source/format
vendored
@ -1 +0,0 @@
|
||||
3.0 (native)
|
18
main.sh
18
main.sh
@ -1,17 +1,23 @@
|
||||
#! /bin/bash
|
||||
|
||||
# Clone Upstream
|
||||
git clone https://github.com/medusalix/xone
|
||||
cp -rvf ./debian ./xone
|
||||
cd ./xone
|
||||
set -e
|
||||
|
||||
for i in ../patches/* ; do patch -Np1 -i $i; done
|
||||
VERSION="0.3.git"
|
||||
|
||||
source ./pika-build-config.sh
|
||||
|
||||
echo "$PIKA_BUILD_ARCH" > pika-build-arch
|
||||
|
||||
# Clone Upstream
|
||||
cd ./xone-debian
|
||||
#git clone https://github.com/medusalix/xone -b v"$VERSION"
|
||||
git clone https://github.com/medusalix/xone
|
||||
|
||||
# Get build deps
|
||||
apt-get install dh-make -y
|
||||
apt-get build-dep ./ -y
|
||||
|
||||
# Build package
|
||||
LOGNAME=root dh_make --createorig -y -l -p xone_"$VERSION" || echo "dh-make: Ignoring Last Error"
|
||||
dpkg-buildpackage --no-sign
|
||||
|
||||
# Move the debs to output
|
||||
|
@ -1 +0,0 @@
|
||||
xone-package-adapt.patch
|
@ -1,35 +0,0 @@
|
||||
diff -uraN a/Makefile b/Makefile
|
||||
--- a/Makefile 1970-01-01 02:00:00.000000000 +0200
|
||||
+++ b/Makefile 2022-10-04 19:12:45.651268524 +0300
|
||||
@@ -0,0 +1,20 @@
|
||||
+VERSION=0.3
|
||||
+
|
||||
+.PHONY: install
|
||||
+all:
|
||||
+ true
|
||||
+
|
||||
+install:
|
||||
+ cp dkms.conf dkms.conf.in
|
||||
+ sed 's/"#VERSION#"/"'"${VERSION}"'"/g' <dkms.conf.in >dkms.conf
|
||||
+ echo 'ccflags-y += -DDEBUG' >> "Kbuild"
|
||||
+ echo "* Copying module into /usr/src..."
|
||||
+ install -dm755 $(DESTDIR)/usr/src/xone
|
||||
+ rsync -av --progress ./* $(DESTDIR)/usr/src/xone/ --exclude debian
|
||||
+ install -dm755 $(DESTDIR)/usr/bin
|
||||
+ cp install/firmware.sh $(DESTDIR)/usr/bin/xone-firmware
|
||||
+ ln -sf /usr/src/xone $(DESTDIR)/usr/src/xone-"${VERSION}"
|
||||
+ install -d $(DESTDIR)/etc/modules-load.d
|
||||
+ cp -r modules-load-d-xone.conf $(DESTDIR)/etc/modules-load.d/xone.conf
|
||||
+ echo "* Blacklisting xpad module..."
|
||||
+ install -D -m 644 install/modprobe.conf $(DESTDIR)/etc/modprobe.d/xone-blacklist.conf
|
||||
diff -uraN a/modules-load-d-xpadneo.conf b/modules-load-d-xpadneo.conf
|
||||
--- a/modules-load-d-xone.conf 1970-01-01 02:00:00.000000000 +0200
|
||||
+++ b/modules-load-d-xone.conf 2022-09-25 20:44:46.000000000 +0300
|
||||
@@ -0,0 +1,6 @@
|
||||
+xone-wired
|
||||
+xone-dongle
|
||||
+xone-gip
|
||||
+xone-gip-gamepad
|
||||
+xone-gip-headset
|
||||
+xone-gip-chatpad
|
||||
+xone-gip-guitar
|
10
pika-build-config/amd64-v3.sh
Executable file
10
pika-build-config/amd64-v3.sh
Executable file
@ -0,0 +1,10 @@
|
||||
#! /bin/bash
|
||||
export PIKA_BUILD_ARCH="amd64-v3"
|
||||
export DEBIAN_FRONTEND="noninteractive"
|
||||
export DEB_BUILD_MAINT_OPTIONS="optimize=+lto -march=x86-64-v3 -O3 -flto -fuse-linker-plugin -falign-functions=32"
|
||||
export DEB_CFLAGS_MAINT_APPEND="-march=x86-64-v3 -O3 -flto -fuse-linker-plugin -falign-functions=32"
|
||||
export DEB_CPPFLAGS_MAINT_APPEND="-march=x86-64-v3 -O3 -flto -fuse-linker-plugin -falign-functions=32"
|
||||
export DEB_CXXFLAGS_MAINT_APPEND="-march=x86-64-v3 -O3 -flto -fuse-linker-plugin -falign-functions=32"
|
||||
export DEB_LDFLAGS_MAINT_APPEND="-march=x86-64-v3 -O3 -flto -fuse-linker-plugin -falign-functions=32"
|
||||
export DEB_BUILD_OPTIONS="nocheck notest terse"
|
||||
export DPKG_GENSYMBOLS_CHECK_LEVEL=0
|
5
pika-build-config/i386.sh
Executable file
5
pika-build-config/i386.sh
Executable file
@ -0,0 +1,5 @@
|
||||
#! /bin/bash
|
||||
export PIKA_BUILD_ARCH="i386"
|
||||
export DEBIAN_FRONTEND="noninteractive"
|
||||
export DEB_BUILD_OPTIONS="nocheck notest terse"
|
||||
export DPKG_GENSYMBOLS_CHECK_LEVEL=0
|
@ -1,8 +1,2 @@
|
||||
# send debs to server
|
||||
rsync -azP --include './' --include '*.deb' --exclude '*' ./output/ ferreo@direct.pika-os.com:/srv/www/incoming/
|
||||
|
||||
# add debs to repo
|
||||
ssh ferreo@direct.pika-os.com 'aptly repo add -force-replace -remove-files pikauwu-main /srv/www/incoming/'
|
||||
|
||||
# publish the repo
|
||||
ssh ferreo@direct.pika-os.com 'aptly publish update -batch -skip-contents -force-overwrite pikauwu filesystem:pikarepo:'
|
||||
rsync -azP --include './' --include '*.deb' --exclude '*' ./output/ ferreo@direct.pika-os.com:/srv/www/cockatiel-incoming/
|
||||
|
20
xone-debian/Makefile
Normal file
20
xone-debian/Makefile
Normal file
@ -0,0 +1,20 @@
|
||||
VERSION=0.3
|
||||
|
||||
.PHONY: install
|
||||
all:
|
||||
true
|
||||
|
||||
install:
|
||||
cp xone/dkms.conf xone/dkms.conf.in
|
||||
sed 's/"#VERSION#"/"'"${VERSION}"'"/g' <xone/dkms.conf.in >xone/dkms.conf
|
||||
echo 'ccflags-y += -DDEBUG' >> "xone/Kbuild"
|
||||
echo "* Copying module into /usr/src..."
|
||||
install -dm755 $(DESTDIR)/usr/src/xone
|
||||
rsync -av --progress ./xone/* $(DESTDIR)/usr/src/xone/ --exclude debian
|
||||
install -dm755 $(DESTDIR)/usr/bin
|
||||
cp xone/install/firmware.sh $(DESTDIR)/usr/bin/xone-firmware
|
||||
ln -sf /usr/src/xone $(DESTDIR)/usr/src/xone-"${VERSION}"
|
||||
install -d $(DESTDIR)/etc/modules-load.d
|
||||
cp -r modules-load-d-xone.conf $(DESTDIR)/etc/modules-load.d/xone.conf
|
||||
echo "* Blacklisting xpad module..."
|
||||
install -D -m 644 xone/install/modprobe.conf $(DESTDIR)/etc/modprobe.d/xone-blacklist.conf
|
@ -1,10 +1,14 @@
|
||||
xone (0.3.git-101pika1) pikauwu; urgency=medium
|
||||
xone (0.3.git-101pika2) pika; urgency=medium
|
||||
|
||||
* Update to latest
|
||||
* Update to PikaOS 4
|
||||
|
||||
-- Ward Nakchbandi <hotrod.master@hotmail.com> Thu, 04 Oct 2022 17:50:00 +0300
|
||||
|
||||
xone (0.3.git-101pika1) pikauwu; urgency=medium
|
||||
|
||||
* Update to latest (why are u 101????)
|
||||
|
||||
-- Ward Nakchbandi <hotrod.master@hotmail.com> Thu, 04 Oct 2022 17:50:00 +0300
|
||||
|
||||
xone (0.3.git-100pika1) pikauwu; urgency=medium
|
||||
|
1
xone-debian/debian/source/format
Normal file
1
xone-debian/debian/source/format
Normal file
@ -0,0 +1 @@
|
||||
3.0 (quilt)
|
6
xone-debian/modules-load-d-xone.conf
Normal file
6
xone-debian/modules-load-d-xone.conf
Normal file
@ -0,0 +1,6 @@
|
||||
xone-wired
|
||||
xone-dongle
|
||||
xone-gip
|
||||
xone-gip-gamepad
|
||||
xone-gip-headset
|
||||
xone-gip-chatpad
|
Loading…
Reference in New Issue
Block a user