overwrite makefile instead of patching

This commit is contained in:
Ward Nakchbandi 2023-03-04 16:33:17 +03:00
parent b3d36d630e
commit 5ce5621e93
5 changed files with 15 additions and 22 deletions

12
Makefile Normal file
View File

@ -0,0 +1,12 @@
VERSION=1.0
all:
true
install:
echo "* Copying module into /usr/src..."
install -dm755 $(DESTDIR)/usr/src/xpad-noone
cp -r xpad-noone $(DESTDIR)/usr/src/
ln -sf /usr/src/xpad-noone $(DESTDIR)/usr/src/xpad-noone-"${VERSION}"
install -d $(DESTDIR)/etc/modules-load.d
cp -r modules-load-d-xpad-noone.conf $(DESTDIR)/etc/modules-load.d/xpad-noone.conf

View File

@ -1 +0,0 @@
xpad-noone-package-adapt.patch

View File

@ -1,21 +0,0 @@
diff -uraN a/Makefile b/Makefile
--- a/Makefile 1970-01-01 02:00:00.000000000 +0200
+++ b/Makefile 2023-03-04 16:27:05.690744954 +0300
@@ -0,0 +1,12 @@
+VERSION=1.0
+
+all:
+ true
+
+install:
+ echo "* Copying module into /usr/src..."
+ install -dm755 $(DESTDIR)/usr/src/xpad-noone
+ cp -r xpad-noone $(DESTDIR)/usr/src/
+ ln -sf /usr/src/xpad-noone $(DESTDIR)/usr/src/xpad-noone-"${VERSION}"
+ install -d $(DESTDIR)/etc/modules-load.d
+ cp -r modules-load-d-xpad-noone.conf $(DESTDIR)/etc/modules-load.d/xpad-noone.conf
diff -uraN a/modules-load-d-xpadneo.conf b/modules-load-d-xpadneo.conf
--- a/modules-load-d-xpad-noone.conf 1970-01-01 02:00:00.000000000 +0200
+++ b/modules-load-d-xpad-noone.conf 2022-09-25 20:44:46.000000000 +0300
@@ -0,0 +1,1 @@
+xpad-noone

View File

@ -6,6 +6,8 @@ add-apt-repository ppa:kubuntu-ppa/backports
# Clone Upstream
git clone https://github.com/medusalix/xpad-noone
cp -rvf ./debian ./xpad-noone
cp -rvf ./modules-load-d-xpad-noone.conf ./xpad-noone
cp -rvf ./Makefile ./xpad-noone
cd ./xpad-noone
# Get build deps

View File

@ -0,0 +1 @@
xpad-noone