dkms/debian/patches/only-autobuild-AUTOINSTALL-yes-modules.patch
2024-11-20 14:25:28 +00:00

17 lines
571 B
Diff

--- a/dkms_common.postinst.in
+++ b/dkms_common.postinst.in
@@ -155,6 +155,13 @@ if [ -z "$autoinstall" ]; then
exit 0
fi
+dkms_conf="/var/lib/dkms/$NAME/$VERSION/source/dkms.conf"
+autoinstall=$(bash -c 'AUTOINSTALL=; . "'"$dkms_conf"'" >/dev/null 2>&1; echo $AUTOINSTALL')
+if [ -z "$autoinstall" ]; then
+ echo "Not building the $NAME module which does not have AUTOINSTALL enabled."
+ exit 0
+fi
+
# On 1st installation, let us look for a directory
# in @MODDIR@ which matches $(uname -r). If none
# is found it is possible that buildd is being used