generated from general-packages/pika-pkg-template
add pam patch
Some checks failed
PikaOS Package Build & Release (amd64-v3) / build (push) Failing after 56s
Some checks failed
PikaOS Package Build & Release (amd64-v3) / build (push) Failing after 56s
This commit is contained in:
parent
eb4e38e9d5
commit
87dc293ed0
2
.github/release-nest-v3
vendored
2
.github/release-nest-v3
vendored
@ -1 +1 @@
|
|||||||
2
|
1
|
24
debian/patches/pam.patch
vendored
Normal file
24
debian/patches/pam.patch
vendored
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
From cc5e2bc37900f27f11630253a0b08d31d9e88086 Mon Sep 17 00:00:00 2001
|
||||||
|
From: ferrreo <harderthanfire@gmail.com>
|
||||||
|
Date: Mon, 2 Dec 2024 19:16:48 +0000
|
||||||
|
Subject: [PATCH] Update build.zig
|
||||||
|
|
||||||
|
---
|
||||||
|
build.zig | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/build.zig b/build.zig
|
||||||
|
index f0e9074..cf25dd2 100644
|
||||||
|
--- a/build.zig
|
||||||
|
+++ b/build.zig
|
||||||
|
@@ -297,7 +297,7 @@ fn install_ly(allocator: std.mem.Allocator, install_config: bool) !void {
|
||||||
|
}
|
||||||
|
|
||||||
|
{
|
||||||
|
- const pam_path = try std.fs.path.join(allocator, &[_][]const u8{ dest_directory, config_directory, "/pam.d" });
|
||||||
|
+ const pam_path = try std.fs.path.join(allocator, &[_][]const u8{ config_directory, "/pam.d" });
|
||||||
|
if (!std.mem.eql(u8, dest_directory, "")) {
|
||||||
|
std.fs.cwd().makePath(pam_path) catch {
|
||||||
|
std.debug.print("warn: {s} already exists as a directory.\n", .{pam_path});
|
||||||
|
|
||||||
|
|
1
debian/patches/series
vendored
Normal file
1
debian/patches/series
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
pam.patch
|
3
debian/rules
vendored
3
debian/rules
vendored
@ -7,5 +7,4 @@ export PIKA_BUILD_ARCH = $(shell cat ../pika-build-arch)
|
|||||||
dh $@
|
dh $@
|
||||||
|
|
||||||
override_dh_auto_build:
|
override_dh_auto_build:
|
||||||
zig build -Dcpu=x86_64_v3 -Doptimize=ReleaseFast -Ddest_directory=$(CURDIR)/debian/tmp/ installsystemd
|
zig build -Dcpu=x86_64_v3 -Doptimize=ReleaseFast -Ddest_directory='$${DESTDIR}' installsystemd
|
||||||
|
|
Loading…
x
Reference in New Issue
Block a user