first commit

This commit is contained in:
Ward Nakchbandi 2023-03-09 18:13:46 +03:00
parent d4909caf8d
commit 1d8d128110
16 changed files with 150 additions and 319 deletions

40
.github/workflows/release.yml vendored Normal file
View File

@ -0,0 +1,40 @@
name: PikaOS Package Release
on:
workflow_dispatch
jobs:
build:
runs-on: self-hosted
container:
image: ubuntu:22.10
volumes:
- /proc:/proc
options: --privileged -it
steps:
- uses: actions/checkout@v3
- name: Install needed packages
run: apt update && apt install software-properties-common sudo git bc gpg gpg-agent bison build-essential ccache cpio fakeroot flex git kmod libelf-dev libncurses5-dev libssl-dev lz4 qtbase5-dev rsync schedtool wget zstd tar reprepro dpkg-sig devscripts -y
- name: Import GPG key
id: import_gpg
uses: crazy-max/ghaction-import-gpg@v5
with:
gpg_private_key: ${{ secrets.GPG_PRIVATE_KEY }}
passphrase: ${{ secrets.PASSPHRASE }}
- name: Install SSH key
uses: shimataro/ssh-key-action@v2
with:
key: ${{ secrets.SSH_KEY }}
name: id_rsa
known_hosts: ${{ secrets.KNOWN_HOSTS }}
if_key_exists: replace
- name: Build Package
run: ./main.sh
- name: Release Package
run: ./release.sh

40
.github/workflows/release_i386.yml vendored Normal file
View File

@ -0,0 +1,40 @@
name: PikaOS Package Release (i386)
on:
workflow_dispatch
jobs:
build:
runs-on: self-hosted
container:
image: ubuntu:22.10
volumes:
- /proc:/proc
options: --privileged -it
steps:
- uses: actions/checkout@v3
- name: Install needed packages
run: apt update && apt install software-properties-common sudo git bc gpg gpg-agent bison build-essential ccache cpio fakeroot flex git kmod libelf-dev libncurses5-dev libssl-dev lz4 qtbase5-dev rsync schedtool wget zstd tar reprepro dpkg-sig devscripts dh-make -y
- name: Import GPG key
id: import_gpg
uses: crazy-max/ghaction-import-gpg@v5
with:
gpg_private_key: ${{ secrets.GPG_PRIVATE_KEY }}
passphrase: ${{ secrets.PASSPHRASE }}
- name: Install SSH key
uses: shimataro/ssh-key-action@v2
with:
key: ${{ secrets.SSH_KEY }}
name: id_rsa
known_hosts: ${{ secrets.KNOWN_HOSTS }}
if_key_exists: replace
- name: Build Package
run: ./main32.sh
- name: Release Package
run: ./release.sh

37
.github/workflows/unrelease.yml vendored Normal file
View File

@ -0,0 +1,37 @@
name: PikaOS Package UnRelease
on:
workflow_dispatch
jobs:
build:
runs-on: self-hosted
container:
image: ubuntu:22.10
volumes:
- /proc:/proc
options: --privileged -it
steps:
- uses: actions/checkout@v3
- name: Install needed packages
run: apt update && apt install software-properties-common sudo git bc gpg gpg-agent bison build-essential ccache cpio fakeroot flex git kmod libelf-dev libncurses5-dev libssl-dev lz4 qtbase5-dev rsync schedtool wget zstd tar reprepro dpkg-sig devscripts dh-make -y
- name: Import GPG key
id: import_gpg
uses: crazy-max/ghaction-import-gpg@v5
with:
gpg_private_key: ${{ secrets.GPG_PRIVATE_KEY }}
passphrase: ${{ secrets.PASSPHRASE }}
- name: Install SSH key
uses: shimataro/ssh-key-action@v2
with:
key: ${{ secrets.SSH_KEY }}
name: id_rsa
known_hosts: ${{ secrets.KNOWN_HOSTS }}
if_key_exists: replace
- name: Un Release Package
run: ./unrelease.sh

22
main.sh Executable file
View File

@ -0,0 +1,22 @@
DEBIAN_FRONTEND=noninteractive
# Add dependent repositories
wget -q -O - https://ppa.pika-os.com/key.gpg | sudo apt-key add -
add-apt-repository https://ppa.pika-os.com
add-apt-repository ppa:pikaos/pika
add-apt-repository ppa:kubuntu-ppa/backports
# Clone Upstream
cd ./neofetch
# Get build deps
ln -fs /usr/share/zoneinfo/America/New_York /etc/localtime
DEBIAN_FRONTEND=noninteractive apt-get install -y tzdata
apt-get build-dep ./ -y
# Build package
dpkg-buildpackage
# Move the debs to output
cd ../
mkdir -p ./output
mv ./*.deb ./output/

View File

@ -1,171 +0,0 @@
neofetch (7.1.0-99nobara5) kinetic; urgency=medium
* Nobara not NobaraOS
-- Ward Nakchbandi <hotrod.master@hotmail.com> Sat, 15 Oct 2022 20:50:00 +0300
neofetch (7.1.0-99nobara4) kinetic; urgency=medium
* Update NobaraOS ascii
-- Ward Nakchbandi <hotrod.master@hotmail.com> Sat, 15 Oct 2022 20:50:00 +0300
neofetch (7.1.0-99nobara3) kinetic; urgency=medium
* Add NobaraOS ascii
-- Ward Nakchbandi <hotrod.master@hotmail.com> Sat, 15 Oct 2022 20:50:00 +0300
neofetch (7.1.0-4) unstable; urgency=medium
* Update d/control.
- Bump Standards-Version to 4.6.0.1.
- Add debhelper-compat version in Build-Depends.
- Add Rules-Requires-Root: no
- Add 'Multi-Arch: foreign'.
* Remove d/compat.
* Update d/copyright
- Update copyright year.
* Add d/upstream/metadata
- Add file.
* Update d/watch.
- Fix format.
-- Nobuhiro Iwamatsu <iwamatsu@debian.org> Mon, 18 Apr 2022 17:27:53 +0900
neofetch (7.1.0-3) unstable; urgency=medium
* d/control: Add some image display tools to Recommends (Closes: #984431)
Thanks to Benjamin Barenblat <bbaren@debian.org>.
* d/control: Add pciutils to Recommends (Closes: #984432)
Thanks to Benjamin Barenblat <bbaren@debian.org>.
* Change shebang to '#!/bin/bash' (Closes: #984433)
- Add d/patches/0001-Change-shebang-to-bin-bash-Closes-984433.patch
- Thanks to Benjamin Barenblat <bbaren@debian.org>.
-- Nobuhiro Iwamatsu <iwamatsu@debian.org> Thu, 09 Sep 2021 12:09:46 +0900
neofetch (7.1.0-2) unstable; urgency=medium
* Fix typo in Package description (Closes: #963627).
Thanks to Raymond Wu Won <rwcaret2@gmail.com>.
-- Nobuhiro Iwamatsu <iwamatsu@debian.org> Tue, 17 Nov 2020 18:25:49 +0900
neofetch (7.1.0-1) unstable; urgency=medium
* New upstream release.
-- Nobuhiro Iwamatsu <iwamatsu@debian.org> Fri, 14 Aug 2020 10:59:40 +0900
neofetch (7.0.0-1) unstable; urgency=medium
* New upstream release.
-- Nobuhiro Iwamatsu <iwamatsu@debian.org> Tue, 24 Mar 2020 11:26:24 +0900
neofetch (6.1.0-1) unstable; urgency=medium
* New upstream release.
-- Nobuhiro Iwamatsu <iwamatsu@debian.org> Mon, 02 Sep 2019 09:05:34 +0900
neofetch (6.0.0-2) unstable; urgency=medium
* Add chafa to Recommends.
-- Nobuhiro Iwamatsu <iwamatsu@debian.org> Wed, 09 Jan 2019 12:20:03 +0900
neofetch (6.0.0-1) unstable; urgency=medium
* New upstream release.
* Dump Standards-Version to 4.3.0.
-- Nobuhiro Iwamatsu <iwamatsu@debian.org> Wed, 09 Jan 2019 12:10:07 +0900
neofetch (5.0.0-1) unstable; urgency=medium
* New upstream release.
-- Nobuhiro Iwamatsu <iwamatsu@debian.org> Wed, 20 Jun 2018 13:28:21 +0900
neofetch (4.0.2-1) unstable; urgency=medium
* New upstream release.
-- Nobuhiro Iwamatsu <iwamatsu@debian.org> Mon, 28 May 2018 10:40:38 +0900
neofetch (4.0.0-1) unstable; urgency=medium
* New upstream release.
* Update Standards-Version to 4.1.4.
* Update debhelper to 11.
-- Nobuhiro Iwamatsu <iwamatsu@debian.org> Thu, 17 May 2018 15:55:57 +0900
neofetch (3.4.0-1) unstable; urgency=medium
* New upstream release.
* Bump Standards-Version to 4.1.3.
* Update Vcs-Browser and Vcs-Git to salsa.
* Add watch file.
-- Nobuhiro Iwamatsu <iwamatsu@debian.org> Fri, 06 Apr 2018 08:01:30 +0900
neofetch (3.3.0-1) unstable; urgency=medium
* New upstream release.
* Update Standards-Version to 4.1.0.
-- Nobuhiro Iwamatsu <iwamatsu@debian.org> Fri, 15 Sep 2017 12:43:35 +0900
neofetch (3.2.0-1) unstable; urgency=medium
* New upstream release.
-- Nobuhiro Iwamatsu <iwamatsu@debian.org> Sat, 24 Jun 2017 06:35:24 +0900
neofetch (3.1.0-1) experimental; urgency=medium
* New upstream release.
-- Nobuhiro Iwamatsu <iwamatsu@debian.org> Thu, 27 Apr 2017 12:34:35 +0900
neofetch (3.0.1-1) experimental; urgency=medium
* New upstream release.
-- Nobuhiro Iwamatsu <iwamatsu@debian.org> Fri, 03 Feb 2017 07:09:18 +0900
neofetch (3.0-1) experimental; urgency=medium
* New upstream release.
-- Nobuhiro Iwamatsu <iwamatsu@debian.org> Tue, 24 Jan 2017 14:51:21 +0900
neofetch (2.0.2-1) unstable; urgency=medium
* New upstream release.
-- Nobuhiro Iwamatsu <iwamatsu@debian.org> Wed, 07 Dec 2016 21:55:51 +0900
neofetch (2.0.1-1) unstable; urgency=medium
* New upstream release. (Closes: #846934)
* Remove debian/patches.
All patches were applied to upstream.
-- Nobuhiro Iwamatsu <iwamatsu@debian.org> Tue, 06 Dec 2016 20:31:36 +0900
neofetch (1.9.1-2) unstable; urgency=medium
* Fix launches pacman game. (Closes: #845629)
Thanks to Dylan Araps <dylan.araps@gmail.com>.
-- Nobuhiro Iwamatsu <iwamatsu@debian.org> Sat, 26 Nov 2016 06:35:37 +0900
neofetch (1.9.1-1) unstable; urgency=medium
* Initial release. (Closes: #844175)
-- Nobuhiro Iwamatsu <iwamatsu@debian.org> Thu, 17 Nov 2016 00:03:38 +0900

View File

@ -1,21 +0,0 @@
Source: neofetch
Maintainer: Nobuhiro Iwamatsu <iwamatsu@debian.org>
Section: utils
Priority: optional
Build-Depends: debhelper-compat (= 13)
Standards-Version: 4.6.0.1
Rules-Requires-Root: no
Vcs-Browser: https://salsa.debian.org/debian/neofetch
Vcs-Git: https://salsa.debian.org/debian/neofetch.git
Homepage: https://github.com/dylanaraps/neofetch
Package: neofetch
Architecture: all
Depends: ${misc:Depends}
Multi-Arch: foreign
Recommends: chafa, caca-utils, imagemagick, jp2a, libsixel-bin, w3m-img, pciutils
Description: Shows Linux System Information with Distribution Logo
Neofetch is a cross-platform and easy-to-use system information
command line script that collects your Linux system information
and display it on the terminal next to an image, it could be your
distributions logo or any ascii art of your choice.

View File

@ -1,27 +0,0 @@
Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: neofetch
Source: https://github.com/dylanaraps/neofetch
Files: *
Copyright: Copyright (c) 2016 Dylan Araps
License: Expat
Files: debian/*
Copyright: 2016 - 2022 Nobuhiro Iwamatsu <iwamatsu@debian.org>
License: Expat
License: Expat
Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:
.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.

View File

@ -1,12 +0,0 @@
[DEFAULT]
pristine-tar = True
cleaner = fakeroot debian/rules clean
upstream-tag = %(version)s
compression = xz
[buildpackage]
export-dir = ../build-area/
[import-orig]
dch = False
filter-pristine-tar = True

View File

@ -1,26 +0,0 @@
From 7c7050dd6c7eed29db2c3fd813b4d84fe9be606d Mon Sep 17 00:00:00 2001
From: Nobuhiro Iwamatsu <iwamatsu@debian.org>
Date: Thu, 9 Sep 2021 11:53:21 +0900
Subject: [PATCH] Change shebang to '#!/bin/bash' (Closes: #984433)
On Debian, Bash is always installed at /bin/bash. so change to
/bin/bash.
Signed-off-by: Nobuhiro Iwamatsu <iwamatsu@debian.org>
Forwarded: not-needed
Bug-Debian: http://bugs.debian.org/984433
---
neofetch | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Index: neofetch-7.1.0/neofetch
===================================================================
--- neofetch-7.1.0.orig/neofetch
+++ neofetch-7.1.0/neofetch
@@ -1,4 +1,4 @@
-#!/usr/bin/env bash
+#!/bin/bash
# vim: noai:ts=4:sw=4:expandtab
# shellcheck source=/dev/null
# shellcheck disable=2009

View File

@ -1,45 +0,0 @@
diff -ruN a/neofetch b/neofetch
--- a/neofetch 2020-08-02 21:37:41.000000000 +0300
+++ b/neofetch 2022-10-22 16:10:23.161617439 +0300
@@ -8171,6 +8171,41 @@
`-//sssssss//.
EOF
;;
+
+ "Nobara"*)
+ set_colors 7 6
+ read -rd '' ascii_data <<'EOF'
+${c1}
+⠀⠀⠀⠀⠀⠀⠀⠀⣀⣀⣀⠀⠀⠀⠀⠀⠀⠀⠀⣀⣀⣀⣀⣀⡀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀
+⠀⠀⠀⠀⠀⣠⣶⣿⣿⣿⣿⣿⣶⣄⣤⣴⣶⣿⣿⣿⣿⣿⣿⣿⣿⣿⣷⣶⣤⣀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀
+⠀⠀⠀⠀⢰⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣦⣄⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀
+⠀⠀⠀⠀⣾⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣷⣄⠀⠀⠀⠀⠀⠀⠀⠀⠀
+⠀⠀⠀⠀⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣧⡀⠀⠀⠀⠀⠀⠀⠀
+⠀⠀⠀⠀⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣷⡀⠀⠀⠀⠀⠀⠀
+⠀⠀⠀⠀⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⠟⠛⠉⠉⠉⠙⠛⢿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣷⡀⠀⠀⠀⠀⠀
+⠀⠀⠀⠀⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⠋⠀⠀⠀⠀⠀⠀⠀⠀⠀⠈⢿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣇⠀⠀⠀⠀⠀
+⠀⠀⠀⠀⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⠃⠀⠀⠀⣤⣶⣿⣷⣦⡄⠀⠀⠀⢻⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⠀⠀⠀⠀⠀
+⠀⠀⠀⠀⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⡿⠀⠀⠀⣸⣿⣿⣿⣿⣿⣿⠀⠀⠀⠀⠉⠙⠛⠿⢿⣿⣿⣿⣿⣿⠀⠀⠀⠀⠀
+⠀⠀⠀⠀⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⡇⠀⠀⠀⠸⣿⣿⣿⣿⣿⡿⠀⠀⠀⢀⣤⣴⣶⣾⣿⣿⣿⣿⣿⣿⠀⠀⠀⠀⠀
+⠀⠀⠀⠀⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⡇⠀⠀⠀⠀⠙⠻⠿⠿⠋⠁⠀⠀⠀⢸⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⠀⠀⠀⠀⠀
+⠀⠀⠀⠀⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⡀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⠀⢸⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⠀⠀⠀⠀⠀
+⠀⠀⠀⠀⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣶⣤⣤⣄⡀⠀⠀⠀⠀⠀⠀⠀⢸⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⠀⠀⠀⠀⠀
+⠀⠀⠀⠀⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣷⡄⠀⠀⠀⠀⠀⢸⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⠀⠀⠀⠀⠀
+⠀⠀⠀⠀⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⡄⠀⠀⠀⠀⢸⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⠀⠀⠀⠀⠀
+⠀⠀⠀⠀⢻⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⠿⠟⠛⠿⢿⣿⣿⡇⠀⠀⠀⠀⠘⣿⣿⣿⣿⣿⣿⣿⣿⣿⣿⠀⠀⠀⠀⠀
+⠀⠀⠀⠀⠘⣿⣿⣿⣿⣿⣿⣿⣿⣿⠋⠀⠀⠀⠀⠀⠀⠈⢻⡇⠀⠀⠀⠀⠀⢻⣿⣿⣿⣿⣿⣿⣿⣿⠟⠀⠀⠀⠀⠀
+⠀⠀⠀⠀⠀⠈⠛⠿⣿⣿⣿⡿⠟⠁⠀⠀⠀⠀⠀⠀⠀⠀⠀⠃⠀⠀⠀⠀⠀⠀⠙⠿⣿⣿⣿⡿⠟⠋⠀⠀⠀⠀⠀⠀
+
+
+
+
+
+EOF
+ ;;
+
+ "Nurunner"*)
+ set_colors 4
+ read -rd '' ascii_data <<'EOF'
"netbsd_small"*)
set_colors 5 7

View File

@ -1,2 +0,0 @@
0001-Change-shebang-to-bin-bash-Closes-984433.patch
nobara_logo.patch

View File

@ -1,4 +0,0 @@
#!/usr/bin/make -f
%:
dh $@

View File

@ -1 +0,0 @@
3.0 (quilt)

View File

@ -1,6 +0,0 @@
---
Name: neofetch
Bug-Database: https://github.com/dylanaraps/neofetch/issues
Bug-Submit: https://github.com/dylanaraps/neofetch/issues/new
Repository: https://github.com/dylanaraps/neofetch.git
Repository-Browse: https://github.com/dylanaraps/neofetch

View File

@ -1,4 +0,0 @@
version=4
opts="filenamemangle=s%(?:.*?)?v?(\d[\d.]*)\.tar\.gz%neofetch-$1.tar.gz%,\
uversionmangle=s/(\d)[_\.\-\+]?(RC|rc|pre|dev|beta|alpha)[.]?(\d*)$/\$1~\$2\$3/" \
https://github.com/dylanaraps/neofetch/tags .*/v?(\d\S*)\.tar\.gz debian

11
release.sh Executable file
View File

@ -0,0 +1,11 @@
# Sign the packages
dpkg-sig --sign builder ./output/*.deb
# Pull down existing ppa repo db files etc
rsync -azP --exclude '*.deb' ferreo@direct.pika-os.com:/srv/www/pikappa/ ./output/repo
# Add the new package to the repo
reprepro -V --basedir ./output/repo/ includedeb kinetic ./output/*.deb
# Push the updated ppa repo to the server
rsync -azP ./output/repo/ ferreo@direct.pika-os.com:/srv/www/pikappa/