ferreo
70e1481ce6
Some checks failed
PikaOS Package Build & Release (amd64-v3) / build (push) Failing after 1m28s
30 lines
1.2 KiB
Diff
30 lines
1.2 KiB
Diff
Description: Use shell variable for pkgconfig
|
|
This patch uses the shell variable for the pkconfig exectuable, thus allowing crossbuilding.
|
|
Author: Helmut Grohne <helmut@subdivi.de> , Matthias Geiger <werdahias@riseup.net>
|
|
Bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1040535
|
|
Forwarded: not-needed
|
|
Last-Update: 2023-11-06
|
|
---
|
|
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
|
|
|
|
--- a/src/helper/CMakeLists.txt
|
|
+++ b/src/helper/CMakeLists.txt
|
|
@@ -13,7 +13,7 @@
|
|
if(NOT INSTALL_DBUS_FILES_IN_PREFIX)
|
|
pkg_check_modules(DBUS REQUIRED dbus-1)
|
|
execute_process(
|
|
- COMMAND pkg-config --variable=datadir dbus-1
|
|
+ COMMAND ${PKG_CONFIG_EXECUTABLE} --variable=datadir dbus-1
|
|
RESULT_VARIABLE DBUS_DATADIR_PREFIX_DIR_RESULT
|
|
OUTPUT_VARIABLE DBUS_DATADIR_PREFIX_DIR
|
|
OUTPUT_STRIP_TRAILING_WHITESPACE
|
|
@@ -27,7 +27,7 @@
|
|
# Find polkit
|
|
pkg_check_modules(POLKIT REQUIRED polkit-gobject-1)
|
|
execute_process(
|
|
- COMMAND pkg-config --variable=policydir polkit-gobject-1
|
|
+ COMMAND ${PKG_CONFIG_EXECUTABLE} --variable=policydir polkit-gobject-1
|
|
RESULT_VARIABLE POLKIT_POLICY_INSTALL_DIR_RESULT
|
|
OUTPUT_VARIABLE POLKIT_POLICY_INSTALL_DIR
|
|
OUTPUT_STRIP_TRAILING_WHITESPACE
|