first commit

This commit is contained in:
Ward from fusion-voyager-3 2023-10-27 15:42:54 +03:00
parent 7dfb64680b
commit 003f30278a
14 changed files with 536 additions and 101 deletions

50
.github/workflows/release_i386.yml vendored Normal file
View File

@ -0,0 +1,50 @@
name: PikaOS Package Release (i386)
on:
workflow_dispatch
jobs:
build:
runs-on: self-hosted
container:
image: ghcr.io/pikaos-linux/pika-i386-package-container:latest
volumes:
- /proc:/proc
options: --privileged -it
steps:
- uses: actions/checkout@v3
- name: Import GPG key
id: import_gpg
uses: crazy-max/ghaction-import-gpg@v5
with:
gpg_private_key: ${{ secrets.GPG_PRIVATE_KEY }}
passphrase: ${{ secrets.PASSPHRASE }}
- name: Install SSH key
uses: shimataro/ssh-key-action@v2
with:
key: ${{ secrets.SSH_KEY }}
name: id_rsa
known_hosts: ${{ secrets.KNOWN_HOSTS }}
if_key_exists: replace
- name: Update apt cache
run: apt-get update -y
- name: Build Package
run: ./main.sh
- name: Release Package
run: ./release.sh
- name: Purge cache
uses: strrife/cloudflare-chunked-purge-action@master
env:
# Zone is required by both authentication methods
CLOUDFLARE_ZONE: ${{ secrets.CLOUDFLARE_ZONE }}
CLOUDFLARE_TOKEN: ${{ secrets.CLOUDFLARE_TOKEN }}
PURGE_URLS: ${{ vars.PURGE_URLS }}

313
debian/changelog vendored
View File

@ -1,5 +1,312 @@
upstream-name (pkgver-pkgrel) distro_codename; urgency=medium
intel-gmmlib (22.3.12-100pika1) pikauwu; urgency=medium
* Initial release. (Closes: #nnnn) <nnnn is the bug number of your ITP>
* New upstream version 22.3.12
-- ferreo <harderthanfire@gmail.com> Wed, 18 Jan 2023 21:48:14 +0000
-- Sebastian Ramacher <sramacher@debian.org> Fri, 21 Jul 2023 22:03:26 +0200
intel-gmmlib (22.3.9+ds1-1) unstable; urgency=medium
* New upstream version 22.3.9+ds1
- Fix build on i386 (Closes: #1041474)
-- Sebastian Ramacher <sramacher@debian.org> Fri, 21 Jul 2023 22:03:26 +0200
intel-gmmlib (22.3.7+ds1-1) unstable; urgency=medium
* New upstream version 22.3.7+ds1
-- Sebastian Ramacher <sramacher@debian.org> Sat, 01 Jul 2023 18:04:44 +0200
intel-gmmlib (22.3.6+ds1-1) unstable; urgency=medium
* New upstream version 22.3.6+ds1
* debian/patches: Refresh patches
-- Sebastian Ramacher <sramacher@debian.org> Thu, 08 Jun 2023 21:08:44 +0200
intel-gmmlib (22.3.4+ds1-1) unstable; urgency=medium
* New upstream version 22.3.4+ds1
-- Sebastian Ramacher <sramacher@debian.org> Fri, 03 Mar 2023 21:29:17 +0100
intel-gmmlib (22.3.3+ds1-1) unstable; urgency=medium
* New upstream version 22.3.3+ds1
* debian/control: Bump Standards-Version
-- Sebastian Ramacher <sramacher@debian.org> Sun, 15 Jan 2023 15:08:15 +0100
intel-gmmlib (22.3.2+ds1-1) unstable; urgency=medium
[ Debian Janitor ]
* Set upstream metadata fields: Repository-Browse.
[ Sebastian Ramacher ]
* New upstream version 22.3.2+ds1
-- Sebastian Ramacher <sramacher@debian.org> Fri, 16 Dec 2022 23:44:26 +0100
intel-gmmlib (22.3.1+ds1-1) unstable; urgency=medium
* New upstream version 22.3.1+ds1
-- Sebastian Ramacher <sramacher@debian.org> Mon, 21 Nov 2022 22:38:27 +0100
intel-gmmlib (22.3.0+ds1-1) unstable; urgency=medium
* New upstream version 22.3.0+ds1
-- Sebastian Ramacher <sramacher@debian.org> Sun, 30 Oct 2022 21:08:18 +0100
intel-gmmlib (22.2.1+ds1-1) unstable; urgency=medium
* New upstream version 22.2.1+ds1
-- Sebastian Ramacher <sramacher@debian.org> Wed, 19 Oct 2022 19:12:24 +0200
intel-gmmlib (22.2.0+ds1-1) unstable; urgency=medium
* New upstream version 22.2.0+ds1
-- Sebastian Ramacher <sramacher@debian.org> Wed, 21 Sep 2022 21:42:32 +0200
intel-gmmlib (22.1.8+ds1-1) unstable; urgency=medium
* New upstream version 22.1.8+ds1
-- Sebastian Ramacher <sramacher@debian.org> Wed, 07 Sep 2022 09:30:41 +0200
intel-gmmlib (22.1.7+ds1-1) unstable; urgency=medium
* New upstream version 22.1.7+ds1
-- Sebastian Ramacher <sramacher@debian.org> Tue, 02 Aug 2022 21:07:30 +0200
intel-gmmlib (22.1.5+ds1-1) unstable; urgency=medium
* New upstream version 22.1.5+ds1
-- Sebastian Ramacher <sramacher@debian.org> Sat, 09 Jul 2022 15:32:35 +0200
intel-gmmlib (22.1.3+ds1-1) unstable; urgency=medium
* New upstream version 22.1.3+ds1
* debian/control: Bump Standards-Version
-- Sebastian Ramacher <sramacher@debian.org> Thu, 26 May 2022 10:10:51 +0200
intel-gmmlib (22.1.2+ds1-1) unstable; urgency=medium
* New upstream version 22.1.2+ds1
- Revert ABI breakage (Closes: #1007992)
-- Sebastian Ramacher <sramacher@debian.org> Fri, 25 Mar 2022 00:04:41 +0100
intel-gmmlib (22.1.1+ds1-1) unstable; urgency=medium
* New upstream version 22.1.1+ds1
-- Sebastian Ramacher <sramacher@debian.org> Sat, 19 Mar 2022 23:24:24 +0100
intel-gmmlib (22.0.2+ds1-1) unstable; urgency=medium
* New upstream version 22.0.2+ds1
-- Sebastian Ramacher <sramacher@debian.org> Mon, 07 Feb 2022 22:16:56 +0100
intel-gmmlib (22.0.1+ds1-1) unstable; urgency=medium
* Upload to unstable
* New upstream version 22.0.1+ds1
-- Sebastian Ramacher <sramacher@debian.org> Thu, 30 Dec 2021 22:12:03 +0100
intel-gmmlib (22.0.0+ds1-1) experimental; urgency=medium
* New upstream version 22.0.0+ds1
* SONAME bump: libigdgmm11 -> libigdgmm12
* debian/copyright:
- Bump copyright years
- Remove Gabi Melman since spdlog is excluded
-- Sebastian Ramacher <sramacher@debian.org> Sun, 19 Dec 2021 10:50:08 +0100
intel-gmmlib (21.3.3+ds1-1) unstable; urgency=medium
* New upstream version 21.3.3+ds1
-- Sebastian Ramacher <sramacher@debian.org> Fri, 19 Nov 2021 20:50:42 +0100
intel-gmmlib (21.3.2+ds1-1) unstable; urgency=medium
* New upstream version 21.3.2+ds1
-- Sebastian Ramacher <sramacher@debian.org> Fri, 29 Oct 2021 15:30:18 +0200
intel-gmmlib (21.3.1+ds1-1) unstable; urgency=medium
[ Debian Janitor ]
* Set upstream metadata fields: Bug-Database, Bug-Submit.
[ Sebastian Ramacher ]
* New upstream release
* debian/control: Bump Standards-Version
-- Sebastian Ramacher <sramacher@debian.org> Fri, 24 Sep 2021 00:09:25 +0200
intel-gmmlib (21.2.2+ds1-1) unstable; urgency=medium
* New upstream release
-- Sebastian Ramacher <sramacher@debian.org> Tue, 31 Aug 2021 19:00:20 +0200
intel-gmmlib (21.2.1+ds1-2) unstable; urgency=medium
* Upload to unstable
-- Sebastian Ramacher <sramacher@debian.org> Sun, 08 Aug 2021 11:46:09 +0200
intel-gmmlib (21.2.1+ds1-1) experimental; urgency=medium
* New upstream release
-- Sebastian Ramacher <sramacher@debian.org> Wed, 04 Aug 2021 22:44:39 +0200
intel-gmmlib (21.1.1+ds1-1) experimental; urgency=medium
* New upstream release
* debian/control: Bump Standards-Version
-- Sebastian Ramacher <sramacher@debian.org> Mon, 05 Apr 2021 13:15:19 +0200
intel-gmmlib (20.4.1+ds1-1) unstable; urgency=medium
* New upstream release
-- Sebastian Ramacher <sramacher@debian.org> Sat, 02 Jan 2021 12:42:08 +0100
intel-gmmlib (20.3.3+ds1-1) unstable; urgency=medium
* New upstream release
-- Sebastian Ramacher <sramacher@debian.org> Sun, 15 Nov 2020 12:42:19 +0100
intel-gmmlib (20.3.2+ds1-1) unstable; urgency=medium
* New upstream release
-- Sebastian Ramacher <sramacher@debian.org> Fri, 18 Sep 2020 10:32:41 +0200
intel-gmmlib (20.2.4+ds1-1) unstable; urgency=medium
* New upstream version release
-- Sebastian Ramacher <sramacher@debian.org> Sun, 23 Aug 2020 10:47:02 +0200
intel-gmmlib (20.2.2+ds1-1) unstable; urgency=medium
* New upstream release
* debian/control: Bump debhelper compat to 13
* debian/copyright: Bump copyright years
-- Sebastian Ramacher <sramacher@debian.org> Mon, 29 Jun 2020 09:33:45 +0200
intel-gmmlib (20.1.1+ds1-1) unstable; urgency=medium
* New upstream release
* debian/control: Bump Standards-Version
-- Sebastian Ramacher <sramacher@debian.org> Mon, 06 Apr 2020 10:04:38 +0200
intel-gmmlib (19.4.1+ds1-1) unstable; urgency=medium
* New upstream release
-- Sebastian Ramacher <sramacher@debian.org> Mon, 23 Dec 2019 13:26:15 +0100
intel-gmmlib (19.3.3+ds1-1) unstable; urgency=medium
* New upstream release.
* debian/rules: Revert "Do not run tests on i386"
-- Sebastian Ramacher <sramacher@debian.org> Fri, 01 Nov 2019 09:33:40 +0100
intel-gmmlib (19.3.2+ds1-3) unstable; urgency=medium
* debian/rules: Do not run tests on i386 until fixed upstream
-- Sebastian Ramacher <sramacher@debian.org> Sun, 13 Oct 2019 14:59:32 +0200
intel-gmmlib (19.3.2+ds1-2) unstable; urgency=medium
* Upload to unstable
* debian/control: Bump Standards-Version
-- Sebastian Ramacher <sramacher@debian.org> Sun, 13 Oct 2019 14:25:07 +0200
intel-gmmlib (19.3.2+ds1-1) experimental; urgency=medium
* New upstream release.
* SONAME bump: libigdgmm9 -> libigdgmm11.
* debian/copyright: Update copyright years.
-- Sebastian Ramacher <sramacher@debian.org> Sun, 22 Sep 2019 23:13:14 +0200
intel-gmmlib (19.2.4+ds1-1) unstable; urgency=medium
* New upstream release.
-- Sebastian Ramacher <sramacher@debian.org> Wed, 04 Sep 2019 19:56:34 +0200
intel-gmmlib (19.2.3+ds1-2) unstable; urgency=medium
* Upload to unstable.
* debian/control: Bump Standards-Version.
-- Sebastian Ramacher <sramacher@debian.org> Sun, 07 Jul 2019 18:43:00 +0200
intel-gmmlib (19.2.3+ds1-1) experimental; urgency=medium
* New upstream release.
* SONAME bump: libigdgmm5 -> libigdgmm9.
* debian/patches: Refresh patches.
* debian/: Bump debhelper compat to 12.
* debian/control:
- Bump Standards-Version.
- Set RRR: no.
* debian/libigdgmm-dev.install: Remove static library, no longer built
upstream.
-- Sebastian Ramacher <sramacher@debian.org> Sun, 07 Jul 2019 11:05:49 +0200
intel-gmmlib (18.4.1+ds1-1) unstable; urgency=medium
* New upstream release.
* Upload to unstable.
-- Sebastian Ramacher <sramacher@debian.org> Sun, 16 Dec 2018 23:43:34 +0100
intel-gmmlib (18.4.0+ds1-1) experimental; urgency=medium
* New upstream release.
* SONAME bump: libigdgmm1 -> libigdgmm5.
* debian/patches: Refresh.
* debian/control:
- Drop dependency on libspdlog-dev from libigdgmm-dev.
spdlog is no longer used in the public header files.
- Remove incorrect Section from libigdgmm5.
-- Sebastian Ramacher <sramacher@debian.org> Wed, 12 Dec 2018 20:44:45 +0100
intel-gmmlib (18.3.0+ds1-2) unstable; urgency=medium
* debian/control: Remove libspdlog-dev from libigdgmm1's Depends.
-- Sebastian Ramacher <sramacher@debian.org> Mon, 03 Dec 2018 22:42:02 +0100
intel-gmmlib (18.3.0+ds1-1) unstable; urgency=medium
* Initial release (Closes: #909983)
-- Sebastian Ramacher <sramacher@debian.org> Wed, 14 Nov 2018 22:57:13 +0100

60
debian/control vendored
View File

@ -1,19 +1,47 @@
Source: upstream-name
Section: admin
Source: intel-gmmlib
Section: libs
Priority: optional
Maintainer: name <email>
Standards-Version: 4.6.1
Build-Depends: debhelper-compat (= 13)
Maintainer: Debian Multimedia Maintainers <debian-multimedia@lists.debian.org>
Uploaders:
Sebastian Ramacher <sramacher@debian.org>,
Timo Aaltonen <tjaalton@debian.org>
Build-Depends:
debhelper-compat (= 13),
cmake,
libspdlog-dev
Standards-Version: 4.6.2
Homepage: https://github.com/intel/gmmlib
Vcs-Browser: https://salsa.debian.org/multimedia-team/intel-gmmlib
Vcs-Git: https://salsa.debian.org/multimedia-team/intel-gmmlib.git
Rules-Requires-Root: no
Package: pkgname1
Architecture: linux-any
# Delete any of these lines if un-used
Depends: ${misc:Depends}, depends
Recommends: high priority optdepends
Conflicts: conflicts
Suggests: low priority optdepends
Breaks: also conflicts!?
Provides: provides
#
Description: pkgdesc
Package: libigdgmm12
Architecture: amd64 i386 x32
Multi-Arch: same
Depends:
${misc:Depends},
${shlibs:Depends}
Description: Intel Graphics Memory Management Library -- shared library
The Intel Graphics Memory Management Library provides device specific
and buffer management for the Intel Graphics Compute Runtime for
OpenCL and the Intel Media Driver for VAAPI.
.
This library is only useful for Broadwell and newer CPUs.
.
This package includes the shared library.
Package: libigdgmm-dev
Section: libdevel
Architecture: amd64 i386 x32
Multi-Arch: same
Depends:
libigdgmm12 (= ${binary:Version}),
${misc:Depends}
Description: Intel Graphics Memory Management Library -- development files
The Intel Graphics Memory Management Library provides device specific
and buffer management for the Intel Graphics Compute Runtime for
OpenCL and the Intel Media Driver for VAAPI.
.
This library is only useful for Broadwell and newer CPUs.
.
This package includes files for development.

59
debian/copyright vendored
View File

@ -0,0 +1,59 @@
Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
Upstream-Name: gmmlib
Source: https://github.com/intel/gmmlib
Files-Excluded: Source/GmmLib/Utility/GmmLog/spdlog/*
Files: *
Copyright: 2005-2021, Intel Corporation
License: Expat
Files: Source/GmmLib/ULT/googletest/*
Copyright: 2003-2009, Google Inc
License: BSD-3-clause
Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are met:
.
* Redistributions of source code must retain the above copyright notice,
this list of conditions and the following disclaimer.
* Redistributions in binary form must reproduce the above copyright notice,
this list of conditions and the following disclaimer in the documentation
and/or other materials provided with the distribution.
* The names of its contributors may not be used to endorse or promote
products derived from this software without specific prior written
permission.
.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
Files: debian/*
Copyright: 2018 Timo Aaltonen <tjaalton@debian.org>
2018-2021 Sebastian Ramacher <sramacher@debian.org>
License: Expat
License: Expat
Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and associated documentation files (the
"Software"), to deal in the Software without restriction, including
without limitation the rights to use, copy, modify, merge, publish,
distribute, sublicense, and/or sell copies of the Software, and to
permit persons to whom the Software is furnished to do so, subject to
the following conditions:
.
The above copyright notice and this permission notice shall be included
in all copies or substantial portions of the Software.
.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

3
debian/libigdgmm-dev.install vendored Normal file
View File

@ -0,0 +1,3 @@
usr/include
usr/lib/*/*.so
usr/lib/*/pkgconfig/igdgmm.pc

1
debian/libigdgmm12.install vendored Normal file
View File

@ -0,0 +1 @@
usr/lib/*/libigdgmm.so.*

84
debian/rules vendored
View File

@ -1,80 +1,10 @@
#! /usr/bin/make -f
#!/usr/bin/make -f
## See debhelper(7) (uncomment to enable).
## Output every command that modifies files on the build system.
export DH_VERBOSE = 1
## === Set paths env vars ===
## Source directory, called upon by $(srcdir)
srcdir = $(shell debian/scripts/get_pwd.sh)
## The Root of package number one, called upon by $(pkgdir1)
pkgdir1 = $(srcdir)/debian/pkgdir1
## The Root of package number two, you can add as many of these as you like
pkgdir2 = $(srcdir)/debian/pkgdir2
## If building a singular package you can remove the number, and as you guessed you call upon it with $(pkgdir)
# pkgdir = $(srcdir)/debian/pkgdir
## === End end of region ===
## === the chain of command ===
## debuild runs a chain of dh functions in the following order:
## dh_testdir
## dh_clean
## dh_auto_clean
## dh_update_autotools_config
## dh_autoreconf
## dh_auto_configure
## dh_prep
## dh_build
## dh_auto_build
## dh_install
## dh_auto_install
## dh_installdocs
## dh_installchangelogs
## dh_perl
## dh_link
## dh_strip_nondeterminism
## dh_compress
## dh_fixperms
## dh_missing
## dh_dwz
## dh_strip
## dh_makeshlibs
## dh_shlibdeps
## dh_installdeb
## dh_gencontrol
## but you are most likely to only need to override the following:
## dh_clean
## dh_auto_configure
## dh_build
## dh_install
## === End end of region ===
## === overriding dh functions ===
## by default all dh functions will run a specific command based on the build system selected by "dh $@"
## if you have a makefile that does everything you need this is fine,
## but most likely you have no MakeFile and you want to add your own commands
## Note : overrides must be places above %:
## So here's a few examples:
## overriding dh_clean to make it not delete rust vendor files:
#override_dh_clean:
# echo "disabled"
## overriding dh_auto_configure to add custom configs:
#override_dh_auto_configure:
# $(srcdir)/configure -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_DATADIR=/usr/share -DCMAKE_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu -DBUILD_PLUGIN=OFF
## overriding dh_install to install files to a package:
#override_dh_auto_configure:
# mkdir -p $(pkgdir1)/usr/bin
# cp $(srcdir)/pikman $(pkgdir1)/usr/bin/
## === End end of region ===
## This here will start the build:
%:
dh $@
override_dh_auto_test:
ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS)))
# Requires Broadwell or newer, so check for SSE 4.2 support at least.
if grep -q sse4_2 /proc/cpuinfo; then dh_auto_test; fi
endif

View File

@ -1,2 +0,0 @@
#! /bin/sh
env | grep -w "PWD" | cut -c5-

4
debian/upstream/metadata vendored Normal file
View File

@ -0,0 +1,4 @@
---
Bug-Database: https://github.com/intel/gmmlib/issues
Bug-Submit: https://github.com/intel/gmmlib/issues/new
Repository-Browse: https://github.com/intel/gmmlib

4
debian/watch vendored Normal file
View File

@ -0,0 +1,4 @@
version=4
opts="uversionmangle=s/.pre/~pre/,dversionmangle=s/@DEB_EXT@//,repacksuffix=+ds1" \
https://github.com/intel/gmmlib/tags \
(?:.*?/)intel-gmmlib@ANY_VERSION@\.tar\.gz

View File

@ -3,9 +3,9 @@
DEBIAN_FRONTEND=noninteractive
# Clone Upstream
mkdir -p ./src-pkg-name
cp -rvf ./debian ./src-pkg-name/
cd ./src-pkg-name/
git clone https://github.com/intel/gmmlib ./intel-gmmlib -b intel-gmmlib-22.3.12
cp -rvf ./debian ./intel-gmmlib/
cd ./intel-gmmlib/
# Get build deps
apt-get build-dep ./ -y

View File

@ -0,0 +1,21 @@
From: Timo Aaltonen <tjaalton@debian.org>
Date: Wed, 14 Nov 2018 22:01:43 +0100
Subject: Use packaged spdlog
---
Source/GmmLib/inc/Internal/Common/GmmLogger.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Source/GmmLib/inc/Internal/Common/GmmLogger.h b/Source/GmmLib/inc/Internal/Common/GmmLogger.h
index a643e26..52b2eee 100644
--- a/Source/GmmLib/inc/Internal/Common/GmmLogger.h
+++ b/Source/GmmLib/inc/Internal/Common/GmmLogger.h
@@ -25,7 +25,7 @@ OTHER DEALINGS IN THE SOFTWARE.
#ifdef __cplusplus
#if GMM_LOG_AVAILABLE
-#include "spdlog/spdlog.h"
+#include <spdlog/spdlog.h>
/////////////////////////////////////////////////////////////////////////////////////
/// @file Logger.h

View File

@ -0,0 +1,28 @@
From: Sebastian Ramacher <sramacher@debian.org>
Date: Wed, 14 Nov 2018 22:07:54 +0100
Subject: Integrate into cmake's test framework
---
Source/GmmLib/ULT/CMakeLists.txt | 9 ---------
1 file changed, 9 deletions(-)
diff --git a/Source/GmmLib/ULT/CMakeLists.txt b/Source/GmmLib/ULT/CMakeLists.txt
index 52e0944..b066854 100644
--- a/Source/GmmLib/ULT/CMakeLists.txt
+++ b/Source/GmmLib/ULT/CMakeLists.txt
@@ -163,15 +163,6 @@ target_link_libraries(${EXE_NAME}
dl
)
-add_custom_target(Run_ULT ALL DEPENDS GMMULT)
-
-add_custom_command(
- TARGET Run_ULT
- POST_BUILD
- COMMAND echo running ULTs
- COMMAND "${CMAKE_COMMAND}" -E env "LD_LIBRARY_PATH=$<TARGET_FILE_DIR:igfx_gmmumd_dll>" ${CMAKE_CFG_INTDIR}/${EXE_NAME} --gtest_filter=CTest*
-)
-
add_test(
NAME ULT
COMMAND env "LD_LIBRARY_PATH=$<TARGET_FILE_DIR:igfx_gmmumd_dll>" $<TARGET_FILE:${EXE_NAME}> --gtest_filter=CTest*

2
patches/series Normal file
View File

@ -0,0 +1,2 @@
0001-Use-packaged-spdlog.patch
0002-Integrate-into-cmake-s-test-framework.patch