This commit is contained in:
parent
0657015ab0
commit
294e1f7e62
6
debian/changelog
vendored
6
debian/changelog
vendored
@ -1,3 +1,9 @@
|
|||||||
|
xwayland (2:23.2.1-100pika1) pikauwu; urgency=medium
|
||||||
|
|
||||||
|
* Update to pikauwu
|
||||||
|
|
||||||
|
-- Ward Nakchbandi <hotrod.master@hotmail.com> Thu, 04 Oct 2022 17:50:00 +0300
|
||||||
|
|
||||||
xwayland (2:23.2.0-99pika1.lunar) lunar; urgency=medium
|
xwayland (2:23.2.0-99pika1.lunar) lunar; urgency=medium
|
||||||
|
|
||||||
* Update to lunar
|
* Update to lunar
|
||||||
|
3
debian/patches/series
vendored
3
debian/patches/series
vendored
@ -1,2 +1 @@
|
|||||||
0001-xwayland-patch-fix-vsync.patch
|
0001-xwayland-patch-fix-vsync.patch
|
||||||
xwayland-cursor-wrap-fix.patch
|
|
34
debian/patches/xwayland-cursor-wrap-fix.patch
vendored
34
debian/patches/xwayland-cursor-wrap-fix.patch
vendored
@ -1,34 +0,0 @@
|
|||||||
From fdc71a08f059d2466e39968652c3df71cc582b3e Mon Sep 17 00:00:00 2001
|
|
||||||
From: GloriousEggroll <gloriouseggroll@gmail.com>
|
|
||||||
Date: Sun, 21 May 2023 03:34:46 -0600
|
|
||||||
Subject: [PATCH] xwayland pointer warp fix
|
|
||||||
|
|
||||||
---
|
|
||||||
hw/xwayland/xwayland-input.c | 5 ++---
|
|
||||||
1 file changed, 2 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/hw/xwayland/xwayland-input.c b/hw/xwayland/xwayland-input.c
|
|
||||||
index 34dd3c8..f7fa737 100644
|
|
||||||
--- a/hw/xwayland/xwayland-input.c
|
|
||||||
+++ b/hw/xwayland/xwayland-input.c
|
|
||||||
@@ -3202,9 +3202,6 @@ xwl_seat_emulate_pointer_warp(struct xwl_seat *xwl_seat,
|
|
||||||
if (!xwl_seat_can_emulate_pointer_warp(xwl_seat))
|
|
||||||
return;
|
|
||||||
|
|
||||||
- if (xwl_seat->x_cursor != NULL)
|
|
||||||
- return;
|
|
||||||
-
|
|
||||||
if (!xwl_seat->pointer_warp_emulator)
|
|
||||||
xwl_seat_create_pointer_warp_emulator(xwl_seat);
|
|
||||||
|
|
||||||
@@ -3215,6 +3212,8 @@ xwl_seat_emulate_pointer_warp(struct xwl_seat *xwl_seat,
|
|
||||||
xwl_window,
|
|
||||||
sprite,
|
|
||||||
x, y);
|
|
||||||
+ if (xwl_seat->x_cursor != NULL)
|
|
||||||
+ xwl_seat_destroy_pointer_warp_emulator(xwl_seat);
|
|
||||||
}
|
|
||||||
|
|
||||||
static Bool
|
|
||||||
--
|
|
||||||
2.40.1
|
|
4
main.sh
4
main.sh
@ -1,5 +1,5 @@
|
|||||||
# Clone Upstream
|
# Clone Upstream
|
||||||
git clone https://gitlab.freedesktop.org/xorg/xserver.git ./xwayland -b xwayland-23.2.0
|
git clone https://gitlab.freedesktop.org/xorg/xserver.git ./xwayland -b xwayland-23.2.1
|
||||||
cp -rvf ./debian ./xwayland/
|
cp -rvf ./debian ./xwayland/
|
||||||
cd ./xwayland
|
cd ./xwayland
|
||||||
|
|
||||||
@ -8,7 +8,7 @@ apt upgrade -y
|
|||||||
apt-get build-dep ./ -y
|
apt-get build-dep ./ -y
|
||||||
|
|
||||||
# Build package
|
# Build package
|
||||||
LOGNAME=root dh_make --createorig -y -l -p xwayland_23.2.0
|
LOGNAME=root dh_make --createorig -y -l -p xwayland_23.2.1
|
||||||
dpkg-buildpackage --no-sign
|
dpkg-buildpackage --no-sign
|
||||||
|
|
||||||
# Move the debs to output
|
# Move the debs to output
|
||||||
|
@ -2,7 +2,7 @@
|
|||||||
rsync -azP --include './' --include '*.deb' --exclude '*' ./output/ ferreo@direct.pika-os.com:/srv/www/incoming/
|
rsync -azP --include './' --include '*.deb' --exclude '*' ./output/ ferreo@direct.pika-os.com:/srv/www/incoming/
|
||||||
|
|
||||||
# add debs to repo
|
# add debs to repo
|
||||||
ssh ferreo@direct.pika-os.com 'aptly repo add -force-replace -remove-files pika-main /srv/www/incoming/'
|
ssh ferreo@direct.pika-os.com 'aptly repo add -force-replace -remove-files pikauwu-main /srv/www/incoming/'
|
||||||
|
|
||||||
# publish the repo
|
# publish the repo
|
||||||
ssh ferreo@direct.pika-os.com 'aptly publish update -batch -skip-contents -force-overwrite lunar filesystem:pikarepo:'
|
ssh ferreo@direct.pika-os.com 'aptly publish update -batch -skip-contents -force-overwrite pikauwu filesystem:pikarepo:'
|
Loading…
Reference in New Issue
Block a user