attempt to fix xwayland frac scale: 1
Some checks failed
PikaOS Package Build & Release (Canary) (amd64-v3) / build (push) Has been cancelled
PikaOS Package Build & Release (amd64-v3) / build (push) Successful in 1m26s

This commit is contained in:
Ward from fusion-voyager-3 2024-08-13 12:10:50 -04:00
parent e886a7bc0a
commit 57cb727c2f
31 changed files with 2697 additions and 247 deletions

View File

@ -1 +0,0 @@
1

View File

@ -1 +0,0 @@
1

View File

@ -1 +0,0 @@
1

View File

@ -1 +0,0 @@
1

View File

@ -1 +1 @@
1
2

View File

@ -1,37 +0,0 @@
name: PikaOS Package Build Only (Canary) (i386)
on:
push:
branches:
- main
paths:
- '.github/build-canary-i386'
jobs:
build:
runs-on: ubuntu-latest
container:
image: ghcr.io/pikaos-linux/pikaos-builder:canaryi386
volumes:
- /proc:/proc
options: --privileged -it
steps:
- uses: actions/checkout@v3
- name: Install SSH key
uses: shimataro/ssh-key-action@v2
with:
key: ${{ secrets.SSH_KEY }}
name: id_rsa
known_hosts: ${{ secrets.KNOWN_HOSTS }}
if_key_exists: replace
- name: Update APT Cache
run: apt-get update -y
- name: Set Build Config
run: cp -vf ./pika-build-config/i386.sh ./pika-build-config.sh
- name: Build Package
run: ./main.sh

View File

@ -1,37 +0,0 @@
name: PikaOS Package Build Only (i386)
on:
push:
branches:
- main
paths:
- '.github/build-nest-i386'
jobs:
build:
runs-on: ubuntu-latest
container:
image: ghcr.io/pikaos-linux/pikaos-builder:nesti386
volumes:
- /proc:/proc
options: --privileged -it
steps:
- uses: actions/checkout@v3
- name: Install SSH key
uses: shimataro/ssh-key-action@v2
with:
key: ${{ secrets.SSH_KEY }}
name: id_rsa
known_hosts: ${{ secrets.KNOWN_HOSTS }}
if_key_exists: replace
- name: Update APT Cache
run: apt-get update -y
- name: Set Build Config
run: cp -vf ./pika-build-config/i386.sh ./pika-build-config.sh
- name: Build Package
run: ./main.sh

View File

@ -1,40 +0,0 @@
name: PikaOS Package Build & Release (Canary) (i386)
on:
push:
branches:
- main
paths:
- '.github/release-canary-i386'
jobs:
build:
runs-on: ubuntu-latest
container:
image: ghcr.io/pikaos-linux/pikaos-builder:canaryi386
volumes:
- /proc:/proc
options: --privileged -it
steps:
- uses: actions/checkout@v3
- name: Install SSH key
uses: shimataro/ssh-key-action@v2
with:
key: ${{ secrets.SSH_KEY }}
name: id_rsa
known_hosts: ${{ secrets.KNOWN_HOSTS }}
if_key_exists: replace
- name: Update APT Cache
run: apt-get update -y
- name: Set Build Config
run: cp -vf ./pika-build-config/i386.sh ./pika-build-config.sh
- name: Build Package
run: ./main.sh
- name: Release Package
run: ./release.sh

View File

@ -1,40 +0,0 @@
name: PikaOS Package Build & Release (i386)
on:
push:
branches:
- main
paths:
- '.github/release-nest-i386'
jobs:
build:
runs-on: ubuntu-latest
container:
image: ghcr.io/pikaos-linux/pikaos-builder:nesti386
volumes:
- /proc:/proc
options: --privileged -it
steps:
- uses: actions/checkout@v3
- name: Install SSH key
uses: shimataro/ssh-key-action@v2
with:
key: ${{ secrets.SSH_KEY }}
name: id_rsa
known_hosts: ${{ secrets.KNOWN_HOSTS }}
if_key_exists: replace
- name: Update APT Cache
run: apt-get update -y
- name: Set Build Config
run: cp -vf ./pika-build-config/i386.sh ./pika-build-config.sh
- name: Build Package
run: ./main.sh
- name: Release Package
run: ./release.sh

2033
debian/changelog vendored

File diff suppressed because it is too large Load Diff

1
debian/clean vendored Normal file
View File

@ -0,0 +1 @@
tests/__pycache__/

134
debian/control vendored
View File

@ -1,19 +1,121 @@
Source: upstream-name
Section: admin
Source: gnome-settings-daemon
Section: gnome
Priority: optional
Maintainer: name <email>
Standards-Version: 4.6.1
Build-Depends: debhelper-compat (= 13)
Maintainer: Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Uploaders: Amin Bandali <bandali@ubuntu.com>,
Gunnar Hjalmarsson <gunnarhj@debian.org>,
Jeremy Bícha <jbicha@ubuntu.com>,
Laurent Bigonville <bigon@debian.org>,
Marco Trevisan (Treviño) <marco@ubuntu.com>
Build-Depends: debhelper-compat (= 13),
dh-exec,
dh-sequence-gnome,
gir1.2-umockdev-1.0 [!hurd-any !alpha !hppa !loong64 !powerpc !ppc64] <!nocheck>,
gnome-session-bin [!hurd-any !alpha !hppa !loong64 !powerpc !ppc64] <!nocheck>,
gsettings-desktop-schemas-dev (>= 46~beta),
gtk-doc-tools,
intltool,
libasound2-dev [linux-any],
libcanberra-gtk3-dev,
libcolord-dev [linux-any],
libcups2-dev,
libfontconfig-dev,
libgcr-4-dev [linux-any],
libgeoclue-2-dev,
libgeocode-glib-dev (>= 3.26.3),
libglib2.0-dev,
libglib2.0-dev:native,
libgnome-desktop-3-dev,
libgtk-3-dev,
libgudev-1.0-dev [linux-any],
libgweather-4-dev (>= 4.1),
libibus-1.0-dev,
liblcms2-dev,
libmm-glib-dev [linux-any],
libnm-dev [linux-any],
libnotify-dev,
libpackagekit-glib2-dev,
libpolkit-gobject-1-dev (>= 0.114),
libpulse-dev,
libsystemd-dev [linux-any],
libupower-glib-dev (>= 0.99.12),
libwacom-dev [!hurd-any !s390 !s390x],
libx11-dev,
libxext-dev,
libxfixes-dev (>= 1:6.0),
libxi-dev,
libxt-dev,
meson,
mutter [!hurd-any !alpha !hppa !loong64 !powerpc !ppc64] <!nocheck>,
polkitd,
python3-dbusmock <!nocheck>,
python3-gi <!nocheck>,
systemd-dev [linux-any],
udev [linux-any] <!nocheck>,
umockdev [!hurd-any !alpha !hppa !loong64 !powerpc !ppc64] <!nocheck>,
xauth <!nocheck>,
xkb-data,
xserver-xorg-input-wacom [!hurd-any !s390 !s390x],
xvfb <!nocheck>
Standards-Version: 4.7.0
Homepage: https://gitlab.gnome.org/GNOME/gnome-settings-daemon
Vcs-Git: https://salsa.debian.org/gnome-team/gnome-settings-daemon.git
Vcs-Browser: https://salsa.debian.org/gnome-team/gnome-settings-daemon
Rules-Requires-Root: no
Package: pkgname1
Architecture: linux-any
# Delete any of these lines if un-used
Depends: ${misc:Depends}, depends
Recommends: high priority optdepends
Conflicts: conflicts
Suggests: low priority optdepends
Breaks: also conflicts!?
Provides: provides
#
Description: pkgdesc
Package: gnome-settings-daemon
Architecture: any
Depends: default-logind [linux-any] | logind [linux-any],
gnome-settings-daemon-common (= ${source:Version}),
gsettings-desktop-schemas (>= 46~beta),
libspa-0.2-bluetooth | pulseaudio-module-bluetooth,
pipewire-audio | pulseaudio,
${misc:Depends},
${shlibs:Depends}
Recommends: iio-sensor-proxy,
pipewire-audio,
pkexec,
x11-xserver-utils
Suggests: usbguard
Breaks: gnome-control-center (<< 1:41.4-2~),
libgtk-4-0 (<< 3.99.1~),
libmutter-6-0 (<< 3.37),
libmutter-7-0 (<< 3.39)
Description: daemon handling the GNOME session settings
This package contains the daemon which is responsible for setting the
various parameters of a GNOME session and the applications that run
under it. It handles the following kinds of settings:
.
* Keyboard: layout, accessibility options, shortcuts, media keys
* Clipboard management
* Theming: background, icons, GTK+ applications
* Cleanup of unused files
* Mouse: cursors, speed, accessibility options
* Startup of other daemons: screensaver, sound daemon
.
It also sets various application settings through X resources and
freedesktop.org XSETTINGS.
Package: gnome-settings-daemon-common
Architecture: all
Depends: ${misc:Depends}
Replaces: gnome-settings-daemon-schemas (<< 3.30.1.2-2~)
Breaks: gnome-settings-daemon-schemas (<< 3.30.1.2-2~)
Provides: gnome-settings-daemon-schemas (= ${source:Version})
Description: daemon handling the GNOME session settings - common files
This package contains GSettings schemas and other architecture-independent
files for GNOME Settings Daemon. It is probably not interesting on its own for
end users, but packages may depend on this if they only need to read and write
settings & don't themselves care if the settings daemon is actually running or
not.
Package: gnome-settings-daemon-dev
Section: libdevel
Architecture: any
Multi-Arch: same
Depends: libglib2.0-dev,
${misc:Depends},
${shlibs:Depends}
Description: Headers for building applications communicating with gnome-settings-daemon
This package contains header files required to build applications that
communicate with the GNOME settings daemon over D-Bus.

167
debian/copyright vendored
View File

@ -0,0 +1,167 @@
This package was debianized by Sebastien Bacher <seb128@canonical.com> on
Wed, 16 Jan 2008 11:12:19 +0100.
It was downloaded from https://download.gnome.org/sources/gnome-settings-daemon
Upstream Authors:
Jonathan Blandford <jrb@redhat.com>
William Jon McCann <mccann@jhu.edu>
Copyright:
Copyright © 1998-2000 Kenneth Christiansen
Copyright © 1998-2001 Pablo Saratxaga
Copyright © 1998, 2001 Tim Janik
Copyright © 1999-2018 Free Software Foundation, Inc.
Copyright © 2000-2005 Martin Willemoes Hansen
Copyright © 2000 Dennis Smit
Copyright © 2000 Keld Simonsen
Copyright © 2001-2006 Ole Laursen
Copyright © 2001 Almer S. Tigelaar
Copyright © 2001 Carlos Perelló Marín
Copyright © 2001 Héctor García Álvarez
Copyright © 2001 Jonathan Blandford <jrb@gnome.org>
Copyright © 2001 Red Hat, Inc.
Copyright © 2001 Udaltsoft
Copyright © 2001 Ximian, Inc.
Copyright © 2002-2003 Pablo Gonzalo del Campo
Copyright © 2002-2013 Reinout van Schouwen
Copyright © 2002 Germán Poo Caamaño
Copyright © 2002 Huib Kleinhout
Copyright © 2002 Jan-Willem Harmanny
Copyright © 2002 Lucas Di Pentima
Copyright © 2002 Ronald Hummelink
Copyright © 2002 Sun Microsystems, Inc.
Copyright © 2003-2006 Francisco Javier F. Serrador
Copyright © 2003-2017 Prevod.org team
Copyright © 2004-2008 Tino Meinen
Copyright © 2004 Red Hat, Inc.
Copyright © 2005,2006 Novell, Inc.
Copyright © 2005 Данило Шеган (Danilo Šegan)
Copyright © 2006-2011 Wouter Bolsterlee
Copyright © 2006 Lasse Bang Mikkelsen
Copyright © 2006 Слободан Д. Средојевић (Slobodan D. Sredojević)
Copyright © 2007-2011 Jorge González
Copyright © 2007-2018 Ask Hjorth Larsen
Copyright © 2007 Claudio Saavedra
Copyright © 2007 Matthias Clasen
Copyright © 2007 The GNOME Foundation
Copyright © 2009 Johannes Berg <johannes@sipsolutions.net>
Copyright © 2010-2015 Милош Поповић (Miloš Popović)
Copyright © 2010-2017 Hannie Dumoleyn
Copyright © 2010 Bastien Nocera <hadess@hadess.net>
Copyright © 2010 Rob van den Berg
Copyright © 2011-2017 Мирослав Николић (Miroslav Nikolić)
Copyright © 2011-2018 Daniel Mustieles
Copyright © 2011 flemming christensen
Copyright © 2011 Red Hat, Inc.
Copyright © 2011 Redmar
Copyright © 2011 Sebi Kul
Copyright © 2012 Kenneth Nielsen
Copyright © 2013 Canonical Ltd.
Copyright © 2013 Intel Corporation.
Copyright © 2015-2016 Nathan Follens
Copyright © 2016-2018 Justin van Steijn
Copyright © 2016 scootergrisen
Copyright © 2017 Endless Mobile, Inc.
Copyright © 2017 Endless Mobile, Inc.
Copyright © Bas Wagter
Copyright © Birger Langkjer
Copyright (C) 2000-2001 Ximian, Inc.
Copyright (C) 2000 Helix Code, Inc
Copyright (C) 2001, 2002, 2003 Bastien Nocera
Copyright (C) 2001-2003 Bastien Nocera <hadess@hadess.net>
Copyright (C) 2001-2006 Jonathan Blandford <jrb@alum.mit.edu>
Copyright (C) 2001 Bastien Nocera <hadess@hadess.net>
Copyright (C) 2002-2005 - Paolo Maggi
Copyright (C) 2002 Red Hat, Inc.
Copyright (C) 2003 Ross Burton <ross@burtonini.com>
Copyright (C) 2005-2011 Richard Hughes <richard@hughsie.com>
Copyright (C) 2005 Paolo Maggi
Copyright (C) 2005 William Jon McCann <mccann@jhu.edu>
Copyright (C) 2006-2007 Ivo van Doorn
Copyright (C) 2006-2007 William Jon McCann <mccann@jhu.edu>
Copyright (C) 2006-2008 Lennart Poettering
Copyright (C) 2006 Emmanuele Bassi <ebassi@gnome.org>
Copyright (C) 2007 Anders Carlsson
Copyright (C) 2007 Dmitry Torokhov
Copyright (C) 2007 Matthias Clasen
Copyright (C) 2007 Rodrigo Moya
Copyright (C) 2007 William Jon McCann <mccann@jhu.edu>
Copyright (C) 2008-2009 Red Hat, Inc.
Copyright (C) 2008-2012 Cosimo Cecchi <cosimoc@gnome.org>
Copyright (C) 2008 Carlos Garnacho <carlos@imendio.com>
Copyright (C) 2008 Lennart Poettering <lennart@poettering.net>
Copyright (C) 2008 Michael J. Chudobiak <mjc@avtechpulse.com>
Copyright (c) 2008, Novell, Inc.
Copyright (C) 2008 Sjoerd Simons <sjoerd@luon.net>
Copyright (C) 2008 Soren Sandmann <sandmann@redhat.com>
Copyright (C) 2008 William Jon McCann
Copyright (C) 2008 William Jon McCann <jmccann@redhat.com>
Copyright (C) 2009 Bastien Nocera
Copyright (C) 2010,2011 Red Hat, Inc.
Copyright (C) 2010 Bastien Nocera <hadess@hadess.net>
Copyright (C) 2011 Bastien Nocera <hadess@hadess.net>
Copyright (C) 2011 Ritesh Khadgaray <khadgaray@gmail.com>
Copyright (C) 2012-2013 Red Hat Inc.
Copyright (C) 2012 Bastien Nocera <hadess@hadess.net>
Copyright (C) 2012 Conor Curran
Copyright (C) 2012 David Henningsson, Canonical Ltd. <david.henningsson@canonical.com>
Copyright (C) 2012 Przemo Firszt <przemo@firszt.eu>
Copyright (C) 2013 Carlos Garnacho <carlosg@gnome.org>
Copyright (C) 2013 Kalev Lember <kalevlember@gmail.com>
Copyright (C) 2013 Przemo Firszt <przemo@firszt.eu>
Copyright (C) 2014 Bastien Nocera <hadess@hadess.net>
Copyright (C) 2014 Carlos Garnacho <carlosg@gnome.org>
Copyright (C) 2014 Red Hat, Inc.
Copyright (C) 2015 Red Hat
Copyright (C) 2017 Bastien Nocera <hadess@hadess.net>
Copyright (C) 2017 Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
Copyright (C) 2017 Richard Hughes <richard@hughsie.com>
Copyright (C) Conor Curran 2011 <conor.curran@canonical.com>
Copyright © Hein-Jan Leliveld
Copyright © Вељко М. Станојевић (Veljko M. Stanojević)
License:
This package is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2 of the License, or
(at your option) any later version.
This package is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
along with this package; if not, write to the Free Software
Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
On Debian systems, the complete text of the GNU General
Public License can be found in `/usr/share/common-licenses/GPL'.
eggaccelerators.h, eggaccelerators.c
License:
This package is free software; you can redistribute it and/or
modify it under the terms of the GNU Lesser General Public
License as published by the Free Software Foundation; either
version 2 of the License, or (at your option) any later version.
This package is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Lesser General Public License for more details.
You should have received a copy of the GNU Lesser General Public
License along with this package; if not, write to the Free Software
Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
On Debian systems, the complete text of the GNU Lesser General
Public License can be found in `/usr/share/common-licenses/LGPL'.
The Debian packaging is (C) 2008, Sebastien Bacher <seb128@canonical.com> and
is licensed under the GPL, see above.

4
debian/docs vendored Normal file
View File

@ -0,0 +1,4 @@
AUTHORS
NEWS
README
TODO

17
debian/gbp.conf vendored Normal file
View File

@ -0,0 +1,17 @@
[DEFAULT]
pristine-tar = True
debian-branch = debian/latest
upstream-branch = upstream/latest
[buildpackage]
sign-tags = True
[dch]
multimaint-merge = True
[import-orig]
postimport = dch -v%(version)s New upstream release; git add debian/changelog; debcommit
upstream-vcs-tag = %(version%~%.)s
[pq]
patch-numbers = False

6
debian/gnome-settings-daemon-common.install vendored Executable file
View File

@ -0,0 +1,6 @@
#!/usr/bin/dh-exec
usr/share/GConf
usr/share/glib-2.0
usr/share/locale
usr/lib/systemd/user
[linux-any] ${env:deb_udevdir}

View File

@ -0,0 +1,4 @@
# This package is installed automatically on GNOME systems, and not
# appropriate to install on non-GNOME systems, even if the machine happens
# to have rfkill devices
appstream-metadata-missing-modalias-provide */udev/rules.d/*

View File

@ -0,0 +1,2 @@
usr/include/gnome-settings-daemon-${env:GSD_MAJOR_VERSION}
usr/lib/pkgconfig/gnome-settings-daemon.pc usr/share/pkgconfig

2
debian/gnome-settings-daemon.docs vendored Normal file
View File

@ -0,0 +1,2 @@
AUTHORS
NEWS

6
debian/gnome-settings-daemon.install vendored Normal file
View File

@ -0,0 +1,6 @@
etc/xdg/Xwayland-session.d
etc/xdg/autostart
usr/lib/gnome-settings-daemon-${env:GSD_MAJOR_VERSION}
usr/libexec
usr/share/gnome-settings-daemon
usr/share/polkit-1

View File

@ -0,0 +1,2 @@
# #1031037
no-manual-page [usr/libexec/*]

109
debian/rules vendored
View File

@ -1,67 +1,56 @@
#! /usr/bin/make -f
#!/usr/bin/make -f
## See debhelper(7) (uncomment to enable).
## Output every command that modifies files on the build system.
export DH_VERBOSE = 1
export PIKA_BUILD_ARCH = $(shell cat ../pika-build-arch)
include /usr/share/dpkg/default.mk
## === the chain of command ===
## debuild runs a chain of dh functions in the following order:
## dh_testdir
## dh_clean
## dh_auto_clean
## dh_update_autotools_config
## dh_autoreconf
## dh_auto_configure
## dh_prep
## dh_build
## dh_auto_build
## dh_install
## dh_auto_install
## dh_installdocs
## dh_installchangelogs
## dh_perl
## dh_link
## dh_strip_nondeterminism
## dh_compress
## dh_fixperms
## dh_missing
## dh_dwz
## dh_strip
## dh_makeshlibs
## dh_shlibdeps
## dh_installdeb
## dh_gencontrol
## but you are most likely to only need to override the following:
## dh_clean
## dh_auto_configure
## dh_build
## dh_install
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
export DEB_LDFLAGS_MAINT_APPEND = -Wl,-z,defs -Wl,-O1 -Wl,--warn-unresolved-symbols
export DEB_LDFLAGS_MAINT_STRIP = -Wl,-Bsymbolic-functions
## === End end of region ===
export GSD_MAJOR_VERSION = $(shell echo $(DEB_VERSION_UPSTREAM) | cut -d~ -f1 | cut -d. -f1)
## === overriding dh functions ===
## by default all dh functions will run a specific command based on the build system selected by "dh $@"
## if you have a makefile that does everything you need this is fine,
## but most likely you have no MakeFile and you want to add your own commands
## Note : overrides must be places above %:
## So here's a few examples:
export deb_udevdir = $(shell pkg-config --variable=udevdir udev | sed s,^/,,)
## overriding dh_clean to make it not delete rust vendor files:
#override_dh_clean:
# echo "disabled"
## overriding dh_auto_configure to add custom configs:
#override_dh_auto_configure:
# $(srcdir)/configure -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_DATADIR=/usr/share -DCMAKE_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu -DBUILD_PLUGIN=OFF
## overriding dh_install to install files to a package:
#override_dh_auto_configure:
# mkdir -p debian/pikman/usr/bin
# cp pikman debian/pikman/usr/bin/
## === End end of region ===
## This here will start the build:
%:
dh $@
ifneq ($(DEB_HOST_ARCH_OS),linux)
CONFFLAGS = \
-Drfkill=false \
-Dnetwork_manager=false \
-Dalsa=false \
-Dcolord=false \
-Dgudev=false \
-Dsystemd=false \
-Dwayland=false \
-Dwwan=false
endif
override_dh_auto_configure:
dh_auto_configure -- \
--libdir=/usr/lib \
$(CONFFLAGS)
override_dh_auto_test:
# Ignore test failures on some architectures because they
# require working mutter & gnome-session.
# Similar skipping is being done in mutter
ifeq (,$(filter $(DEB_HOST_ARCH), mips64el riscv64))
xvfb-run --auto-servernum dh_auto_test
else
xvfb-run --auto-servernum dh_auto_test || true
endif
override_dh_installchangelogs:
dh_installchangelogs -XChangeLog
# The build system is not installing the polkit policy files on non-linux
# architectures even if the code requires libpolkit-gobject-1 library
ifneq ($(DEB_HOST_ARCH_OS),linux)
execute_before_dh_install:
grep -E -v 'polkit-1' debian/gnome-settings-daemon.install > debian/gnome-settings-daemon.install.$(DEB_HOST_ARCH_OS)
endif
execute_before_dh_clean:
rm -f debian/gnome-settings-daemon.install.$(DEB_HOST_ARCH_OS)
override_dh_gnome_clean:

1
debian/source/lintian-overrides vendored Normal file
View File

@ -0,0 +1 @@
dh-exec-subst-unknown-variable env:deb_udevdir [debian/*]

5
debian/upstream/metadata vendored Normal file
View File

@ -0,0 +1,5 @@
---
Bug-Database: https://gitlab.gnome.org/GNOME/gnome-settings-daemon/-/issues
Bug-Submit: https://gitlab.gnome.org/GNOME/gnome-settings-daemon/-/issues/new
Repository: https://gitlab.gnome.org/GNOME/gnome-settings-daemon.git
Repository-Browse: https://gitlab.gnome.org/GNOME/gnome-settings-daemon

4
debian/watch vendored Normal file
View File

@ -0,0 +1,4 @@
version=4
opts="searchmode=plain, uversionmangle=s/\.(alpha|beta|rc)/~$1/, downloadurlmangle=s|cache.json||" \
https://download.gnome.org/sources/@PACKAGE@/cache.json \
[\d.]+/@PACKAGE@-([\d.]+\.?(?:beta|rc)?[\d.]*)@ARCHIVE_EXT@

16
main.sh
View File

@ -2,22 +2,24 @@
set -e
. ./pika-build-config.sh
VERSION="46.0"
source ./pika-build-config.sh
echo "$PIKA_BUILD_ARCH" > pika-build-arch
VERSION="1.0"
# Clone Upstream
mkdir -p ./src-pkg-name
cp -rvf ./debian ./src-pkg-name/
cd ./src-pkg-name/
git clone --depth=1 https://gitlab.gnome.org/GNOME/gnome-settings-daemon -b "$VERSION"
cp -rvf ./debian ./gnome-settings-daemon
cd ./gnome-settings-daemon
for i in $(cat ../patches/series) ; do echo "Applying Patch: $i" && patch -Np1 -i ../patches/$i || echo "Applying Patch $i Failed!"; done
# Get build deps
LOGNAME=root dh_make --createorig -y -l -p src-pkg-name_"$VERSION" || echo "dh-make: Ignoring Last Error"
apt-get build-dep ./ -y
# Build package
LOGNAME=root dh_make --createorig -y -l -p gnome-settings-daemon_"$VERSION" || echo "dh-make: Ignoring Last Error"
dpkg-buildpackage --no-sign
# Move the debs to output

View File

@ -0,0 +1,58 @@
From: Laurent Bigonville <bigon@debian.org>
Date: Thu, 12 Mar 2020 18:05:51 +0100
Subject: Debianize the 00-xrdb script
In Debian, /etc/X11/Xresources is a directory, processing of ~/.Xresources
is controlled by /etc/X11/Xsession.options, and xrdb is not a mandatory
dependency.
Forwarded: not-needed, Debian-specific
---
plugins/xsettings/00-xrdb | 36 +++++++++++++++++++++++++++++++-----
1 file changed, 31 insertions(+), 5 deletions(-)
diff --git a/plugins/xsettings/00-xrdb b/plugins/xsettings/00-xrdb
index a047e8b..7fc8492 100755
--- a/plugins/xsettings/00-xrdb
+++ b/plugins/xsettings/00-xrdb
@@ -1,9 +1,35 @@
#!/bin/sh
-userresources=$HOME/.Xresources
-sysresources=/etc/X11/Xresources
+# This script mimic what /etc/X11/Xsession.d/30x11-common_xresources is doing
+# but for Xwayland
-# merge in defaults
-[ -r "$sysresources" ] && xrdb -nocpp -merge "$sysresources"
-[ -r "$userresources" ] && xrdb -merge "$userresources"
+USRRESOURCES=$HOME/.Xresources
+SYSRESOURCES=/etc/X11/Xresources
+OPTIONFILE=/etc/X11/Xsession.options
+# read OPTIONFILE
+OPTIONS=$(cat "$OPTIONFILE") || true
+
+has_option() {
+ if [ "${OPTIONS#*
+$1}" != "$OPTIONS" ]; then
+ return 0
+ else
+ return 1
+ fi
+}
+
+if [ -d "$SYSRESOURCES" ] && which xrdb >/dev/null 2>&1; then
+ RESOURCEFILES=$(run-parts --list $SYSRESOURCES)
+ if [ -n "$RESOURCEFILES" ]; then
+ for RESOURCEFILE in $RESOURCEFILES; do
+ xrdb -merge $RESOURCEFILE
+ done
+ fi
+fi
+
+if has_option allow-user-resources && [ -f "$USRRESOURCES" ]; then
+ if which xrdb >/dev/null 2>&1; then
+ xrdb -merge $USRRESOURCES
+ fi
+fi

View File

@ -0,0 +1,208 @@
From 325ea8da548bac876d7c707b616e1bb4190305f8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Jonas=20=C3=85dahl?= <jadahl@gmail.com>
Date: Wed, 13 Dec 2023 17:31:07 +0100
Subject: [PATCH] xsettings: Get UI scaling factor from dedicated D-Bus API
Instead of getting the UI scaling factor from the display configuration
API, get it from a new X11 properties API exposed by mutter.
---
plugins/xsettings/gsd-xsettings-manager.c | 140 ++++++++--------------
1 file changed, 53 insertions(+), 87 deletions(-)
diff --git a/plugins/xsettings/gsd-xsettings-manager.c b/plugins/xsettings/gsd-xsettings-manager.c
index f8ec6ebc..8a8f069f 100644
--- a/plugins/xsettings/gsd-xsettings-manager.c
+++ b/plugins/xsettings/gsd-xsettings-manager.c
@@ -609,81 +609,47 @@ get_dpi_from_gsettings (GsdXSettingsManager *manager)
return dpi * factor;
}
-static gboolean
-get_legacy_ui_scale (GVariantIter *properties,
- int *scale)
-{
- const char *key;
- GVariant *value;
-
- *scale = 0;
-
- while (g_variant_iter_loop (properties, "{&sv}", &key, &value)) {
- if (!g_str_equal (key, "legacy-ui-scaling-factor"))
- continue;
-
- *scale = g_variant_get_int32 (value);
- break;
- }
-
- if (*scale < 1) {
- g_warning ("Failed to get current UI legacy scaling factor");
- *scale = 1;
- return FALSE;
- }
-
- return TRUE;
-}
-
-#define MODE_FORMAT "(siiddada{sv})"
-#define MODES_FORMAT "a" MODE_FORMAT
-
-#define MONITOR_SPEC_FORMAT "(ssss)"
-#define MONITOR_FORMAT "(" MONITOR_SPEC_FORMAT MODES_FORMAT "a{sv})"
-#define MONITORS_FORMAT "a" MONITOR_FORMAT
-
-#define LOGICAL_MONITOR_FORMAT "(iiduba" MONITOR_SPEC_FORMAT "a{sv})"
-#define LOGICAL_MONITORS_FORMAT "a" LOGICAL_MONITOR_FORMAT
-
-#define CURRENT_STATE_FORMAT "(u" MONITORS_FORMAT LOGICAL_MONITORS_FORMAT "a{sv})"
-
static int
get_window_scale (GsdXSettingsManager *manager)
{
g_autoptr(GError) error = NULL;
- g_autoptr(GVariant) current_state = NULL;
+ g_autoptr(GVariant) res = NULL;
+ g_autoptr(GVariant) ui_scaling_factor_variant = NULL;
g_autoptr(GVariantIter) properties = NULL;
- int scale = 1;
-
- current_state =
- g_dbus_connection_call_sync (manager->dbus_connection,
- "org.gnome.Mutter.DisplayConfig",
- "/org/gnome/Mutter/DisplayConfig",
- "org.gnome.Mutter.DisplayConfig",
- "GetCurrentState",
- NULL,
- NULL,
- G_DBUS_CALL_FLAGS_NO_AUTO_START,
- -1,
- NULL,
- &error);
- if (!current_state) {
- g_warning ("Failed to get current display configuration state: %s",
- error->message);
+ int ui_scaling_factor = 1;
+
+ res = g_dbus_connection_call_sync (manager->dbus_connection,
+ "org.gnome.Mutter.X11",
+ "/org/gnome/Mutter/X11",
+ "org.freedesktop.DBus.Properties",
+ "Get",
+ g_variant_new ("(ss)",
+ "org.gnome.Mutter.X11",
+ "UiScalingFactor"),
+ NULL,
+ G_DBUS_CALL_FLAGS_NO_AUTO_START,
+ -1,
+ NULL,
+ &error);
+ if (!res) {
+ if (g_error_matches (error,
+ G_DBUS_ERROR,
+ G_DBUS_ERROR_NAME_HAS_NO_OWNER)) {
+ /* Mutter X11 interface is not yet on the bus, this is expected
+ * while starting up, it'll appear on the bus right away.
+ */
+ } else {
+ g_warning ("Failed to get current UI scaling factor: %s",
+ error->message);
+ }
+
return 1;
}
- g_variant_get (current_state,
- CURRENT_STATE_FORMAT,
- NULL,
- NULL,
- NULL,
- &properties);
-
- if (!get_legacy_ui_scale (properties, &scale))
- g_warning ("Failed to get current UI legacy scaling factor");
+ g_variant_get (res, "(v)", &ui_scaling_factor_variant);
+ g_variant_get (ui_scaling_factor_variant, "i", &ui_scaling_factor);
- return scale;
+ return ui_scaling_factor;
}
typedef struct {
@@ -1120,33 +1086,33 @@ setup_xsettings_managers (GsdXSettingsManager *manager)
}
static void
-monitors_changed (GsdXSettingsManager *manager)
+ui_scaling_factor_changed (GsdXSettingsManager *manager)
{
update_xft_settings (manager);
queue_notify (manager);
}
static void
-on_monitors_changed (GDBusConnection *connection,
- const gchar *sender_name,
- const gchar *object_path,
- const gchar *interface_name,
- const gchar *signal_name,
- GVariant *parameters,
- gpointer data)
+on_mutter_x11_properties_changed (GDBusConnection *connection,
+ const gchar *sender_name,
+ const gchar *object_path,
+ const gchar *interface_name,
+ const gchar *signal_name,
+ GVariant *parameters,
+ gpointer data)
{
GsdXSettingsManager *manager = data;
- monitors_changed (manager);
+ ui_scaling_factor_changed (manager);
}
static void
-on_display_config_name_appeared_handler (GDBusConnection *connection,
- const gchar *name,
- const gchar *name_owner,
- gpointer data)
+on_mutter_x11_name_appeared_handler (GDBusConnection *connection,
+ const gchar *name,
+ const gchar *name_owner,
+ gpointer data)
{
GsdXSettingsManager *manager = data;
- monitors_changed (manager);
+ ui_scaling_factor_changed (manager);
}
static void
@@ -1422,20 +1388,20 @@ gsd_xsettings_manager_start (GsdXSettingsManager *manager,
manager->monitors_changed_id =
g_dbus_connection_signal_subscribe (manager->dbus_connection,
- "org.gnome.Mutter.DisplayConfig",
- "org.gnome.Mutter.DisplayConfig",
- "MonitorsChanged",
- "/org/gnome/Mutter/DisplayConfig",
+ "org.gnome.Mutter.X11",
+ "org.freedesktop.DBus.Properties",
+ "PropertiesChanged",
+ "/org/gnome/Mutter/X11",
NULL,
G_DBUS_SIGNAL_FLAGS_NONE,
- on_monitors_changed,
+ on_mutter_x11_properties_changed,
manager,
NULL);
manager->display_config_watch_id =
g_bus_watch_name_on_connection (manager->dbus_connection,
- "org.gnome.Mutter.DisplayConfig",
+ "org.gnome.Mutter.X11",
G_BUS_NAME_WATCHER_FLAGS_NONE,
- on_display_config_name_appeared_handler,
+ on_mutter_x11_name_appeared_handler,
NULL,
manager,
NULL);
--
2.45.1

2
patches/series Normal file
View File

@ -0,0 +1,2 @@
debian/01_debianize_xrdb.patch
pika/0001-xsettings-Get-UI-scaling-factor-from-dedicated-D-Bus.patch

View File

@ -1,3 +1,2 @@
# send debs to server
rsync -azP --include './' --include '*.deb' --exclude '*' ./output/ ferreo@direct.pika-os.com:/srv/www/cockatiel-incoming/