a1d3a8b37d
Some checks failed
PikaOS Package Build & Release (Canary) (amd64-v3) / build (push) Has been cancelled
PikaOS Package Build Only (Canary) (amd64-v3) / build (push) Failing after 17s
PikaOS Package Build Only (amd64-v3) / build (push) Failing after 13s
PikaOS Package Build & Release (amd64-v3) / build (push) Failing after 13s
36 lines
690 B
Bash
Executable File
36 lines
690 B
Bash
Executable File
#!/bin/sh
|
|
|
|
set -eu
|
|
|
|
namespace=mutter-14/
|
|
|
|
if [ -z "${HOME-}" ] || ! [ -w "${HOME}" ]; then
|
|
export HOME="${AUTOPKGTEST_TMP}"
|
|
fi
|
|
|
|
cd "$AUTOPKGTEST_TMP"
|
|
|
|
if [ -z "$(ginsttest-runner -l "$namespace")" ]; then
|
|
echo "Error: no installed-tests found matching $namespace" >&2
|
|
exit 1
|
|
fi
|
|
|
|
e=0
|
|
ginsttest-runner \
|
|
--log-directory "$AUTOPKGTEST_ARTIFACTS" \
|
|
--tap \
|
|
"$namespace" || e="$?"
|
|
|
|
if [ "$e" -ne 0 ]; then
|
|
arch="$(dpkg --print-architecture)"
|
|
case "$arch" in
|
|
# Please keep this list in sync with debian/rules
|
|
(mips64el|riscv64|s390x)
|
|
echo "# Ignoring test failure on $arch"
|
|
exit 77
|
|
;;
|
|
esac
|
|
|
|
exit "$e"
|
|
fi
|