108 lines
3.4 KiB
Diff
108 lines
3.4 KiB
Diff
From: Jeremy Bicha <jeremy.bicha@canonical.com>
|
|
Date: Sun, 21 Aug 2022 10:30:55 -0400
|
|
Subject: Revert "build: Port to gcr4"
|
|
|
|
This reverts commit 5c935af7d3b3a3c9feb4e0d9ea214b6d25a7a2e7.
|
|
|
|
Forwarded: not-needed
|
|
---
|
|
js/misc/dependencies.js | 2 +-
|
|
meson.build | 4 ++--
|
|
src/meson.build | 2 +-
|
|
src/shell-keyring-prompt.c | 6 +++---
|
|
src/shell-secure-text-buffer.c | 2 +-
|
|
5 files changed, 8 insertions(+), 8 deletions(-)
|
|
|
|
diff --git a/js/misc/dependencies.js b/js/misc/dependencies.js
|
|
index c61753e..7a827bc 100644
|
|
--- a/js/misc/dependencies.js
|
|
+++ b/js/misc/dependencies.js
|
|
@@ -7,7 +7,7 @@ import gi from 'gi';
|
|
import 'gi://AccountsService?version=1.0';
|
|
import 'gi://Atk?version=1.0';
|
|
import 'gi://Atspi?version=2.0';
|
|
-import 'gi://Gcr?version=4';
|
|
+import 'gi://Gcr?version=3';
|
|
import 'gi://Gdk?version=4.0';
|
|
import 'gi://Gdm?version=1.0';
|
|
import 'gi://Geoclue?version=2.0';
|
|
diff --git a/meson.build b/meson.build
|
|
index 70ba711..8e1f1f4 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -21,7 +21,7 @@ libmutter_test_pc = 'libmutter-test-' + mutter_api_version
|
|
|
|
ecal_req = '>= 3.33.1'
|
|
eds_req = '>= 3.33.1'
|
|
-gcr_req = '>= 3.90.0'
|
|
+gcr_req = '>= 3.7.5'
|
|
gio_req = '>= 2.56.0'
|
|
gi_req = '>= 1.49.1'
|
|
gjs_req = '>= 1.73.1'
|
|
@@ -74,7 +74,7 @@ endif
|
|
atk_bridge_dep = dependency('atk-bridge-2.0')
|
|
ecal_dep = dependency('libecal-2.0', version: ecal_req)
|
|
eds_dep = dependency('libedataserver-1.2', version: eds_req)
|
|
-gcr_dep = dependency('gcr-4', version: gcr_req)
|
|
+gcr_dep = dependency('gcr-base-3', version: gcr_req)
|
|
gdk_x11_dep = dependency('gdk-x11-3.0')
|
|
gdk_pixbuf_dep = dependency('gdk-pixbuf-2.0')
|
|
gi_dep = dependency('gobject-introspection-1.0', version: gi_req)
|
|
diff --git a/src/meson.build b/src/meson.build
|
|
index 070312b..6a9b266 100644
|
|
--- a/src/meson.build
|
|
+++ b/src/meson.build
|
|
@@ -217,7 +217,7 @@ libshell_dep = declare_dependency(link_with: libshell)
|
|
libshell_gir_includes = [
|
|
'Clutter-@0@'.format(mutter_api_version),
|
|
'Meta-@0@'.format(mutter_api_version),
|
|
- 'Gcr-4',
|
|
+ 'Gcr-3',
|
|
'PolkitAgent-1.0',
|
|
'GdkPixbuf-2.0'
|
|
]
|
|
diff --git a/src/shell-keyring-prompt.c b/src/shell-keyring-prompt.c
|
|
index bb03279..83c6746 100644
|
|
--- a/src/shell-keyring-prompt.c
|
|
+++ b/src/shell-keyring-prompt.c
|
|
@@ -26,7 +26,7 @@
|
|
#include "shell-secure-text-buffer.h"
|
|
|
|
#define GCR_API_SUBJECT_TO_CHANGE
|
|
-#include <gcr/gcr.h>
|
|
+#include <gcr/gcr-base.h>
|
|
|
|
#include <glib/gi18n.h>
|
|
|
|
@@ -91,7 +91,7 @@ enum {
|
|
|
|
static GParamSpec *props[N_PROPS] = { NULL, };
|
|
|
|
-static void shell_keyring_prompt_iface (GcrPromptInterface *iface);
|
|
+static void shell_keyring_prompt_iface (GcrPromptIface *iface);
|
|
|
|
G_DEFINE_TYPE_WITH_CODE (ShellKeyringPrompt, shell_keyring_prompt, G_TYPE_OBJECT,
|
|
G_IMPLEMENT_INTERFACE (GCR_TYPE_PROMPT, shell_keyring_prompt_iface);
|
|
@@ -531,7 +531,7 @@ shell_keyring_prompt_close (GcrPrompt *prompt)
|
|
}
|
|
|
|
static void
|
|
-shell_keyring_prompt_iface (GcrPromptInterface *iface)
|
|
+shell_keyring_prompt_iface (GcrPromptIface *iface)
|
|
{
|
|
iface->prompt_password_async = shell_keyring_prompt_password_async;
|
|
iface->prompt_password_finish = shell_keyring_prompt_password_finish;
|
|
diff --git a/src/shell-secure-text-buffer.c b/src/shell-secure-text-buffer.c
|
|
index 8271410..03af451 100644
|
|
--- a/src/shell-secure-text-buffer.c
|
|
+++ b/src/shell-secure-text-buffer.c
|
|
@@ -26,7 +26,7 @@
|
|
#include "shell-secure-text-buffer.h"
|
|
|
|
#define GCR_API_SUBJECT_TO_CHANGE
|
|
-#include <gcr/gcr.h>
|
|
+#include <gcr/gcr-base.h>
|
|
|
|
#include <string.h>
|
|
|