generated from kernel-packages/linux-pikaos-6.12.10
Initial commit
This commit is contained in:
commit
eee1b54a6e
1
.github/build-canary-v3
vendored
Normal file
1
.github/build-canary-v3
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
1
|
1
.github/build-nest-v3
vendored
Normal file
1
.github/build-nest-v3
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
1
|
1
.github/release-canary-v3
vendored
Normal file
1
.github/release-canary-v3
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
1
|
1
.github/release-nest-v3
vendored
Normal file
1
.github/release-nest-v3
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
2
|
34
.github/workflows/build-canaryv3.yml
vendored
Normal file
34
.github/workflows/build-canaryv3.yml
vendored
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
name: PikaOS Package Build Only (Canary) (amd64-v3)
|
||||||
|
|
||||||
|
on:
|
||||||
|
push:
|
||||||
|
branches:
|
||||||
|
- main
|
||||||
|
paths:
|
||||||
|
- '.github/build-canary-v3'
|
||||||
|
|
||||||
|
jobs:
|
||||||
|
build:
|
||||||
|
runs-on: ubuntu-latest
|
||||||
|
container:
|
||||||
|
image: ghcr.io/pikaos-linux/pikaos-builder:canaryv3
|
||||||
|
volumes:
|
||||||
|
- /proc:/proc
|
||||||
|
options: --privileged -it
|
||||||
|
|
||||||
|
steps:
|
||||||
|
- uses: actions/checkout@v3
|
||||||
|
|
||||||
|
- name: Install SSH key
|
||||||
|
uses: shimataro/ssh-key-action@v2
|
||||||
|
with:
|
||||||
|
key: ${{ secrets.SSH_KEY }}
|
||||||
|
name: id_rsa
|
||||||
|
known_hosts: ${{ secrets.KNOWN_HOSTS }}
|
||||||
|
if_key_exists: replace
|
||||||
|
|
||||||
|
- name: Update APT Cache
|
||||||
|
run: apt-get update -y
|
||||||
|
|
||||||
|
- name: Build Package
|
||||||
|
run: ./main.sh
|
34
.github/workflows/build-nestv3.yml
vendored
Normal file
34
.github/workflows/build-nestv3.yml
vendored
Normal file
@ -0,0 +1,34 @@
|
|||||||
|
name: PikaOS Package Build Only (amd64-v3)
|
||||||
|
|
||||||
|
on:
|
||||||
|
push:
|
||||||
|
branches:
|
||||||
|
- main
|
||||||
|
paths:
|
||||||
|
- '.github/build-nest-v3'
|
||||||
|
|
||||||
|
jobs:
|
||||||
|
build:
|
||||||
|
runs-on: self-hosted
|
||||||
|
container:
|
||||||
|
image: ghcr.io/pikaos-linux/pikaos-builder:nestv3
|
||||||
|
volumes:
|
||||||
|
- /proc:/proc
|
||||||
|
options: --privileged -it
|
||||||
|
|
||||||
|
steps:
|
||||||
|
- uses: actions/checkout@v3
|
||||||
|
|
||||||
|
- name: Install SSH key
|
||||||
|
uses: shimataro/ssh-key-action@v2
|
||||||
|
with:
|
||||||
|
key: ${{ secrets.SSH_KEY }}
|
||||||
|
name: id_rsa
|
||||||
|
known_hosts: ${{ secrets.KNOWN_HOSTS }}
|
||||||
|
if_key_exists: replace
|
||||||
|
|
||||||
|
- name: Update APT Cache
|
||||||
|
run: apt-get update -y
|
||||||
|
|
||||||
|
- name: Build Package
|
||||||
|
run: ./main.sh
|
37
.github/workflows/release-canaryv3.yml
vendored
Normal file
37
.github/workflows/release-canaryv3.yml
vendored
Normal file
@ -0,0 +1,37 @@
|
|||||||
|
name: PikaOS Package Build & Release (Canary) (amd64-v3)
|
||||||
|
|
||||||
|
on:
|
||||||
|
push:
|
||||||
|
branches:
|
||||||
|
- main
|
||||||
|
paths:
|
||||||
|
- '.github/release-canary-v3'
|
||||||
|
|
||||||
|
jobs:
|
||||||
|
build:
|
||||||
|
runs-on: ubuntu-latest
|
||||||
|
container:
|
||||||
|
image: ghcr.io/pikaos-linux/pikaos-builder:canaryv3
|
||||||
|
volumes:
|
||||||
|
- /proc:/proc
|
||||||
|
options: --privileged -it
|
||||||
|
|
||||||
|
steps:
|
||||||
|
- uses: actions/checkout@v3
|
||||||
|
|
||||||
|
- name: Install SSH key
|
||||||
|
uses: shimataro/ssh-key-action@v2
|
||||||
|
with:
|
||||||
|
key: ${{ secrets.SSH_KEY }}
|
||||||
|
name: id_rsa
|
||||||
|
known_hosts: ${{ secrets.KNOWN_HOSTS }}
|
||||||
|
if_key_exists: replace
|
||||||
|
|
||||||
|
- name: Update APT Cache
|
||||||
|
run: apt-get update -y
|
||||||
|
|
||||||
|
- name: Build Package
|
||||||
|
run: ./main.sh
|
||||||
|
|
||||||
|
- name: Release Package
|
||||||
|
run: ./release.sh
|
37
.github/workflows/release-nestv3.yml
vendored
Normal file
37
.github/workflows/release-nestv3.yml
vendored
Normal file
@ -0,0 +1,37 @@
|
|||||||
|
name: PikaOS Package Build & Release (amd64-v3)
|
||||||
|
|
||||||
|
on:
|
||||||
|
push:
|
||||||
|
branches:
|
||||||
|
- main
|
||||||
|
paths:
|
||||||
|
- '.github/release-nest-v3'
|
||||||
|
|
||||||
|
jobs:
|
||||||
|
build:
|
||||||
|
runs-on: self-hosted
|
||||||
|
container:
|
||||||
|
image: ghcr.io/pikaos-linux/pikaos-builder:nestv3
|
||||||
|
volumes:
|
||||||
|
- /proc:/proc
|
||||||
|
options: --privileged -it
|
||||||
|
|
||||||
|
steps:
|
||||||
|
- uses: actions/checkout@v3
|
||||||
|
|
||||||
|
- name: Install SSH key
|
||||||
|
uses: shimataro/ssh-key-action@v2
|
||||||
|
with:
|
||||||
|
key: ${{ secrets.SSH_KEY }}
|
||||||
|
name: id_rsa
|
||||||
|
known_hosts: ${{ secrets.KNOWN_HOSTS }}
|
||||||
|
if_key_exists: replace
|
||||||
|
|
||||||
|
- name: Update APT Cache
|
||||||
|
run: apt-get update -y
|
||||||
|
|
||||||
|
- name: Build Package
|
||||||
|
run: ./main.sh
|
||||||
|
|
||||||
|
- name: Release Package
|
||||||
|
run: ./release.sh
|
16
LICENSE.md
Normal file
16
LICENSE.md
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
This is a packaged upstream version of the Linux kernel.
|
||||||
|
|
||||||
|
The sources may be found at most Linux archive sites, including:
|
||||||
|
https://www.kernel.org/pub/linux/kernel
|
||||||
|
|
||||||
|
Copyright: 1991 - 2023 Linus Torvalds and others.
|
||||||
|
|
||||||
|
The git repository for mainline kernel development is at:
|
||||||
|
git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git
|
||||||
|
|
||||||
|
This program is free software; you can redistribute it and/or modify
|
||||||
|
it under the terms of the GNU General Public License as published by
|
||||||
|
the Free Software Foundation; version 2 dated June, 1991.
|
||||||
|
|
||||||
|
On Debian GNU/Linux systems, the complete text of the GNU General Public
|
||||||
|
License version 2 can be found in `/usr/share/common-licenses/GPL-2'.
|
8
README.md
Normal file
8
README.md
Normal file
@ -0,0 +1,8 @@
|
|||||||
|
# pika-kernel-builder
|
||||||
|
Scripts for building and releasing the Pika kernel, based on Cachy OS kernel patches - <3 them
|
||||||
|
|
||||||
|
To add our kernel apt repo do:
|
||||||
|
|
||||||
|
wget -q -O - https://ppa.pika-os.com/key.gpg | sudo apt-key add -
|
||||||
|
|
||||||
|
sudo add-apt-repository https://ppa.pika-os.com
|
14
main.sh
Executable file
14
main.sh
Executable file
@ -0,0 +1,14 @@
|
|||||||
|
#! /bin/bash
|
||||||
|
|
||||||
|
export DEBIAN_FRONTEND="noninteractive"
|
||||||
|
|
||||||
|
apt-get update -y
|
||||||
|
apt-get install -y clang lld llvm
|
||||||
|
|
||||||
|
mkdir -p ./output
|
||||||
|
|
||||||
|
. ./scripts/source.sh
|
||||||
|
. ../scripts/patch.sh
|
||||||
|
. ../scripts/config.sh
|
||||||
|
. ../scripts/build.sh
|
||||||
|
. ../scripts/output.sh
|
14
patches/0000-deb-packaging.patch
Normal file
14
patches/0000-deb-packaging.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
--- a/scripts/package/builddeb
|
||||||
|
+++ b/scripts/package/builddeb
|
||||||
|
@@ -125,7 +125,10 @@
|
||||||
|
|
||||||
|
CC="${DEB_HOST_GNU_TYPE}-gcc" "${srctree}/scripts/package/install-extmod-build" "${pdir}/usr/src/linux-headers-${version}"
|
||||||
|
|
||||||
|
- mkdir -p $pdir/lib/modules/$version/
|
||||||
|
+ mkdir -p "${pdir}/usr/src/linux-headers-${version}/"
|
||||||
|
+ cp .config "${pdir}/usr/src/linux-headers-${version}/.config"
|
||||||
|
+
|
||||||
|
+ mkdir -p $pdir/lib/modules/$version/
|
||||||
|
ln -s /usr/src/linux-headers-$version $pdir/lib/modules/$version/build
|
||||||
|
}
|
||||||
|
|
50659
patches/0001-cachyos-base-all.patch
Normal file
50659
patches/0001-cachyos-base-all.patch
Normal file
File diff suppressed because it is too large
Load Diff
50
patches/0001-dkms-clang.patch
Normal file
50
patches/0001-dkms-clang.patch
Normal file
@ -0,0 +1,50 @@
|
|||||||
|
From 1e5a4a3f9c67c5abea53df6881192c8c5f43765c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Eric Naim <dnaim@cachyos.org>
|
||||||
|
Date: Sat, 21 Sep 2024 23:46:05 +0800
|
||||||
|
Subject: [PATCH] Remove some Werror CFLAGS to increase compatibility with some
|
||||||
|
DKMS modules in clang-built kernels
|
||||||
|
|
||||||
|
Signed-off-by: Eric Naim <dnaim@cachyos.org>
|
||||||
|
---
|
||||||
|
scripts/Makefile.clang | 2 --
|
||||||
|
scripts/Makefile.extrawarn | 4 ----
|
||||||
|
2 files changed, 6 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/scripts/Makefile.clang b/scripts/Makefile.clang
|
||||||
|
index 6c23c6af797f..59b2e19416af 100644
|
||||||
|
--- a/scripts/Makefile.clang
|
||||||
|
+++ b/scripts/Makefile.clang
|
||||||
|
@@ -31,9 +31,7 @@ endif
|
||||||
|
# certain optimization flags it knows it has not implemented.
|
||||||
|
# Make it behave more like gcc by erroring when these flags are encountered
|
||||||
|
# so they can be implemented or wrapped in cc-option.
|
||||||
|
-CLANG_FLAGS += -Werror=unknown-warning-option
|
||||||
|
CLANG_FLAGS += -Werror=ignored-optimization-argument
|
||||||
|
CLANG_FLAGS += -Werror=option-ignored
|
||||||
|
-CLANG_FLAGS += -Werror=unused-command-line-argument
|
||||||
|
KBUILD_CPPFLAGS += $(CLANG_FLAGS)
|
||||||
|
export CLANG_FLAGS
|
||||||
|
diff --git a/scripts/Makefile.extrawarn b/scripts/Makefile.extrawarn
|
||||||
|
index 1d13cecc7cc7..ec97275c8852 100644
|
||||||
|
--- a/scripts/Makefile.extrawarn
|
||||||
|
+++ b/scripts/Makefile.extrawarn
|
||||||
|
@@ -12,7 +12,6 @@ KBUILD_CFLAGS += -Wundef
|
||||||
|
KBUILD_CFLAGS += -Werror=implicit-function-declaration
|
||||||
|
KBUILD_CFLAGS += -Werror=implicit-int
|
||||||
|
KBUILD_CFLAGS += -Werror=return-type
|
||||||
|
-KBUILD_CFLAGS += -Werror=strict-prototypes
|
||||||
|
KBUILD_CFLAGS += -Wno-format-security
|
||||||
|
KBUILD_CFLAGS += -Wno-trigraphs
|
||||||
|
KBUILD_CFLAGS += $(call cc-disable-warning,frame-address,)
|
||||||
|
@@ -68,9 +67,6 @@ KBUILD_CFLAGS += $(KBUILD_CFLAGS-y) $(CONFIG_CC_IMPLICIT_FALLTHROUGH)
|
||||||
|
# Prohibit date/time macros, which would make the build non-deterministic
|
||||||
|
KBUILD_CFLAGS += -Werror=date-time
|
||||||
|
|
||||||
|
-# enforce correct pointer usage
|
||||||
|
-KBUILD_CFLAGS += $(call cc-option,-Werror=incompatible-pointer-types)
|
||||||
|
-
|
||||||
|
# Require designated initializers for all marked structures
|
||||||
|
KBUILD_CFLAGS += $(call cc-option,-Werror=designated-init)
|
||||||
|
|
||||||
|
--
|
||||||
|
2.46.1
|
1043
patches/0002-bore-cachy.patch
Normal file
1043
patches/0002-bore-cachy.patch
Normal file
File diff suppressed because it is too large
Load Diff
6837
patches/asus2.patch
Normal file
6837
patches/asus2.patch
Normal file
File diff suppressed because it is too large
Load Diff
60
patches/asus3.patch
Normal file
60
patches/asus3.patch
Normal file
@ -0,0 +1,60 @@
|
|||||||
|
From a4ddda3952942c4e3df9099065004dc7f0077fee Mon Sep 17 00:00:00 2001
|
||||||
|
From: Armin Wolf <W_Armin@gmx.de>
|
||||||
|
Date: Sun, 24 Nov 2024 18:19:41 +0100
|
||||||
|
Subject: [PATCH] platform/x86: asus-wmi: Ignore return value when writing
|
||||||
|
thermal policy
|
||||||
|
|
||||||
|
On some machines like the ASUS Vivobook S14 writing the thermal policy
|
||||||
|
returns the currently writen thermal policy instead of an error code.
|
||||||
|
|
||||||
|
Ignore the return code to avoid falsely returning an error when the
|
||||||
|
thermal policy was written successfully.
|
||||||
|
|
||||||
|
Reported-by: auslands-kv@gmx.de
|
||||||
|
Closes: https://bugzilla.kernel.org/show_bug.cgi?id=219517
|
||||||
|
Fixes: 2daa86e78c49 ("platform/x86: asus_wmi: Support throttle thermal policy")
|
||||||
|
Signed-off-by: Armin Wolf <W_Armin@gmx.de>
|
||||||
|
Signed-off-by: Eric Naim <dnaim@cachyos.org>
|
||||||
|
---
|
||||||
|
drivers/platform/x86/asus-wmi.c | 11 ++---------
|
||||||
|
1 file changed, 2 insertions(+), 9 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/drivers/platform/x86/asus-wmi.c b/drivers/platform/x86/asus-wmi.c
|
||||||
|
index 89f5f44857d555..1101e5b2488e52 100644
|
||||||
|
--- a/drivers/platform/x86/asus-wmi.c
|
||||||
|
+++ b/drivers/platform/x86/asus-wmi.c
|
||||||
|
@@ -3696,7 +3696,6 @@ static int asus_wmi_custom_fan_curve_init(struct asus_wmi *asus)
|
||||||
|
/* Throttle thermal policy ****************************************************/
|
||||||
|
static int throttle_thermal_policy_write(struct asus_wmi *asus)
|
||||||
|
{
|
||||||
|
- u32 retval;
|
||||||
|
u8 value;
|
||||||
|
int err;
|
||||||
|
|
||||||
|
@@ -3718,8 +3717,8 @@ static int throttle_thermal_policy_write(struct asus_wmi *asus)
|
||||||
|
value = asus->throttle_thermal_policy_mode;
|
||||||
|
}
|
||||||
|
|
||||||
|
- err = asus_wmi_set_devstate(asus->throttle_thermal_policy_dev,
|
||||||
|
- value, &retval);
|
||||||
|
+ /* Some machines do not return an error code as a result, so we ignore it */
|
||||||
|
+ err = asus_wmi_set_devstate(asus->throttle_thermal_policy_dev, value, NULL);
|
||||||
|
|
||||||
|
sysfs_notify(&asus->platform_device->dev.kobj, NULL,
|
||||||
|
"throttle_thermal_policy");
|
||||||
|
@@ -3729,12 +3728,6 @@ static int throttle_thermal_policy_write(struct asus_wmi *asus)
|
||||||
|
return err;
|
||||||
|
}
|
||||||
|
|
||||||
|
- if (retval != 1) {
|
||||||
|
- pr_warn("Failed to set throttle thermal policy (retval): 0x%x\n",
|
||||||
|
- retval);
|
||||||
|
- return -EIO;
|
||||||
|
- }
|
||||||
|
-
|
||||||
|
/* Must set to disabled if mode is toggled */
|
||||||
|
if (asus->cpu_fan_curve_available)
|
||||||
|
asus->custom_fan_curves[FAN_CURVE_DEV_CPU].enabled = false;
|
||||||
|
|
||||||
|
|
||||||
|
|
58
patches/asus4.patch
Normal file
58
patches/asus4.patch
Normal file
@ -0,0 +1,58 @@
|
|||||||
|
From 76556b655f7b50afe5c58006f44221900e5711a9 Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Luke D. Jones" <luke@ljones.dev>
|
||||||
|
Date: Wed, 23 Aug 2023 11:05:59 +1200
|
||||||
|
Subject: [PATCH v2] ALSA: hda: cs35l41: Support ASUS 2023 laptops with missing
|
||||||
|
DSD
|
||||||
|
|
||||||
|
Support adding the missing DSD properties required for ASUS ROG 2023
|
||||||
|
laptops and other ASUS laptops to properly utilise the cs35l41.
|
||||||
|
|
||||||
|
The currently added laptops are:
|
||||||
|
- ASUS GS650P, i2c
|
||||||
|
- ASUS GA402X, i2c
|
||||||
|
- ASUS GU604V, spi
|
||||||
|
- ASUS GU603V, spi
|
||||||
|
- ASUS GV601V, spi
|
||||||
|
- ASUS GZ301V, spi
|
||||||
|
- ASUS ROG ALLY, i2c
|
||||||
|
- ASUS G614J, spi
|
||||||
|
- ASUS G634J, spi
|
||||||
|
- ASUS G614JI, spi
|
||||||
|
- ASUS G713P, i2c
|
||||||
|
- ASUS H7604JV, spi
|
||||||
|
|
||||||
|
The SPI connected amps may be required to use an external DSD patch
|
||||||
|
to fix or add the "cs-gpios" property.
|
||||||
|
|
||||||
|
Co-developed-by: Jonathan LoBue <jlobue10@gmail.com>
|
||||||
|
Signed-off-by: Jonathan LoBue <jlobue10@gmail.com>
|
||||||
|
Co-developed-by: Luke D. Jones <luke@ljones.dev>
|
||||||
|
Signed-off-by: Luke D. Jones <luke@ljones.dev>
|
||||||
|
---
|
||||||
|
sound/pci/hda/cs35l41_hda_property.c | 57 ++++++++++++++++++++++++++++
|
||||||
|
1 file changed, 57 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/sound/pci/hda/cs35l41_hda_property.c b/sound/pci/hda/cs35l41_hda_property.c
|
||||||
|
index c9eb70290..2b8f8fd52 100644
|
||||||
|
--- a/sound/pci/hda/cs35l41_hda_property.c
|
||||||
|
+++ b/sound/pci/hda/cs35l41_hda_property.c
|
||||||
|
@@ -79,6 +79,7 @@
|
||||||
|
{ "104316D3", 2, EXTERNAL, { CS35L41_LEFT, CS35L41_RIGHT, 0, 0 }, 1, 2, 0, 0, 0, 0 },
|
||||||
|
{ "104316F3", 2, EXTERNAL, { CS35L41_LEFT, CS35L41_RIGHT, 0, 0 }, 1, 2, 0, 0, 0, 0 },
|
||||||
|
{ "104317F3", 2, INTERNAL, { CS35L41_LEFT, CS35L41_RIGHT, 0, 0 }, 0, 1, -1, 1000, 4500, 24 },
|
||||||
|
+ { "10431B93", 2, INTERNAL, { CS35L41_LEFT, CS35L41_RIGHT, 0, 0 }, 1, 2, 0, 1000, 4500, 24 },
|
||||||
|
{ "10431863", 2, INTERNAL, { CS35L41_LEFT, CS35L41_RIGHT, 0, 0 }, 1, 2, 0, 1000, 4500, 24 },
|
||||||
|
{ "104318D3", 2, EXTERNAL, { CS35L41_LEFT, CS35L41_RIGHT, 0, 0 }, 0, 1, -1, 0, 0, 0 },
|
||||||
|
{ "10431C9F", 2, INTERNAL, { CS35L41_LEFT, CS35L41_RIGHT, 0, 0 }, 1, 2, 0, 1000, 4500, 24 },
|
||||||
|
@@ -360,6 +361,7 @@ static const struct cs35l41_prop_model cs35l41_prop_model_table[] = {
|
||||||
|
{ "CSC3551", "104316D3", generic_dsd_config },
|
||||||
|
{ "CSC3551", "104316F3", generic_dsd_config },
|
||||||
|
{ "CSC3551", "104317F3", generic_dsd_config },
|
||||||
|
+ { "CSC3551", "10431B93", generic_dsd_config },
|
||||||
|
{ "CSC3551", "10431863", generic_dsd_config },
|
||||||
|
{ "CSC3551", "104318D3", generic_dsd_config },
|
||||||
|
{ "CSC3551", "10431C9F", generic_dsd_config },
|
||||||
|
|
||||||
|
--
|
||||||
|
2.41.0
|
||||||
|
|
7
patches/series
Normal file
7
patches/series
Normal file
@ -0,0 +1,7 @@
|
|||||||
|
0000-deb-packaging.patch
|
||||||
|
0001-cachyos-base-all.patch
|
||||||
|
0001-dkms-clang.patch
|
||||||
|
0002-bore-cachy.patch
|
||||||
|
asus2.patch
|
||||||
|
asus3.patch
|
||||||
|
asus4.patch
|
2
release.sh
Executable file
2
release.sh
Executable file
@ -0,0 +1,2 @@
|
|||||||
|
# send debs to server
|
||||||
|
rsync -azP --include './' --include '*.deb' --exclude '*' ./output/ ferreo@direct.pika-os.com:/srv/www/cockatiel-incoming/
|
5
scripts/build.sh
Executable file
5
scripts/build.sh
Executable file
@ -0,0 +1,5 @@
|
|||||||
|
#!/bin/bash
|
||||||
|
|
||||||
|
echo "Pika Kernel - Building"
|
||||||
|
|
||||||
|
make CC=clang LD=ld.lld LLVM=1 LLVM_IAS=1 -j`nproc` bindeb-pkg LOCALVERSION=-pikaos KDEB_PKGVERSION=$(make kernelversion)-101pika1
|
43
scripts/config.sh
Executable file
43
scripts/config.sh
Executable file
@ -0,0 +1,43 @@
|
|||||||
|
#!/bin/bash
|
||||||
|
|
||||||
|
echo "Pika Kernel - Applying configuration"
|
||||||
|
|
||||||
|
cp ../config .config
|
||||||
|
|
||||||
|
make prepare
|
||||||
|
|
||||||
|
scripts/config -k -d CONFIG_GENERIC_CPU
|
||||||
|
scripts/config -k -e CONFIG_GENERIC_CPU3
|
||||||
|
scripts/config -e CACHY
|
||||||
|
scripts/config -e SCHED_BORE
|
||||||
|
|
||||||
|
scripts/config -e LTO -e LTO_CLANG -e ARCH_SUPPORTS_LTO_CLANG -e ARCH_SUPPORTS_LTO_CLANG_THIN -e HAS_LTO_CLANG -e LTO_CLANG_THIN -d LTO_NONE -e HAVE_GCC_PLUGINS
|
||||||
|
|
||||||
|
scripts/config -e HZ_1000 --set-val HZ 1000
|
||||||
|
scripts/config -d HZ_PERIODIC -d NO_HZ_IDLE -d CONTEXT_TRACKING_FORCE -e NO_HZ_FULL_NODEF -e NO_HZ_FULL -e NO_HZ -e NO_HZ_COMMON -e CONTEXT_TRACKING
|
||||||
|
scripts/config -e PREEMPT_BUILD -d PREEMPT_NONE -d PREEMPT_VOLUNTARY -e PREEMPT -e PREEMPT_COUNT -e PREEMPTION -e PREEMPT_DYNAMIC
|
||||||
|
scripts/config -d CC_OPTIMIZE_FOR_PERFORMANCE \
|
||||||
|
-e CC_OPTIMIZE_FOR_PERFORMANCE_O3
|
||||||
|
|
||||||
|
scripts/config -e SCHED_CLASS_EXT
|
||||||
|
|
||||||
|
scripts/config -e LRU_GEN -e LRU_GEN_ENABLED -d LRU_GEN_STATS
|
||||||
|
|
||||||
|
scripts/config -d TRANSPARENT_HUGEPAGE_MADVISE -e TRANSPARENT_HUGEPAGE_ALWAYS
|
||||||
|
|
||||||
|
scripts/config -e PER_VMA_LOCK -d PER_VMA_LOCK_STATS
|
||||||
|
|
||||||
|
scripts/config -e DAMON \
|
||||||
|
-e DAMON_VADDR \
|
||||||
|
-e DAMON_DBGFS \
|
||||||
|
-e DAMON_SYSFS \
|
||||||
|
-e DAMON_PADDR \
|
||||||
|
-e DAMON_RECLAIM \
|
||||||
|
-e DAMON_LRU_SORT
|
||||||
|
|
||||||
|
scripts/config --set-val MODULE_COMPRESS_ZSTD_LEVEL 19 -e MODULE_COMPRESS_ZSTD_ULTRA --set-val MODULE_COMPRESS_ZSTD_LEVEL_ULTRA 22 --set-val ZSTD_COMP_VAL 22
|
||||||
|
|
||||||
|
scripts/config -e EFI_HANDOVER_PROTOCOL
|
||||||
|
|
||||||
|
scripts/config -e USER_NS
|
||||||
|
|
11
scripts/output.sh
Executable file
11
scripts/output.sh
Executable file
@ -0,0 +1,11 @@
|
|||||||
|
#!/bin/bash
|
||||||
|
|
||||||
|
echo "Pika Kernel - Copying Output"
|
||||||
|
|
||||||
|
cd ..
|
||||||
|
rm ./linux-libc*.deb
|
||||||
|
|
||||||
|
for f in *.deb;
|
||||||
|
do
|
||||||
|
cp $f ./output/$f
|
||||||
|
done
|
8
scripts/patch.sh
Executable file
8
scripts/patch.sh
Executable file
@ -0,0 +1,8 @@
|
|||||||
|
#!/bin/bash
|
||||||
|
|
||||||
|
echo "Pika Kernel - Applying patches"
|
||||||
|
|
||||||
|
if [ -f ../patches/series ]
|
||||||
|
then
|
||||||
|
for i in $(cat ../patches/series | grep -v '^#') ; do echo "Applying Patch: $i" && patch -Np1 -i ../patches/$i || bash -c "echo "Applying Patch $i Failed!" && exit 2"; done
|
||||||
|
fi
|
8
scripts/source.sh
Executable file
8
scripts/source.sh
Executable file
@ -0,0 +1,8 @@
|
|||||||
|
#!/bin/bash
|
||||||
|
|
||||||
|
echo "Pika Kernel - Getting source"
|
||||||
|
|
||||||
|
wget -nv https://cdn.kernel.org/pub/linux/kernel/v"$(echo $(cat ./VERSION) | cut -f1 -d".")".x/linux-"$(cat ./VERSION)".tar.gz
|
||||||
|
tar -xf ./linux-"$(cat ./VERSION)".tar.gz
|
||||||
|
|
||||||
|
cd linux-"$(cat ./VERSION)"
|
Loading…
x
Reference in New Issue
Block a user