Update patches/0001-cachyos-base-all.patch

This commit is contained in:
ferreo 2024-12-28 12:49:22 +01:00
parent 51b4e0651d
commit a729ed6101

View File

@ -1,4 +1,4 @@
From a89e358d449153fa1a741edc60a8f9a143e5d297 Mon Sep 17 00:00:00 2001
From 68fd401540c8011e3210751d8727074bcbb60150 Mon Sep 17 00:00:00 2001
From: Peter Jung <admin@ptr1337.dev>
Date: Thu, 19 Dec 2024 18:49:54 +0100
Subject: [PATCH 01/12] amd-cache-optimizer
@ -272,7 +272,7 @@ index 000000000000..0f6d3c54d879
--
2.47.1
From 5b24edbe81299a51cf1694d0e33c33d995e2c04d Mon Sep 17 00:00:00 2001
From fae888443fc1f6cf82450cc88c9fc14a4157d759 Mon Sep 17 00:00:00 2001
From: Peter Jung <admin@ptr1337.dev>
Date: Thu, 19 Dec 2024 18:50:07 +0100
Subject: [PATCH 02/12] amd-pstate
@ -1174,7 +1174,7 @@ index dd4682857c12..23698d0f4bb4 100644
--
2.47.1
From c335f50994128543c8e019b8cc913d7fb0e98f2b Mon Sep 17 00:00:00 2001
From 63aefa7ec768a3b856b41412903f2b8f94c25e95 Mon Sep 17 00:00:00 2001
From: Peter Jung <admin@ptr1337.dev>
Date: Thu, 19 Dec 2024 18:50:18 +0100
Subject: [PATCH 03/12] autofdo
@ -1590,7 +1590,7 @@ index a578178468f1..a2d251917629 100644
M: Petr Mladek <pmladek@suse.com>
R: Steven Rostedt <rostedt@goodmis.org>
diff --git a/Makefile b/Makefile
index c10952585c14..a0229efbf8e3 100644
index 685a57f6c8d2..9eb33adc33e7 100644
--- a/Makefile
+++ b/Makefile
@@ -1019,6 +1019,8 @@ include-$(CONFIG_KMSAN) += scripts/Makefile.kmsan
@ -1920,7 +1920,7 @@ index 3d27983dc908..6f64d611faea 100644
--
2.47.1
From d03dc7618d35c0c3e5ab7373cff2032a8c3ecf9f Mon Sep 17 00:00:00 2001
From 0914fb7e5b7a07ab07317160b090c1e8bbdd5ca9 Mon Sep 17 00:00:00 2001
From: Peter Jung <admin@ptr1337.dev>
Date: Thu, 19 Dec 2024 18:50:32 +0100
Subject: [PATCH 04/12] bbr3
@ -5306,7 +5306,7 @@ index 79064580c8c0..697270ce1ea6 100644
--
2.47.1
From 2b16de2dc6156279f389d532824a302d212f2611 Mon Sep 17 00:00:00 2001
From e344a34773ac1f24697490d3d5790f10f3f81c5c Mon Sep 17 00:00:00 2001
From: Peter Jung <admin@ptr1337.dev>
Date: Thu, 19 Dec 2024 18:50:43 +0100
Subject: [PATCH 05/12] cachy
@ -5538,7 +5538,7 @@ index 6d942b5c58f0..1768a106aab1 100644
======
diff --git a/Makefile b/Makefile
index a0229efbf8e3..201faadca07f 100644
index 9eb33adc33e7..802baad237e2 100644
--- a/Makefile
+++ b/Makefile
@@ -802,11 +802,19 @@ KBUILD_CFLAGS += -fno-delete-null-pointer-checks
@ -12778,7 +12778,7 @@ index 7183e5aca282..56573371a2f8 100644
{
return &init_user_ns;
diff --git a/include/linux/wait.h b/include/linux/wait.h
index 8aa3372f21a0..924778a426ce 100644
index 2b322a9b88a2..6f977c21fd81 100644
--- a/include/linux/wait.h
+++ b/include/linux/wait.h
@@ -163,6 +163,7 @@ static inline bool wq_has_sleeper(struct wait_queue_head *wq_head)
@ -12789,7 +12789,7 @@ index 8aa3372f21a0..924778a426ce 100644
extern void add_wait_queue_priority(struct wait_queue_head *wq_head, struct wait_queue_entry *wq_entry);
extern void remove_wait_queue(struct wait_queue_head *wq_head, struct wait_queue_entry *wq_entry);
@@ -1191,6 +1192,7 @@ do { \
@@ -1192,6 +1193,7 @@ do { \
*/
void prepare_to_wait(struct wait_queue_head *wq_head, struct wait_queue_entry *wq_entry, int state);
bool prepare_to_wait_exclusive(struct wait_queue_head *wq_head, struct wait_queue_entry *wq_entry, int state);
@ -12952,7 +12952,7 @@ index 2bbb6eca5144..125cdf85741c 100644
return state;
diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
index 782ce70ebd1b..b793e9db30ad 100644
index 1ca96c99872f..d06d306b7fba 100644
--- a/kernel/sched/fair.c
+++ b/kernel/sched/fair.c
@@ -73,10 +73,19 @@ unsigned int sysctl_sched_tunable_scaling = SCHED_TUNABLESCALING_LOG;
@ -12989,10 +12989,10 @@ index 782ce70ebd1b..b793e9db30ad 100644
#ifdef CONFIG_NUMA_BALANCING
/* Restrict the NUMA promotion throughput (MB/s) for each target node. */
diff --git a/kernel/sched/sched.h b/kernel/sched/sched.h
index c03b3d7b320e..c5d6012794de 100644
index f2ef520513c4..d6e2ca8c8cd2 100644
--- a/kernel/sched/sched.h
+++ b/kernel/sched/sched.h
@@ -2816,7 +2816,7 @@ extern void deactivate_task(struct rq *rq, struct task_struct *p, int flags);
@@ -2825,7 +2825,7 @@ extern void deactivate_task(struct rq *rq, struct task_struct *p, int flags);
extern void wakeup_preempt(struct rq *rq, struct task_struct *p, int flags);
@ -13232,7 +13232,7 @@ index a2b16b08cbbf..48d611e58ad3 100644
static int __read_mostly sysctl_compact_memory;
diff --git a/mm/huge_memory.c b/mm/huge_memory.c
index 5734d5d5060f..af595df5b65f 100644
index 7e0f72cd9fd4..4410a8b06db3 100644
--- a/mm/huge_memory.c
+++ b/mm/huge_memory.c
@@ -65,7 +65,11 @@ unsigned long transparent_hugepage_flags __read_mostly =
@ -13288,7 +13288,7 @@ index fcd4c1439cb9..e2f7d709e819 100644
EXPORT_SYMBOL_GPL(dirty_writeback_interval);
diff --git a/mm/page_alloc.c b/mm/page_alloc.c
index b6958333054d..5f730fa84e6c 100644
index de65e8b4f75f..ee05f9932c3b 100644
--- a/mm/page_alloc.c
+++ b/mm/page_alloc.c
@@ -271,7 +271,11 @@ const char * const migratetype_names[MIGRATE_TYPES] = {
@ -13570,7 +13570,7 @@ index fe7947f77406..99e138cfdd95 100644
--
2.47.1
From 03450504df5c4fe2d2ba5981aff7a532ab1ebf17 Mon Sep 17 00:00:00 2001
From 7e83775ac56854885575c57878201bb8a61a1377 Mon Sep 17 00:00:00 2001
From: Peter Jung <admin@ptr1337.dev>
Date: Thu, 19 Dec 2024 18:51:01 +0100
Subject: [PATCH 06/12] crypto
@ -15176,7 +15176,7 @@ index bbcff1fb78cb..752812bc4991 100644
--
2.47.1
From 3e7168943409ace243e6d4b10896d6e71b5e0c4d Mon Sep 17 00:00:00 2001
From c6aea0c46173f8802aba928df945ef92dcc20b64 Mon Sep 17 00:00:00 2001
From: Peter Jung <admin@ptr1337.dev>
Date: Thu, 19 Dec 2024 18:51:12 +0100
Subject: [PATCH 07/12] fixes
@ -16131,7 +16131,32 @@ index 192fc75b51e6..d88fc0ca893d 100644
--
2.47.1
From 46225020f04e55a29ae30473a9a8cf0d15f0979e Mon Sep 17 00:00:00 2001
From 50e5354d1e4a5ce9d71bf956e78ab0167b46ae0c Mon Sep 17 00:00:00 2001
From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
Date: Fri, 27 Dec 2024 15:08:09 +0100
Subject: [PATCH] drm/amdgpu: Add missing statement in resume_phase3
Fixes: 73dae652dcac776296890da215ee7dec357a1032
See: https://gitlab.freedesktop.org/drm/amd/-/issues/3853#note_2714815
For: https://gitlab.archlinux.org/archlinux/packaging/packages/linux/-/issues/101
---
drivers/gpu/drm/amd/amdgpu/amdgpu_device.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c
index 51904906545e59..ad4cd84e40f28d 100644
--- a/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c
+++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_device.c
@@ -3723,6 +3723,7 @@ static int amdgpu_device_ip_resume_phase3(struct amdgpu_device *adev)
r = adev->ip_blocks[i].version->funcs->resume(adev);
if (r)
return r;
+ adev->ip_blocks[i].status.hw = true;
}
}
From f520a57069c8c9dab1231a6254a1af4e05a4bebc Mon Sep 17 00:00:00 2001
From: Peter Jung <admin@ptr1337.dev>
Date: Thu, 19 Dec 2024 18:51:57 +0100
Subject: [PATCH 08/12] ntsync
@ -19161,7 +19186,7 @@ index 000000000000..3aad311574c4
--
2.47.1
From 7bb6922864744721217f728cc01dcb53dcdcc2da Mon Sep 17 00:00:00 2001
From 0cc2e53ebfcfab4ce050b958795508582d11c4cb Mon Sep 17 00:00:00 2001
From: Peter Jung <admin@ptr1337.dev>
Date: Thu, 19 Dec 2024 18:52:26 +0100
Subject: [PATCH 09/12] perf-per-core
@ -20158,7 +20183,7 @@ index 2361ed4d2b15..37a9afffb59e 100644
--
2.47.1
From 607312cadf367e1baf1362f85e0568ebae5b6d59 Mon Sep 17 00:00:00 2001
From 4a1c243cf572b60fce8e804577a69e308942a433 Mon Sep 17 00:00:00 2001
From: Peter Jung <admin@ptr1337.dev>
Date: Thu, 19 Dec 2024 18:52:41 +0100
Subject: [PATCH 10/12] pksm
@ -20591,7 +20616,7 @@ index 01071182763e..7394bad8178e 100644
--
2.47.1
From 6b556061a9210594131186c61ecb345ab247923e Mon Sep 17 00:00:00 2001
From 379c5b54fcac5fca5eefd8fe5f3f5d3342b257cf Mon Sep 17 00:00:00 2001
From: Peter Jung <admin@ptr1337.dev>
Date: Thu, 19 Dec 2024 18:53:09 +0100
Subject: [PATCH 11/12] t2
@ -30840,7 +30865,7 @@ index b03d526e4c45..66d09cbec5a8 100755
--
2.47.1
From a7a211a9bf51bfd07e645e8362b40f249d00d13b Mon Sep 17 00:00:00 2001
From ffe6e261d3ee197a08c96468e5f55eab115ae7b9 Mon Sep 17 00:00:00 2001
From: Peter Jung <admin@ptr1337.dev>
Date: Thu, 19 Dec 2024 18:53:34 +0100
Subject: [PATCH 12/12] zstd