update to lunar
This commit is contained in:
parent
1dd6e2d5c4
commit
c48efc6bef
43
.github/workflows/release.yml
vendored
Normal file
43
.github/workflows/release.yml
vendored
Normal file
@ -0,0 +1,43 @@
|
||||
name: PikaOS Package Release
|
||||
|
||||
on:
|
||||
workflow_dispatch
|
||||
|
||||
jobs:
|
||||
build:
|
||||
runs-on: self-hosted
|
||||
container:
|
||||
image: ubuntu:23.04
|
||||
volumes:
|
||||
- /proc:/proc
|
||||
options: --privileged -it
|
||||
|
||||
steps:
|
||||
- uses: actions/checkout@v3
|
||||
|
||||
- name: Install needed packages
|
||||
run: apt update && apt install software-properties-common sudo git bc gpg gpg-agent bison build-essential ccache cpio fakeroot flex git kmod libelf-dev libncurses5-dev libssl-dev lz4 qtbase5-dev rsync schedtool wget zstd tar reprepro dpkg-sig devscripts -y
|
||||
|
||||
- name: Import GPG key
|
||||
id: import_gpg
|
||||
uses: crazy-max/ghaction-import-gpg@v5
|
||||
with:
|
||||
gpg_private_key: ${{ secrets.GPG_PRIVATE_KEY }}
|
||||
passphrase: ${{ secrets.PASSPHRASE }}
|
||||
|
||||
- name: Install SSH key
|
||||
uses: shimataro/ssh-key-action@v2
|
||||
with:
|
||||
key: ${{ secrets.SSH_KEY }}
|
||||
name: id_rsa
|
||||
known_hosts: ${{ secrets.KNOWN_HOSTS }}
|
||||
if_key_exists: replace
|
||||
|
||||
- name: Build Package
|
||||
run: ./main.sh
|
||||
env:
|
||||
GH_TOKEN: ${{ secrets.GITHUB_TOKEN }}
|
||||
|
||||
|
||||
- name: Release Package
|
||||
run: ./release.sh
|
@ -1,3 +1,9 @@
|
||||
obs-gstreamer-vaapi-plugin (0.3.4.git-99pika1-lunar) lunar; urgency=medium
|
||||
|
||||
* Update to lunar
|
||||
|
||||
-- Ward Nakchbandi <hotrod.master@hotmail.com> Sat, 01 Oct 2022 14:50:00 +0200
|
||||
|
||||
obs-gstreamer-vaapi-plugin (0.3.4.git-99pika1) kinetic; urgency=medium
|
||||
|
||||
* Rebrand to PikaOS
|
0
obs-vaapi/debian/compat → debian/compat
vendored
0
obs-vaapi/debian/compat → debian/compat
vendored
0
obs-vaapi/debian/rules → debian/rules
vendored
0
obs-vaapi/debian/rules → debian/rules
vendored
1
debian/source/format
vendored
Normal file
1
debian/source/format
vendored
Normal file
@ -0,0 +1 @@
|
||||
3.0 (native)
|
22
main.sh
Executable file
22
main.sh
Executable file
@ -0,0 +1,22 @@
|
||||
#! /bin/bash
|
||||
set -e
|
||||
# Add dependent repositories
|
||||
wget -q -O - https://ppa.pika-os.com/key.gpg | sudo apt-key add -
|
||||
add-apt-repository https://ppa.pika-os.com
|
||||
add-apt-repository ppa:pikaos/pika
|
||||
add-apt-repository ppa:kubuntu-ppa/backports
|
||||
# Clone Upstream
|
||||
git clone https://github.com/fzwoch/obs-vaapi
|
||||
cp -rvf ./debian ./obs-vaapi/
|
||||
cd ./obs-vaapi
|
||||
|
||||
# Get build deps
|
||||
apt-get build-dep ./ -y
|
||||
|
||||
# Build package
|
||||
dpkg-buildpackage --no-sign
|
||||
|
||||
# Move the debs to output
|
||||
cd ../
|
||||
mkdir -p ./output
|
||||
mv ./*.deb ./output/
|
@ -1,14 +0,0 @@
|
||||
diff -uraN a/obs-vaapi.c b/obs-vaapi.c
|
||||
--- a/obs-vaapi.c 2022-10-14 17:34:42.000000000 +0300
|
||||
+++ b/obs-vaapi.c 2022-10-14 17:54:33.364706110 +0300
|
||||
@@ -26,8 +26,8 @@
|
||||
#include <gst/video/video.h>
|
||||
#include <pci/pci.h>
|
||||
|
||||
-#define ENCODER_TYPE_DATA_H264 "VAAPI H.264"
|
||||
-#define ENCODER_TYPE_DATA_H265 "VAAPI H.265"
|
||||
+#define ENCODER_TYPE_DATA_H264 "GPU: AMD/Intel VAAPI H.264"
|
||||
+#define ENCODER_TYPE_DATA_H265 "GPU: AMD/Intel VAAPI H.265/HEVC"
|
||||
|
||||
OBS_DECLARE_MODULE()
|
||||
|
@ -1 +0,0 @@
|
||||
encoder-rename.patch
|
@ -1 +0,0 @@
|
||||
3.0 (quilt)
|
11
release.sh
Executable file
11
release.sh
Executable file
@ -0,0 +1,11 @@
|
||||
# Sign the packages
|
||||
dpkg-sig --sign builder ./output/*.deb
|
||||
|
||||
# Pull down existing ppa repo db files etc
|
||||
rsync -azP --exclude '*.deb' ferreo@direct.pika-os.com:/srv/www/pikappa/ ./output/repo
|
||||
|
||||
# Add the new package to the repo
|
||||
reprepro -V --basedir ./output/repo/ includedeb lunar ./output/*.deb
|
||||
|
||||
# Push the updated ppa repo to the server
|
||||
rsync -azP ./output/repo/ ferreo@direct.pika-os.com:/srv/www/pikappa/
|
Loading…
Reference in New Issue
Block a user