Update obs studio
Some checks failed
PikaOS Package Build & Release (amd64-v3) / build (push) Failing after 30s
Some checks failed
PikaOS Package Build & Release (amd64-v3) / build (push) Failing after 30s
This commit is contained in:
parent
d949158242
commit
1fee386264
2
.github/release-nest-v3
vendored
2
.github/release-nest-v3
vendored
@ -1 +1 @@
|
|||||||
2
|
3
|
6
debian/changelog
vendored
6
debian/changelog
vendored
@ -1,3 +1,9 @@
|
|||||||
|
obs-studio (1:31.0.1-101pika1) pika; urgency=low
|
||||||
|
|
||||||
|
Update to 31.0.1
|
||||||
|
|
||||||
|
-- Kevin Henkel <obs.goldace@gmail.com> Sat, 04 Feb 2023 12:48:06 +0100
|
||||||
|
|
||||||
obs-studio (1:30.2.1-101pika3) pika; urgency=low
|
obs-studio (1:30.2.1-101pika3) pika; urgency=low
|
||||||
|
|
||||||
Update to 30.2.1
|
Update to 30.2.1
|
||||||
|
2
main.sh
2
main.sh
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
set -e
|
set -e
|
||||||
|
|
||||||
VERSION="30.2.1"
|
VERSION="31.0.1"
|
||||||
|
|
||||||
source ./pika-build-config.sh
|
source ./pika-build-config.sh
|
||||||
|
|
||||||
|
@ -1,33 +1,34 @@
|
|||||||
--- a/libobs/CMakeLists.txt
|
--- a/libobs/CMakeLists.txt
|
||||||
+++ b/libobs/CMakeLists.txt
|
+++ b/libobs/CMakeLists.txt
|
||||||
@@ -145,24 +145,6 @@ target_sources(
|
@@ -138,25 +138,6 @@ target_sources(
|
||||||
target_sources(
|
target_sources(
|
||||||
libobs
|
libobs
|
||||||
PRIVATE # cmake-format: sortable
|
PRIVATE
|
||||||
- util/simde/check.h
|
- util/simde/check.h
|
||||||
- util/simde/debug-trap.h
|
- util/simde/debug-trap.h
|
||||||
- util/simde/hedley.h
|
- util/simde/hedley.h
|
||||||
- util/simde/simde-align.h
|
- util/simde/simde-align.h
|
||||||
- util/simde/simde-arch.h
|
- util/simde/simde-arch.h
|
||||||
- util/simde/simde-common.h
|
- util/simde/simde-common.h
|
||||||
- util/simde/simde-constify.h
|
- util/simde/simde-constify.h
|
||||||
- util/simde/simde-detect-clang.h
|
- util/simde/simde-detect-clang.h
|
||||||
- util/simde/simde-diagnostic.h
|
- util/simde/simde-diagnostic.h
|
||||||
- util/simde/simde-features.h
|
- util/simde/simde-features.h
|
||||||
- util/simde/simde-math.h
|
- util/simde/simde-math.h
|
||||||
- util/simde/x86/mmx.h
|
- util/simde/x86/mmx.h
|
||||||
- util/simde/x86/sse.h
|
- util/simde/x86/sse.h
|
||||||
- util/simde/x86/sse2.h)
|
- util/simde/x86/sse2.h
|
||||||
|
-)
|
||||||
-
|
-
|
||||||
-target_sources(
|
-target_sources(
|
||||||
- libobs
|
- libobs
|
||||||
- PRIVATE # cmake-format: sortable
|
- PRIVATE
|
||||||
callback/calldata.c
|
callback/calldata.c
|
||||||
callback/calldata.h
|
callback/calldata.h
|
||||||
callback/decl.c
|
callback/decl.c
|
||||||
--- a/libobs/util/sse-intrin.h
|
--- a/libobs/util/sse-intrin.h
|
||||||
+++ b/libobs/util/sse-intrin.h
|
+++ b/libobs/util/sse-intrin.h
|
||||||
@@ -28,6 +28,6 @@
|
@@ -27,6 +27,6 @@
|
||||||
#endif
|
#endif
|
||||||
#define SIMDE_ENABLE_NATIVE_ALIASES
|
#define SIMDE_ENABLE_NATIVE_ALIASES
|
||||||
PRAGMA_WARN_PUSH
|
PRAGMA_WARN_PUSH
|
||||||
@ -35,13 +36,3 @@
|
|||||||
+#include <simde/x86/sse2.h>
|
+#include <simde/x86/sse2.h>
|
||||||
PRAGMA_WARN_POP
|
PRAGMA_WARN_POP
|
||||||
#endif
|
#endif
|
||||||
--- a/cmake/Modules/CompilerConfig.cmake
|
|
||||||
+++ b/cmake/Modules/CompilerConfig.cmake
|
|
||||||
@@ -157,7 +157,6 @@ if(LOWERCASE_CMAKE_SYSTEM_PROCESSOR MATC
|
|
||||||
endif()
|
|
||||||
elseif(LOWERCASE_CMAKE_SYSTEM_PROCESSOR MATCHES "^(powerpc|ppc)64(le)?")
|
|
||||||
set(ARCH_SIMD_DEFINES -DNO_WARN_X86_INTRINSICS)
|
|
||||||
- set(ARCH_SIMD_FLAGS -mvsx)
|
|
||||||
else()
|
|
||||||
if(CMAKE_C_COMPILER_ID MATCHES "^(Apple)?Clang|GNU" OR CMAKE_CXX_COMPILER_ID MATCHES "^(Apple)?Clang|GNU")
|
|
||||||
check_c_compiler_flag("-fopenmp-simd" C_COMPILER_SUPPORTS_OPENMP_SIMD)
|
|
||||||
|
9
patches/02_disable-obs-browser.patch
Normal file
9
patches/02_disable-obs-browser.patch
Normal file
@ -0,0 +1,9 @@
|
|||||||
|
--- /dev/null
|
||||||
|
+++ b/plugins/obs-browser/CMakeLists.txt
|
||||||
|
@@ -0,0 +1,6 @@
|
||||||
|
+project(obs-browser)
|
||||||
|
+
|
||||||
|
+option(
|
||||||
|
+ ENABLE_BROWSER
|
||||||
|
+ "Enable building OBS with browser source plugin (required Chromium Embedded Framework)"
|
||||||
|
+ ${OS_LINUX})
|
@ -1,10 +0,0 @@
|
|||||||
--- a/cmake/Modules/CompilerConfig.cmake
|
|
||||||
+++ b/cmake/Modules/CompilerConfig.cmake
|
|
||||||
@@ -108,7 +108,6 @@ else()
|
|
||||||
- https://github.com/obsproject/obs-studio/issues/8850 for 13.1.1
|
|
||||||
]]
|
|
||||||
add_compile_options(
|
|
||||||
- -Werror
|
|
||||||
-Wextra
|
|
||||||
-Wvla
|
|
||||||
-Wswitch
|
|
11
patches/03_FTBFS-gcc-14-32-bits.patch
Normal file
11
patches/03_FTBFS-gcc-14-32-bits.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- a/libobs-opengl/gl-egl-common.c
|
||||||
|
+++ b/libobs-opengl/gl-egl-common.c
|
||||||
|
@@ -379,7 +379,7 @@ bool gl_egl_query_dmabuf_modifiers_for_f
|
||||||
|
blog(LOG_ERROR, "Unable to load eglQueryDmaBufModifiersEXT");
|
||||||
|
return false;
|
||||||
|
}
|
||||||
|
- if (!query_dmabuf_modifiers(egl_display, drm_format, modifiers, n_modifiers)) {
|
||||||
|
+ if (!query_dmabuf_modifiers(egl_display, drm_format, modifiers, (EGLuint64KHR*)n_modifiers)) {
|
||||||
|
*n_modifiers = 0;
|
||||||
|
*modifiers = NULL;
|
||||||
|
return false;
|
22
patches/472.patch
Normal file
22
patches/472.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
From 79eb41c0a8b8e70adf59a374dc357be3962e7b12 Mon Sep 17 00:00:00 2001
|
||||||
|
From: tytan652 <tytan652@tytanium.xyz>
|
||||||
|
Date: Thu, 30 Jan 2025 19:58:05 +0100
|
||||||
|
Subject: [PATCH] Revert "Enable Qt message loop on Linux"
|
||||||
|
|
||||||
|
This reverts commit 98d94a432264c1754e4dea1501a5ce36b04b1718.
|
||||||
|
---
|
||||||
|
cmake/os-linux.cmake | 2 --
|
||||||
|
1 file changed, 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/cmake/os-linux.cmake b/cmake/os-linux.cmake
|
||||||
|
index d80f9d4ad..7c95a9efe 100644
|
||||||
|
--- a/cmake/os-linux.cmake
|
||||||
|
+++ b/cmake/os-linux.cmake
|
||||||
|
@@ -1,7 +1,5 @@
|
||||||
|
find_package(X11 REQUIRED)
|
||||||
|
|
||||||
|
-target_compile_definitions(obs-browser PRIVATE ENABLE_BROWSER_QT_LOOP)
|
||||||
|
-
|
||||||
|
target_link_libraries(obs-browser PRIVATE CEF::Wrapper CEF::Library X11::X11)
|
||||||
|
set_target_properties(obs-browser PROPERTIES BUILD_RPATH "$ORIGIN/" INSTALL_RPATH "$ORIGIN/")
|
||||||
|
|
@ -1,97 +0,0 @@
|
|||||||
From 11dae1dd5a7600534807e254dfa30c9613779dd7 Mon Sep 17 00:00:00 2001
|
|
||||||
From: GloriousEggroll <gloriouseggroll@gmail.com>
|
|
||||||
Date: Sat, 29 Apr 2023 14:46:16 -0600
|
|
||||||
Subject: [PATCH] encoder rename
|
|
||||||
|
|
||||||
---
|
|
||||||
plugins/obs-ffmpeg/obs-ffmpeg-av1.c | 4 ++--
|
|
||||||
plugins/obs-ffmpeg/obs-ffmpeg-nvenc.c | 4 ++--
|
|
||||||
plugins/obs-x264/obs-x264.c | 2 +-
|
|
||||||
5 files changed, 10 insertions(+), 10 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/plugins/obs-ffmpeg/obs-ffmpeg-av1.c b/plugins/obs-ffmpeg/obs-ffmpeg-av1.c
|
|
||||||
index 0b671ae..681f728 100644
|
|
||||||
--- a/plugins/obs-ffmpeg/obs-ffmpeg-av1.c
|
|
||||||
+++ b/plugins/obs-ffmpeg/obs-ffmpeg-av1.c
|
|
||||||
@@ -41,13 +41,13 @@ struct av1_encoder {
|
|
||||||
static const char *aom_av1_getname(void *unused)
|
|
||||||
{
|
|
||||||
UNUSED_PARAMETER(unused);
|
|
||||||
- return "AOM AV1";
|
|
||||||
+ return "CPU: AOM AV1 (FFmpeg)";
|
|
||||||
}
|
|
||||||
|
|
||||||
static const char *svt_av1_getname(void *unused)
|
|
||||||
{
|
|
||||||
UNUSED_PARAMETER(unused);
|
|
||||||
- return "SVT-AV1";
|
|
||||||
+ return "CPU: SVT-AV1 (FFmpeg)";
|
|
||||||
}
|
|
||||||
|
|
||||||
static void av1_video_info(void *data, struct video_scale_info *info)
|
|
||||||
diff --git a/plugins/obs-ffmpeg/obs-ffmpeg-nvenc.c b/plugins/obs-ffmpeg/obs-ffmpeg-nvenc.c
|
|
||||||
index 8cd8138..add8e02 100644
|
|
||||||
--- a/plugins/obs-ffmpeg/obs-ffmpeg-nvenc.c
|
|
||||||
+++ b/plugins/obs-ffmpeg/obs-ffmpeg-nvenc.c
|
|
||||||
@@ -45,7 +45,7 @@ struct nvenc_encoder {
|
|
||||||
extern bool ubuntu_20_04_nvenc_fallback;
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-#define ENCODER_NAME_H264 "NVIDIA NVENC H.264 (FFmpeg)"
|
|
||||||
+#define ENCODER_NAME_H264 "GPU: NVIDIA NVENC H.264 (FFmpeg)"
|
|
||||||
static const char *h264_nvenc_getname(void *unused)
|
|
||||||
{
|
|
||||||
UNUSED_PARAMETER(unused);
|
|
||||||
@@ -53,7 +53,7 @@ static const char *h264_nvenc_getname(void *unused)
|
|
||||||
}
|
|
||||||
|
|
||||||
#ifdef ENABLE_HEVC
|
|
||||||
-#define ENCODER_NAME_HEVC "NVIDIA NVENC HEVC (FFmpeg)"
|
|
||||||
+#define ENCODER_NAME_HEVC "GPU: NVIDIA NVENC H.265/HEVC (FFmpeg)"
|
|
||||||
static const char *hevc_nvenc_getname(void *unused)
|
|
||||||
{
|
|
||||||
UNUSED_PARAMETER(unused);
|
|
||||||
diff --git a/plugins/obs-x264/obs-x264.c b/plugins/obs-x264/obs-x264.c
|
|
||||||
index 1de88d3..d4c377d 100644
|
|
||||||
--- a/plugins/obs-x264/obs-x264.c
|
|
||||||
+++ b/plugins/obs-x264/obs-x264.c
|
|
||||||
@@ -68,7 +68,7 @@ struct obs_x264 {
|
|
||||||
static const char *obs_x264_getname(void *unused)
|
|
||||||
{
|
|
||||||
UNUSED_PARAMETER(unused);
|
|
||||||
- return "x264";
|
|
||||||
+ return "CPU: x264";
|
|
||||||
}
|
|
||||||
|
|
||||||
static void obs_x264_stop(void *data);
|
|
||||||
diff --git a/plugins/obs-ffmpeg/obs-ffmpeg-vaapi.c b/plugins/obs-ffmpeg/obs-ffmpeg-vaapi.c
|
|
||||||
index 370f9b7..e0bbd82 100644
|
|
||||||
--- a/plugins/obs-ffmpeg/obs-ffmpeg-vaapi.c
|
|
||||||
+++ b/plugins/obs-ffmpeg/obs-ffmpeg-vaapi.c
|
|
||||||
@@ -89,20 +89,20 @@ struct vaapi_encoder {
|
|
||||||
static const char *h264_vaapi_getname(void *unused)
|
|
||||||
{
|
|
||||||
UNUSED_PARAMETER(unused);
|
|
||||||
- return "FFmpeg VAAPI H.264";
|
|
||||||
+ return "GPU: AMD/Intel VAAPI H.264 (FFmpeg)";
|
|
||||||
}
|
|
||||||
|
|
||||||
static const char *av1_vaapi_getname(void *unused)
|
|
||||||
{
|
|
||||||
UNUSED_PARAMETER(unused);
|
|
||||||
- return "FFmpeg VAAPI AV1";
|
|
||||||
+ return "GPU: AMD/Intel VAAPI AV1 (FFmpeg)";
|
|
||||||
}
|
|
||||||
|
|
||||||
#ifdef ENABLE_HEVC
|
|
||||||
static const char *hevc_vaapi_getname(void *unused)
|
|
||||||
{
|
|
||||||
UNUSED_PARAMETER(unused);
|
|
||||||
- return "FFmpeg VAAPI HEVC";
|
|
||||||
+ return "GPU: AMD/Intel VAAPI H.265/HEVC (FFmpeg)";
|
|
||||||
}
|
|
||||||
#endif
|
|
||||||
|
|
||||||
--
|
|
||||||
2.40.0
|
|
||||||
|
|
35
patches/obs-studio-UI-use-fdk-aac-by-default.patch
Normal file
35
patches/obs-studio-UI-use-fdk-aac-by-default.patch
Normal file
@ -0,0 +1,35 @@
|
|||||||
|
From f5177e740846c074e0e2f7aae04a19190e6cbda8 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Neal Gompa <neal@gompa.dev>
|
||||||
|
Date: Thu, 4 May 2023 13:52:01 -0400
|
||||||
|
Subject: [PATCH] UI: Default to fdk-aac for AAC when auto-configuring settings
|
||||||
|
|
||||||
|
We always have the FDK-AAC codec available, and it's a better
|
||||||
|
codec anyway.
|
||||||
|
---
|
||||||
|
UI/window-basic-auto-config-test.cpp | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/UI/window-basic-auto-config-test.cpp b/UI/window-basic-auto-config-test.cpp
|
||||||
|
index 5b5051919..9c4769e0a 100644
|
||||||
|
--- a/UI/window-basic-auto-config-test.cpp
|
||||||
|
+++ b/UI/window-basic-auto-config-test.cpp
|
||||||
|
@@ -194,7 +194,7 @@ void AutoConfigTestPage::TestBandwidthThread()
|
||||||
|
|
||||||
|
OBSEncoderAutoRelease vencoder = obs_video_encoder_create((wiz->x264Available ? "obs_x264" : "ffmpeg_openh264"),
|
||||||
|
"test_h264", nullptr, nullptr);
|
||||||
|
- OBSEncoderAutoRelease aencoder = obs_audio_encoder_create("ffmpeg_aac", "test_aac", nullptr, 0, nullptr);
|
||||||
|
+ OBSEncoderAutoRelease aencoder = obs_audio_encoder_create("libfdk_aac", "test_aac", nullptr, 0, nullptr);
|
||||||
|
OBSServiceAutoRelease service = obs_service_create(serverType, "test_service", nullptr, nullptr);
|
||||||
|
|
||||||
|
/* -----------------------------------*/
|
||||||
|
@@ -559,7 +559,7 @@ bool AutoConfigTestPage::TestSoftwareEncoding()
|
||||||
|
|
||||||
|
OBSEncoderAutoRelease vencoder = obs_video_encoder_create((wiz->x264Available ? "obs_x264" : "ffmpeg_openh264"),
|
||||||
|
"test_h264", nullptr, nullptr);
|
||||||
|
- OBSEncoderAutoRelease aencoder = obs_audio_encoder_create("ffmpeg_aac", "test_aac", nullptr, 0, nullptr);
|
||||||
|
+ OBSEncoderAutoRelease aencoder = obs_audio_encoder_create("libfdk_aac", "test_aac", nullptr, 0, nullptr);
|
||||||
|
OBSOutputAutoRelease output = obs_output_create("null_output", "null", nullptr, nullptr);
|
||||||
|
|
||||||
|
/* -----------------------------------*/
|
||||||
|
--
|
||||||
|
2.46.2
|
25
patches/obs-studio-fix-incompatible-pointer-type.patch
Normal file
25
patches/obs-studio-fix-incompatible-pointer-type.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From 88286758bfb7dfcf13875db36f2b2b3960497e99 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Neal Gompa <neal@gompa.dev>
|
||||||
|
Date: Sat, 5 Oct 2024 10:57:23 -0400
|
||||||
|
Subject: [PATCH] libobs-opengl: Fix incompatible pointer type error for 32-bit
|
||||||
|
arches
|
||||||
|
|
||||||
|
---
|
||||||
|
libobs-opengl/gl-egl-common.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/libobs-opengl/gl-egl-common.c b/libobs-opengl/gl-egl-common.c
|
||||||
|
index 8854e9d0c..819061ae0 100644
|
||||||
|
--- a/libobs-opengl/gl-egl-common.c
|
||||||
|
+++ b/libobs-opengl/gl-egl-common.c
|
||||||
|
@@ -379,7 +379,7 @@ bool gl_egl_query_dmabuf_modifiers_for_format(EGLDisplay egl_display, uint32_t d
|
||||||
|
blog(LOG_ERROR, "Unable to load eglQueryDmaBufModifiersEXT");
|
||||||
|
return false;
|
||||||
|
}
|
||||||
|
- if (!query_dmabuf_modifiers(egl_display, drm_format, modifiers, n_modifiers)) {
|
||||||
|
+ if (!query_dmabuf_modifiers(egl_display, drm_format, modifiers, (EGLuint64KHR *)n_modifiers)) {
|
||||||
|
*n_modifiers = 0;
|
||||||
|
*modifiers = NULL;
|
||||||
|
return false;
|
||||||
|
--
|
||||||
|
2.46.2
|
@ -1,3 +1,7 @@
|
|||||||
01_use-sysytem-libsimde.patch
|
01_use-sysytem-libsimde.patch
|
||||||
03_FTBFS-Werror.patch
|
02_disable-obs-browser.patch
|
||||||
encoder-rename.patch
|
03_FTBFS-gcc-14-32-bits.patch
|
||||||
|
99_AMF-encoder.patch
|
||||||
|
obs-studio-fix-incompatible-pointer-type.patch
|
||||||
|
obs-studio-UI-use-fdk-aac-by-default.patch
|
||||||
|
472.patch
|
Loading…
x
Reference in New Issue
Block a user