Fix patch application for kernel in debian/rules for amd64 and i386 architectures

This commit is contained in:
ferreo 2024-11-19 08:21:26 +00:00
parent fa2f21518d
commit c6afc93beb
2 changed files with 4 additions and 25 deletions

View File

@ -93,26 +93,3 @@ index 8cb94219..16f0d13e 100644
--
2.47.0
Signed-off-by: Rahul Rameshbabu <rrameshbabu@nvidia.com>
---
kernel-open/nvidia-drm/nvidia-drm-drv.c | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/kernel/nvidia-drm/nvidia-drm-drv.c b/kernel/nvidia-drm/nvidia-drm-drv.c
index 8cb94219..16f0d13e 100644
--- a/kernel/nvidia-drm/nvidia-drm-drv.c
+++ b/kernel/nvidia-drm/nvidia-drm-drv.c
@@ -1711,6 +1711,10 @@ static const struct file_operations nv_drm_fops = {
.read = drm_read,
.llseek = noop_llseek,
+
+#if defined(FOP_UNSIGNED_OFFSET)
+ .fop_flags = FOP_UNSIGNED_OFFSET,
+#endif
};
static const struct drm_ioctl_desc nv_drm_ioctls[] = {
--
2.47.0

View File

@ -18,7 +18,8 @@ ifeq (amd64,$(DEB_HOST_ARCH))
# Extract all manpages
gunzip debian/tmp/*.1.gz -k
# Apply the patch from debian/patches/0001.patch
patch -p1 debian/tmp < debian/tmp/patches/0001.patch
patch -Np2 -i debian/tmp/patches/0001.patch -d debian/tmp/kernel
patch -Np2 -i debian/tmp/patches/0001.patch -d debian/tmp/kernel-open
# NVENC/NvFBC
sed -i 's/\xe8\x35\x3e\xfe\xff\x85\xc0\x41\x89\xc4/\xe8\x35\x3e\xfe\xff\x29\xc0\x41\x89\xc4/g' "debian/tmp/libnvidia-encode.so.565.57.01"
sed -i 's/\x85\xc0\x0f\x84\x9b\x00\x00\x00\x48/\x85\xc0\x90\x90\x90\x90\x90\x90\x48/g' "debian/tmp/libnvidia-fbc.so.565.57.01"
@ -32,7 +33,8 @@ ifeq (i386,$(DEB_HOST_ARCH))
# Copy installer contents into debian temp dir
cp -rf ./NVIDIA-Linux-*/* debian/tmp
# Apply the patch from debian/patches/0001.patch
patch -p1 debian/tmp < debian/tmp/patches/0001.patch
patch -Np2 -i debian/tmp/patches/0001.patch -d debian/tmp/kernel
patch -Np2 -i debian/tmp/patches/0001.patch -d debian/tmp/kernel-open
# Replace libs with 32 bit
rm -rf debian/tmp/*.so*
cp -rf ./NVIDIA-Linux-*/32/* debian/tmp