Last fix please
This commit is contained in:
parent
a266999390
commit
d8aa90fb43
2
.github/build-nest-v3
vendored
2
.github/build-nest-v3
vendored
@ -1 +1 @@
|
||||
1
|
||||
2
|
@ -1,25 +0,0 @@
|
||||
From ca61ee8197185b9db1d1f1d61460c60a0933eeb3 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Jung <admin@ptr1337.dev>
|
||||
Date: Fri, 18 Oct 2024 22:40:58 +0200
|
||||
Subject: [PATCH 3/6] Add IBT support
|
||||
|
||||
Signed-off-by: Peter Jung <admin@ptr1337.dev>
|
||||
---
|
||||
src/nvidia-modeset/Makefile | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/nvidia-modeset/Makefile b/src/nvidia-modeset/Makefile
|
||||
index 2b96f3fa..ed934014 100644
|
||||
--- a/src/nvidia-modeset/Makefile
|
||||
+++ b/src/nvidia-modeset/Makefile
|
||||
@@ -151,6 +151,7 @@ ifeq ($(TARGET_ARCH),x86_64)
|
||||
CONDITIONAL_CFLAGS += $(call TEST_CC_ARG, -fno-jump-tables)
|
||||
CONDITIONAL_CFLAGS += $(call TEST_CC_ARG, -mindirect-branch=thunk-extern)
|
||||
CONDITIONAL_CFLAGS += $(call TEST_CC_ARG, -mindirect-branch-register)
|
||||
+ CONDITIONAL_CFLAGS += $(call TEST_CC_ARG, -mharden-sls=all)
|
||||
endif
|
||||
|
||||
CFLAGS += $(CONDITIONAL_CFLAGS)
|
||||
--
|
||||
2.47.0
|
||||
|
@ -25,10 +25,6 @@ ifeq (amd64,$(DEB_HOST_ARCH))
|
||||
patch -Np2 -i $(CURDIR)/debian/patches/0001-Make-modeset-and-fbdev-default-enabled.patch -d $(CURDIR)/debian/tmp/kernel
|
||||
patch -Np2 -i $(CURDIR)/debian/patches/0001-Make-modeset-and-fbdev-default-enabled.patch -d $(CURDIR)/debian/tmp/kernel-open
|
||||
|
||||
# Fix for https://bugs.archlinux.org/task/74886
|
||||
patch -Np2 -i $(CURDIR)/debian/patches/0003-Add-IBT-Support.patch -d $(CURDIR)/debian/tmp/kernel
|
||||
patch -Np2 -i $(CURDIR)/debian/patches/0003-Add-IBT-Support.patch -d $(CURDIR)/debian/tmp/kernel-open
|
||||
|
||||
# Fix build errors on 6.13+
|
||||
# https://github.com/NVIDIA/open-gpu-kernel-modules/issues/746
|
||||
patch -Np2 -i $(CURDIR)/debian/patches/0006-crypto-Add-fix-for-6.13-Module-compilation.patch -d $(CURDIR)/debian/tmp/kernel
|
||||
|
Loading…
x
Reference in New Issue
Block a user