swayosd/debian/rules
Ward from fusion-voyager-3 75d94f36ee
All checks were successful
PikaOS Package Build & Release (Canary) (amd64-v3) / build (push) Successful in 1m36s
port to pika os 4
2024-07-27 00:07:28 +03:00

16 lines
405 B
Makefile
Executable File

#! /usr/bin/make -f
export PIKA_BUILD_ARCH = $(shell cat ../pika-build-arch)
override_dh_prep:
# amd64 build prep
ifeq (amd64-v3,$(PIKA_BUILD_ARCH))
# Does not support LTO due to dylib-lto
#export RUSTFLAGS = -C target-cpu=x86-64-v3 -C lto=fat -C embed-bitcode -C codegen-units=1 -C opt-level=3 -Zdylib-lto
export RUSTFLAGS = -C target-cpu=x86-64-v3 -C opt-level=3
endif
%:
dh $@ --buildsystem=meson