xdg-desktop-portal-hyprland/debian/rules
2024-08-24 21:05:19 +02:00

21 lines
677 B
Makefile
Executable File

#! /usr/bin/make -f
## See debhelper(7) (uncomment to enable).
## Output every command that modifies files on the build system.
export DH_VERBOSE = 1
## overriding dh_auto_configure to add custom configs:
override_dh_auto_configure:
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_LIBEXECDIR=/usr/lib -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu -B build
cmake --build build --config Release --target all
override_dh_install:
DESTDIR=debian/tmp cmake --install build
rm -rfv debian/xdg-desktop-portal-hyprland/usr/lib/*/pkgconfig/hyprland-protocols.pc
dh_install
## === End end of region ===
## This here will start the build:
%:
dh $@